summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-02-20 16:14:53 +0000
committerMatthew Smith <matthew@gentoo.org>2023-02-20 16:15:35 +0000
commitc23ab12438ae3a329ba70a674f7fff87ad843901 (patch)
tree206f1881e61a4deee2c1c9ca73089d625dccbd9b /net-misc/xmrig
parentnet-im/zoom: Add /opt/zoom/Qt/lib to library path (diff)
downloadgentoo-c23ab12438ae3a329ba70a674f7fff87ad843901.tar.gz
gentoo-c23ab12438ae3a329ba70a674f7fff87ad843901.tar.bz2
gentoo-c23ab12438ae3a329ba70a674f7fff87ad843901.zip
net-misc/xmrig: fix build with gcc 13
Closes: https://bugs.gentoo.org/895226 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-misc/xmrig')
-rw-r--r--net-misc/xmrig/files/xmrig-6.18.1-gcc-13.patch70
-rw-r--r--net-misc/xmrig/xmrig-6.18.1-r1.ebuild (renamed from net-misc/xmrig/xmrig-6.18.1.ebuild)3
-rw-r--r--net-misc/xmrig/xmrig-6.19.0-r1.ebuild (renamed from net-misc/xmrig/xmrig-6.19.0.ebuild)1
-rw-r--r--net-misc/xmrig/xmrig-9999.ebuild3
4 files changed, 75 insertions, 2 deletions
diff --git a/net-misc/xmrig/files/xmrig-6.18.1-gcc-13.patch b/net-misc/xmrig/files/xmrig-6.18.1-gcc-13.patch
new file mode 100644
index 000000000000..1726c3b01523
--- /dev/null
+++ b/net-misc/xmrig/files/xmrig-6.18.1-gcc-13.patch
@@ -0,0 +1,70 @@
+From bd14e6034ba2de0056278c3ad9923199b7f4d20f Mon Sep 17 00:00:00 2001
+From: Matthew Smith <matthew@gentoo.org>
+Date: Mon, 20 Feb 2023 16:09:19 +0000
+Subject: [PATCH] Fix build with gcc 13
+
+Now some header files are not included transistively with new
+libstdc++.
+
+Bug: https://bugs.gentoo.org/895226
+--- a/src/backend/opencl/runners/OclBaseRunner.cpp
++++ b/src/backend/opencl/runners/OclBaseRunner.cpp
+@@ -23,6 +23,9 @@
+ */
+
+
++#include <stdexcept>
++
++
+ #include "backend/opencl/runners/OclBaseRunner.h"
+ #include "backend/opencl/cl/OclSource.h"
+ #include "backend/opencl/OclCache.h"
+--- a/src/backend/opencl/runners/OclCnRunner.cpp
++++ b/src/backend/opencl/runners/OclCnRunner.cpp
+@@ -16,6 +16,9 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include <stdexcept>
++
++
+ #include "backend/opencl/runners/OclCnRunner.h"
+ #include "backend/opencl/kernels/Cn0Kernel.h"
+ #include "backend/opencl/kernels/Cn1Kernel.h"
+--- a/src/backend/opencl/runners/OclKawPowRunner.cpp
++++ b/src/backend/opencl/runners/OclKawPowRunner.cpp
+@@ -16,6 +16,9 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include <stdexcept>
++
++
+ #include "backend/opencl/runners/OclKawPowRunner.h"
+ #include "backend/common/Tags.h"
+ #include "3rdparty/libethash/ethash_internal.h"
+--- a/src/backend/opencl/runners/OclRxJitRunner.cpp
++++ b/src/backend/opencl/runners/OclRxJitRunner.cpp
+@@ -16,6 +16,9 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include <stdexcept>
++
++
+ #include "backend/opencl/runners/OclRxJitRunner.h"
+ #include "backend/opencl/cl/rx/randomx_run_gfx803.h"
+ #include "backend/opencl/cl/rx/randomx_run_gfx900.h"
+--- a/src/base/net/http/HttpResponse.h
++++ b/src/base/net/http/HttpResponse.h
+@@ -21,6 +21,7 @@
+ #define XMRIG_HTTPRESPONSE_H
+
+
++#include <cstdint>
+ #include <map>
+ #include <string>
+
+--
+2.39.2
+
diff --git a/net-misc/xmrig/xmrig-6.18.1.ebuild b/net-misc/xmrig/xmrig-6.18.1-r1.ebuild
index 0f1d09c1b7a9..89809b2e8627 100644
--- a/net-misc/xmrig/xmrig-6.18.1.ebuild
+++ b/net-misc/xmrig/xmrig-6.18.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -33,6 +33,7 @@ RDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-6.12.2-nonotls.patch
+ "${FILESDIR}"/${PN}-6.18.1-gcc-13.patch
)
src_prepare() {
diff --git a/net-misc/xmrig/xmrig-6.19.0.ebuild b/net-misc/xmrig/xmrig-6.19.0-r1.ebuild
index 7f9e7dd2397c..7a4ceae89308 100644
--- a/net-misc/xmrig/xmrig-6.19.0.ebuild
+++ b/net-misc/xmrig/xmrig-6.19.0-r1.ebuild
@@ -33,6 +33,7 @@ RDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-6.12.2-nonotls.patch
+ "${FILESDIR}"/${PN}-6.18.1-gcc-13.patch
)
src_prepare() {
diff --git a/net-misc/xmrig/xmrig-9999.ebuild b/net-misc/xmrig/xmrig-9999.ebuild
index 5e038e700270..7a4ceae89308 100644
--- a/net-misc/xmrig/xmrig-9999.ebuild
+++ b/net-misc/xmrig/xmrig-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -33,6 +33,7 @@ RDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-6.12.2-nonotls.patch
+ "${FILESDIR}"/${PN}-6.18.1-gcc-13.patch
)
src_prepare() {