summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/uftp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/uftp')
-rw-r--r--net-misc/uftp/Manifest2
-rw-r--r--net-misc/uftp/files/logrotate16
-rw-r--r--net-misc/uftp/files/uftp-3.7_makefile.patch79
-rw-r--r--net-misc/uftp/files/uftpd.conf8
-rw-r--r--net-misc/uftp/files/uftpd.init24
-rw-r--r--net-misc/uftp/files/uftpproxyd.conf5
-rw-r--r--net-misc/uftp/files/uftpproxyd.init24
-rw-r--r--net-misc/uftp/metadata.xml12
-rw-r--r--net-misc/uftp/uftp-3.7.1.ebuild46
-rw-r--r--net-misc/uftp/uftp-3.7.ebuild46
10 files changed, 262 insertions, 0 deletions
diff --git a/net-misc/uftp/Manifest b/net-misc/uftp/Manifest
new file mode 100644
index 000000000000..c2e1e3a63727
--- /dev/null
+++ b/net-misc/uftp/Manifest
@@ -0,0 +1,2 @@
+DIST uftp-3.7.1.tar 849920 SHA256 9010317b53b68dc67408077d56d02becbe2e2a1027d4d27df5378c99fee27433 SHA512 93fefe1d4c5310bfa6470a78011e63aea8cc9cf59a73ea24920d3ad8c835476bbc410b3669ee79c847eba7d21d61f600e09529d5e6f2ed24076f663a34d99c15 WHIRLPOOL 7a4cbd8092ef1439ea4c11b96c5eb2504968f689f0a099208e0a0ba066e72394aa5fcbfb6ca9b9f382702b9631fc27cf80293f13d5e07d8b08818d39a371b1c9
+DIST uftp-3.7.tar 849920 SHA256 c5da4236e57dc152bc8dbb27110a4f504c2525ec079fa285c4f9309a798eca26 SHA512 8e154ea196b34995bc3831c375237a4d98f0627ca79fb6714b66763f64748810e5151efdc40773044a127a0e875ffcc8b985e6f7babd359ae38280a219c4d610 WHIRLPOOL 0a46c5588027ce67777fdfec3b45a27d97c4b95c9cbba9ebdb7704cee5d28b2db29e499ae1f3fcb5d29dec99ec54ade86a1bcaa5f5b8abc178e38768d910ab8d
diff --git a/net-misc/uftp/files/logrotate b/net-misc/uftp/files/logrotate
new file mode 100644
index 000000000000..8dd18f7c2aa9
--- /dev/null
+++ b/net-misc/uftp/files/logrotate
@@ -0,0 +1,16 @@
+#
+# /etc/logrotate.d/uftpd
+#
+/var/log/uftpd.log {
+ daily
+ rotate 5
+ notifempty
+ missingok
+}
+
+/var/log/uftpproxyd.log {
+ daily
+ rotate 5
+ notifempty
+ missingok
+}
diff --git a/net-misc/uftp/files/uftp-3.7_makefile.patch b/net-misc/uftp/files/uftp-3.7_makefile.patch
new file mode 100644
index 000000000000..81afe8b9baae
--- /dev/null
+++ b/net-misc/uftp/files/uftp-3.7_makefile.patch
@@ -0,0 +1,79 @@
+diff -Nuar uftp-3.7.orig//makefile uftp-3.7/makefile
+--- uftp-3.7.orig//makefile 2012-08-10 17:00:22.566403478 +0600
++++ uftp-3.7/makefile 2012-08-10 17:04:47.523386683 +0600
+@@ -39,25 +39,26 @@
+ endif
+
+ # defaults
+-CC = gcc
+-OPTIONS=-g -Wall $(ENC_OPTS)
++CC ?= gcc
++OPTIONS=$(ENC_OPTS)
+ LDLIBS=-lc -lm $(CRYPT_LIB)
+-CFLAGS=
++CFLAGS?=
++LDFLAGS?=
+
+ # FreeBSD
+ ifeq ("FreeBSD", "$(UNAME_S)")
+-OPTIONS=-g -Wall -DHAS_GETIFADDRS $(ENC_OPTS)
++OPTIONS=-DHAS_GETIFADDRS $(ENC_OPTS)
+ endif
+
+ # OSX, aka Darwin
+ ifeq ("Darwin", "$(UNAME_S)")
+-OPTIONS=-g -Wall -DHAS_GETIFADDRS $(ENC_OPTS)
++OPTIONS=-DHAS_GETIFADDRS $(ENC_OPTS)
+ endif
+
+ # Sun
+ ifeq ("SunOS", "$(UNAME_S)")
+-CC = cc
+-OPTIONS=-g -DBSD_COMP $(ENC_OPTS)
++CC ?= cc
++OPTIONS=-DBSD_COMP $(ENC_OPTS)
+ LDLIBS=-lnsl -lsocket -lm $(CRYPT_LIB)
+ CFLAGS=`getconf LFS_CFLAGS`
+ OPENSSL=/usr/sfw
+@@ -65,9 +66,9 @@
+
+ # Linux
+ ifeq ("Linux", "$(UNAME_S)")
+-OPTIONS=-g -Wall -DHAS_GETIFADDRS $(ENC_OPTS)
++OPTIONS=-DHAS_GETIFADDRS $(ENC_OPTS)
+ LDLIBS=-lm $(CRYPT_LIB)
+-CFLAGS=`getconf LFS_CFLAGS`
++CFLAGS?=`getconf LFS_CFLAGS`
+ endif
+
+ ifdef OPENSSL
+@@ -82,7 +83,7 @@
+ testclient_multi.o: testclient_multi.c uftp.h uftp_common.h encryption.h
+
+ testclient_multi: testclient_multi.o encrypt_openssl.o uftp_common.o
+- $(CC) $(OPTIONS) $(LIB) -o $@ $^ $(LDLIBS)
++ $(CC) $(OPTIONS) $(LIB) -o $@ $^ $(LDLIBS) $(LDFLAGS)
+
+ clean:
+ rm -f testclient_multi uftp uftpd uftpproxyd uftp_keymgt *.o
+@@ -176,16 +177,16 @@
+ endif
+
+ uftp: $(UFTP_OBJS)
+- $(CC) $(OPTIONS) $(LIB) -o $@ $^ $(LDLIBS)
++ $(CC) $(OPTIONS) $(LIB) -o $@ $^ $(LDLIBS) $(LDFLAGS)
+
+ uftpd: $(UFTPD_OBJS)
+- $(CC) $(OPTIONS) $(LIB) -o $@ $^ $(LDLIBS)
++ $(CC) $(OPTIONS) $(LIB) -o $@ $^ $(LDLIBS) $(LDFLAGS)
+
+ uftpproxyd: $(UFTPPROXYD_OBJS)
+- $(CC) $(OPTIONS) $(LIB) -o $@ $^ $(LDLIBS)
++ $(CC) $(OPTIONS) $(LIB) -o $@ $^ $(LDLIBS) $(LDFLAGS)
+
+ uftp_keymgt: $(UFTP_KEYMGT_OBJS)
+- $(CC) $(OPTIONS) $(LIB) -o $@ $^ $(LDLIBS)
++ $(CC) $(OPTIONS) $(LIB) -o $@ $^ $(LDLIBS) $(LDFLAGS)
+
+ %.o: %.c
+ $(CC) $(OPTIONS) $(INCLUDE) $(CFLAGS) -c $<
diff --git a/net-misc/uftp/files/uftpd.conf b/net-misc/uftp/files/uftpd.conf
new file mode 100644
index 000000000000..c38336c54bdc
--- /dev/null
+++ b/net-misc/uftp/files/uftpd.conf
@@ -0,0 +1,8 @@
+# conf.d file for uftpd
+
+# Destionation dir for downloaded files
+UFTPD_DIR="/tmp"
+
+# Options to pass to the uftpd process
+# For more info see man utfpd(1)
+UFTPD_OPTS=""
diff --git a/net-misc/uftp/files/uftpd.init b/net-misc/uftp/files/uftpd.init
new file mode 100644
index 000000000000..e2d6a22bc259
--- /dev/null
+++ b/net-misc/uftp/files/uftpd.init
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+PROGRAM=/usr/sbin/uftpd
+PIDFILE=/var/run/uftpd.pid
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting uftpd"
+ start-stop-daemon --start --exec ${PROGRAM} -- \
+ -L /var/log/uftpd.log -P ${PIDFILE} -D ${UFTPD_DIR} ${UFTPD_OPTS}
+ eend $? "Failed to start uftpd"
+}
+
+stop() {
+ ebegin "Stopping uftpd"
+ start-stop-daemon --stop --exec ${PROGRAM} -p ${PIDFILE}
+ eend $? "Failed to stop uftpd"
+}
diff --git a/net-misc/uftp/files/uftpproxyd.conf b/net-misc/uftp/files/uftpproxyd.conf
new file mode 100644
index 000000000000..37c094d7d7ba
--- /dev/null
+++ b/net-misc/uftp/files/uftpproxyd.conf
@@ -0,0 +1,5 @@
+# conf.d file for uftpd
+
+# Options to pass to the uftpd process
+# For more info see man utfpproxyd(1)
+UFTPPROXYD_OPTS=""
diff --git a/net-misc/uftp/files/uftpproxyd.init b/net-misc/uftp/files/uftpproxyd.init
new file mode 100644
index 000000000000..856226b3e3ea
--- /dev/null
+++ b/net-misc/uftp/files/uftpproxyd.init
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+PROGRAM=/usr/sbin/uftpproxyd
+PIDFILE=/var/run/uftpproxyd.pid
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting uftpd"
+ start-stop-daemon --start --exec ${PROGRAM} -- \
+ -L /var/log/uftpproxyd.log -P ${PIDFILE} ${UFTPPROXYD_OPTS}
+ eend $? "Failed to start uftpd"
+}
+
+stop() {
+ ebegin "Stopping uftpd"
+ start-stop-daemon --stop --exec ${PROGRAM} -p ${PIDFILE}
+ eend $? "Failed to stop uftpd"
+}
diff --git a/net-misc/uftp/metadata.xml b/net-misc/uftp/metadata.xml
new file mode 100644
index 000000000000..e172f68d2263
--- /dev/null
+++ b/net-misc/uftp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>azamat.hackimov@gmail.com</email>
+ <name>Azamat Hackimov</name>
+</maintainer>
+<use>
+ <flag name="server">Install uftp server daemon</flag>
+</use>
+</pkgmetadata>
diff --git a/net-misc/uftp/uftp-3.7.1.ebuild b/net-misc/uftp/uftp-3.7.1.ebuild
new file mode 100644
index 000000000000..b3fea778f0f3
--- /dev/null
+++ b/net-misc/uftp/uftp-3.7.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Encrypted UDP based FTP with multicast"
+HOMEPAGE="http://www.tcnj.edu/~bush/uftp.html"
+SRC_URI="http://www.tcnj.edu/~bush/downloads/${P}.tar"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+server ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.7_makefile.patch"
+}
+
+src_compile() {
+ use ssl || local opt="NO_ENCRYPTION=1"
+ emake CC=$(tc-getCC) $opt uftp uftp_keymgt
+ use server && emake CC=$(tc-getCC) $opt uftpd uftpproxyd
+}
+
+src_install() {
+ dobin uftp uftp_keymgt
+ dodoc ReadMe.txt
+ doman uftp.1 uftp_keymgt.1
+
+ if use server ; then
+ dosbin uftpd uftpproxyd
+ newinitd "${FILESDIR}/uftpd.init" uftpd
+ newconfd "${FILESDIR}/uftpd.conf" uftpd
+ newinitd "${FILESDIR}/uftpproxyd.init" uftpproxyd
+ newconfd "${FILESDIR}/uftpproxyd.conf" uftpproxyd
+ doman uftpd.1 uftpproxyd.1
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/logrotate" uftpd
+ fi
+}
diff --git a/net-misc/uftp/uftp-3.7.ebuild b/net-misc/uftp/uftp-3.7.ebuild
new file mode 100644
index 000000000000..779b82a9631c
--- /dev/null
+++ b/net-misc/uftp/uftp-3.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Encrypted UDP based FTP with multicast"
+HOMEPAGE="http://www.tcnj.edu/~bush/uftp.html"
+SRC_URI="http://www.tcnj.edu/~bush/downloads/${P}.tar"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+server ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}_makefile.patch"
+}
+
+src_compile() {
+ use ssl || local opt="NO_ENCRYPTION=1"
+ emake CC=$(tc-getCC) $opt uftp uftp_keymgt
+ use server && emake CC=$(tc-getCC) $opt uftpd uftpproxyd
+}
+
+src_install() {
+ dobin uftp uftp_keymgt
+ dodoc ReadMe.txt
+ doman uftp.1 uftp_keymgt.1
+
+ if use server ; then
+ dosbin uftpd uftpproxyd
+ newinitd "${FILESDIR}/uftpd.init" uftpd
+ newconfd "${FILESDIR}/uftpd.conf" uftpd
+ newinitd "${FILESDIR}/uftpproxyd.init" uftpproxyd
+ newconfd "${FILESDIR}/uftpproxyd.conf" uftpproxyd
+ doman uftpd.1 uftpproxyd.1
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/logrotate" uftpd
+ fi
+}