summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-14 20:44:11 +0100
committerSam James <sam@gentoo.org>2022-08-14 20:49:09 +0100
commit4e5ed953755580feb167672fb76923f1980d3a9e (patch)
treeb543815817dc51368a2b6e7b1189aff2ae3fa7a9 /net-misc/rsync/rsync-9999.ebuild
parentmedia-gfx/imv: set sourcehut remote-id (diff)
downloadgentoo-4e5ed953755580feb167672fb76923f1980d3a9e.tar.gz
gentoo-4e5ed953755580feb167672fb76923f1980d3a9e.tar.bz2
gentoo-4e5ed953755580feb167672fb76923f1980d3a9e.zip
net-misc/rsync: add 3.2.5
Drops USE=ipv6 given it's not a well-tested option anyway (see e.g. https://bugzilla.samba.org/show_bug.cgi?id=10715). IPv6 support is now always enabled. Bug: https://bugs.gentoo.org/862876 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/rsync/rsync-9999.ebuild')
-rw-r--r--net-misc/rsync/rsync-9999.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/net-misc/rsync/rsync-9999.ebuild b/net-misc/rsync/rsync-9999.ebuild
index d172d6ec7259..ab9d689fb713 100644
--- a/net-misc/rsync/rsync-9999.ebuild
+++ b/net-misc/rsync/rsync-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit flag-o-matic prefix python-single-r1 systemd
DESCRIPTION="File transfer program to keep remote files into sync"
@@ -31,7 +31,7 @@ fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="acl examples iconv ipv6 lz4 ssl stunnel system-zlib xattr xxhash zstd"
+IUSE="acl examples iconv lz4 ssl stunnel system-zlib xattr xxhash zstd"
REQUIRED_USE+=" examples? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="acl? ( virtual/acl )
@@ -78,16 +78,12 @@ src_prepare() {
}
src_configure() {
- # Force enable IPv6 on musl - upstream bug:
- # https://bugzilla.samba.org/show_bug.cgi?id=10715
- use elibc_musl && use ipv6 && append-cppflags -DINET6
-
local myeconfargs=(
--with-rsyncd-conf="${EPREFIX}"/etc/rsyncd.conf
--without-included-popt
+ --enable-ipv6
$(use_enable acl acl-support)
$(use_enable iconv)
- $(use_enable ipv6)
$(use_enable lz4)
$(use_enable ssl openssl)
$(use_with !system-zlib included-zlib)