summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov <spiderx@spiderx.dp.ua>2024-08-20 20:02:28 +0300
committerEli Schwartz <eschwartz@gentoo.org>2024-08-22 22:03:14 -0400
commitf8014ba6a6269c7d9cc06135709c9a36891266c0 (patch)
tree7854c71eab93b8d173e33e2f829cad431162b838 /net-misc/pingu
parentdev-lang/zig: drop 0.11.0-r1, 0.12.0 (diff)
downloadgentoo-f8014ba6a6269c7d9cc06135709c9a36891266c0.tar.gz
gentoo-f8014ba6a6269c7d9cc06135709c9a36891266c0.tar.bz2
gentoo-f8014ba6a6269c7d9cc06135709c9a36891266c0.zip
net-misc/pingu: add 1.5.1, wrt 937095
Closes: https://bugs.gentoo.org/937095 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Closes: https://github.com/gentoo/gentoo/pull/38220 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'net-misc/pingu')
-rw-r--r--net-misc/pingu/Manifest1
-rw-r--r--net-misc/pingu/pingu-1.5.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/pingu/Manifest b/net-misc/pingu/Manifest
index dff3f8cd1f88..52284a8b7b55 100644
--- a/net-misc/pingu/Manifest
+++ b/net-misc/pingu/Manifest
@@ -1 +1,2 @@
+DIST pingu-1.5.1.tar.gz 31574 BLAKE2B afc11958aace1a1f87dbd9051f40354f4f0bd77f599d17a4772de8ba2f7d8d7fec0e203c87f354517bf0e29d5238265459a97d950a157316b530a577a989f472 SHA512 1ec50ad5a1cb7318dc6ffb8ab8454f85dda9d31ea13503eaf001109b7255b6e93e165769e9b3c7fd95f2449f079e107f81a974b148b6f00f50f13ee8124d92fb
DIST pingu-1.5.tar.gz 31565 BLAKE2B 13d1fa075f32d5a32cece55c5292cda08f72e711a8567cc8b25ce0e2bb0325395f1346e9feb96eb266c93d10d04609d87562192f7b7d0c22730fd4a8561c6c1a SHA512 71e5fbe93f831f24d168957cdeaff2817a22f407575316d6515755bec760d10724821070549eaab562924237b96976a1a776ca903d5fe0cd9f9b69a38eadd8c9
diff --git a/net-misc/pingu/pingu-1.5.1.ebuild b/net-misc/pingu/pingu-1.5.1.ebuild
new file mode 100644
index 000000000000..73a282c4fac8
--- /dev/null
+++ b/net-misc/pingu/pingu-1.5.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="Policy routing daemon with failover and load-balancing"
+HOMEPAGE="https://github.com/ncopa/pingu"
+SRC_URI="https://github.com/ncopa/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="dev-libs/libev"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-text/asciidoc )"
+
+# Fix QA with install into path /run/pingu must be created at runtime
+PATCHES=( "${FILESDIR}"/"${PN}"-1.5-makefile.patch )
+
+QA_CONFIG_IMPL_DECL_SKIP=( 'strlcpy' )
+
+src_configure() {
+ local myconf=(
+ --prefix=/usr
+ "$(use_enable debug)"
+ "$(use_enable doc)"
+ )
+ edo ./configure "${myconf[@]}"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+
+ newtmpfiles "${FILESDIR}"/pingu.tmpfile pingu.conf
+ newinitd "${FILESDIR}"/pingu.initd pingu
+ newconfd "${FILESDIR}"/pingu.confd pingu
+ systemd_dounit "${FILESDIR}"/pingu.service
+ keepdir /var/lib/pingu
+ insinto /etc/pingu
+ newins pingu.conf pingu.conf.example
+}
+
+pkg_postinst() {
+ tmpfiles_process pingu.conf
+}