summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-08-27 00:51:47 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-08-27 01:41:59 +0200
commit7fb5a706f83c6e9c62d3b1ee12f413677eac9bda (patch)
tree4f9065da184f9cac6c96822c44f283a68201a7e4 /net-misc/ipmiview
parentsys-auth/AusweisApp2: drop 1.26.4, 1.26.5, 1.26.6 (diff)
downloadgentoo-7fb5a706f83c6e9c62d3b1ee12f413677eac9bda.tar.gz
gentoo-7fb5a706f83c6e9c62d3b1ee12f413677eac9bda.tar.bz2
gentoo-7fb5a706f83c6e9c62d3b1ee12f413677eac9bda.zip
net-misc/ipmiview: add 2.21.1.230720
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc/ipmiview')
-rw-r--r--net-misc/ipmiview/Manifest1
-rw-r--r--net-misc/ipmiview/ipmiview-2.21.1.230720.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/net-misc/ipmiview/Manifest b/net-misc/ipmiview/Manifest
index 2a46bec2cd28..63f9e1229420 100644
--- a/net-misc/ipmiview/Manifest
+++ b/net-misc/ipmiview/Manifest
@@ -1 +1,2 @@
DIST IPMIView_2.21.0_build.221118_bundleJRE_Linux_x64.tar.gz 152487572 BLAKE2B 3183a7eb48b476d5ba46d7bbb8e5e9287b5622f92474984c60580c4273fe077526e276d7b849011fd6e9fc2e7c170947ab6dafe64fa47ee1ee9b3c3b74318d3f SHA512 4e21bee8c81acc0afc33df34e10530157a09908957c3aad54b9f51ca71b83e79d1b52a804f18f34fb8bbfaf2574ab7a3b65d0f66495aa27284cd67baa387f737
+DIST IPMIView_2.21.1_build.230720_bundleJRE_Linux_x64.tar.gz 117666196 BLAKE2B 32284883846dc780cd1b613bc34f91d2fa6f4bad144ef7a26f76b78852a81e8adcbcf64a08aff06919f2029c8880b3ca6a8bae0674779139216b55659d3415f2 SHA512 103cc4c12f3ad6a503877db85abd89ad4e0dfdb48d99d30483ab3b97534e7f1729cc94b19ad0ff45c381986807a443d45338df24e7edc41839ed7e718804d46a
diff --git a/net-misc/ipmiview/ipmiview-2.21.1.230720.ebuild b/net-misc/ipmiview/ipmiview-2.21.1.230720.ebuild
new file mode 100644
index 000000000000..6417f07fea8f
--- /dev/null
+++ b/net-misc/ipmiview/ipmiview-2.21.1.230720.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop java-pkg-2 prefix
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="IPMIView"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="A GUI application that allows to manage multiple target systems through BMC"
+HOMEPAGE="https://www.supermicro.com/"
+SRC_URI="https://www.supermicro.com/Bios/sw_download/588/${MY_PN}_${MY_PV}_build.${MY_DATE}_bundleJRE_Linux_x64.tar.gz"
+
+LICENSE="supermicro"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ net-misc/stunnel
+ sys-libs/ncurses-compat:5
+ virtual/jre:1.8
+"
+
+BDEPEND="app-arch/unzip"
+
+RESTRICT="bindist mirror"
+
+DIR="/usr/share/${PN}"
+QA_PREBUILT="usr/lib*"
+
+src_unpack() {
+ unpack ${A}
+ mv -v ${MY_PN}_${MY_PV}_build.${MY_DATE}_bundleJRE_Linux_x64 ${P} || die
+}
+
+src_prepare() {
+ default
+
+ # Extract icons for menu entries
+ unzip -j -LL IPMIView20.jar images/ipmi{view,trap}.ico || die
+
+ # Don't use their scary launchers
+ rm -v lax.jar || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ java-pkg_dojar *.jar
+ java-pkg_doso *64.so
+
+ local pre=$(prefixify_ro "${FILESDIR}"/launcher-pre.bash)
+ java-pkg_dolauncher ipmiview --jar IPMIView20.jar -pre "${pre}"
+ java-pkg_dolauncher ikvm --jar iKVM.jar -pre "${pre}"
+ java-pkg_dolauncher ikvmmicroblade --jar iKVMMicroBlade.jar -pre "${pre}"
+ java-pkg_dolauncher jviewerx9 --jar JViewerX9.jar -pre "${pre}"
+ java-pkg_dolauncher trapreceiver --jar TrapView.jar -pre "${pre}"
+
+ exeinto ${DIR}/jre/bin
+ newexe $(prefixify_ro "${FILESDIR}"/fake-java-r1.bash) java
+
+ insinto ${DIR}/lib/BMCSecurity
+ doins BMCSecurity/*.{crt,key,pem,txt}
+
+ insinto ${DIR}/lib/BMCSecurity/linux
+ doins BMCSecurity/linux/stunnel.conf
+
+ dosym ../../../../../bin/stunnel ${DIR}/lib/BMCSecurity/linux/stunnel32
+ dosym ../../../../../bin/stunnel ${DIR}/lib/BMCSecurity/linux/stunnel64
+
+ doicon ipmi{view,trap}.ico
+ make_desktop_entry ipmiview IPMIView ipmiview.ico
+ make_desktop_entry trapreceiver "Trap Receiver" ipmitrap.ico
+
+ local DOCS=( *.pdf *.txt )
+ einstalldocs
+}