summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-04-24 21:18:14 -0700
committerZac Medico <zmedico@gentoo.org>2019-04-24 21:26:34 -0700
commit0b9196e0375c2e24ad585a05791f585c63598e98 (patch)
treeae9c1f11d69e43afe71635432e2a68e6dcc3e9e6 /net-misc/electron-cash
parentdev-ruby/selenium-webdriver: fix childprocess dependency (diff)
downloadgentoo-0b9196e0375c2e24ad585a05791f585c63598e98.tar.gz
gentoo-0b9196e0375c2e24ad585a05791f585c63598e98.tar.bz2
gentoo-0b9196e0375c2e24ad585a05791f585c63598e98.zip
net-misc/electron-cash: version bump to 3.3.6
Reported-by: Kete Tefid <ketetefid@gmail.com> Closes: https://bugs.gentoo.org/670070 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'net-misc/electron-cash')
-rw-r--r--net-misc/electron-cash/Manifest1
-rw-r--r--net-misc/electron-cash/electron-cash-3.3.6.ebuild151
-rw-r--r--net-misc/electron-cash/files/3.3.6-no-user-root.patch27
3 files changed, 179 insertions, 0 deletions
diff --git a/net-misc/electron-cash/Manifest b/net-misc/electron-cash/Manifest
index 9e516e83c80c..0d7de87b7986 100644
--- a/net-misc/electron-cash/Manifest
+++ b/net-misc/electron-cash/Manifest
@@ -1 +1,2 @@
DIST electron-cash-3.1.3.tar.gz 1643903 BLAKE2B ff7c4f8d10b680c9fe3fcb949349cdbc84acb49939b33af2816f8154c3675241e3637bc326af9c2a662588571aeab37de86eb89a627e934b824114c3907a8158 SHA512 267f434ef09bea23b79a9ad8cb8e734a7e1ece7d17d2e2cc91496af3d0fcb035256ec3977c2fbeff4c7ac16193a0a185041fd526c46129fcea62bcdfe043a208
+DIST electron-cash-3.3.6.tar.gz 8506610 BLAKE2B 85f61ec0c95e41c5fc170c3419317e077c3e871ee90db7f4e7ebbf6e931950746798efe9b4b6e7c6e0992a52165772a699d8220e1a21ff597f024084929afddc SHA512 993829ce29013e26f219bbd41d13c8d399920ee4c1e5fcae3c4fb298c766228766e93b559db1de3c14bd5add6f651c83655afb32bf173bacdaddf83a8a941f18
diff --git a/net-misc/electron-cash/electron-cash-3.3.6.ebuild b/net-misc/electron-cash/electron-cash-3.3.6.ebuild
new file mode 100644
index 000000000000..7c1417f11660
--- /dev/null
+++ b/net-misc/electron-cash/electron-cash-3.3.6.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="ncurses?"
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+MY_P="Electron-Cash-${PV}"
+DESCRIPTION="Lightweight Bitcoin Cash client (BCH fork of Electrum)"
+HOMEPAGE="https://github.com/fyookball/electrum/"
+SRC_URI="https://github.com/fyookball/electrum/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="audio_modem cli cosign digitalbitbox email ncurses qrcode +qt5 sync vkb
+ l10n_es l10n_ja l10n_pt l10n_zh-CN"
+
+REQUIRED_USE="
+ || ( cli ncurses qt5 )
+ audio_modem? ( qt5 )
+ cosign? ( qt5 )
+ digitalbitbox? ( qt5 )
+ email? ( qt5 )
+ qrcode? ( qt5 )
+ sync? ( qt5 )
+ vkb? ( qt5 )
+"
+
+RDEPEND="
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ dev-python/jsonrpclib[${PYTHON_USEDEP}]
+ dev-python/pbkdf2[${PYTHON_USEDEP}]
+ dev-python/pyaes[${PYTHON_USEDEP}]
+ dev-python/PySocks[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/tlslite[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ virtual/python-dnspython[${PYTHON_USEDEP}]
+ qrcode? ( media-gfx/zbar[v4l] )
+ qt5? (
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ )
+ ncurses? ( dev-lang/python )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="RELEASE-NOTES"
+
+src_prepare() {
+ eapply "${FILESDIR}/3.3.6-no-user-root.patch"
+
+ # Prevent icon from being installed in the wrong location
+ sed -i '/icons/d' setup.py || die
+
+ if use qt5; then
+ pyrcc5 icons.qrc -o gui/qt/icons_rc.py || die
+ else
+ sed "s|'electroncash_gui.qt',||" -i setup.py || die
+ fi
+
+ local wordlist=
+ for wordlist in \
+ $(usex l10n_ja '' japanese) \
+ $(usex l10n_pt '' portuguese) \
+ $(usex l10n_es '' spanish) \
+ $(usex l10n_zh-CN '' chinese_simplified) \
+ ; do
+ rm -f "lib/wordlist/${wordlist}.txt" || die
+ sed -i "/${wordlist}\\.txt/d" lib/mnemonic.py || die
+ done
+
+ # Remove unrequested GUI implementations:
+ local gui setup_py_gui
+ for gui in \
+ $(usex cli '' stdio) \
+ kivy \
+ $(usex qt5 '' qt ) \
+ $(usex ncurses '' text ) \
+ ; do
+ rm gui/"${gui}"* -r || die
+ done
+
+ # And install requested ones...
+ for gui in \
+ $(usex qt5 qt '') \
+ ; do
+ setup_py_gui="${setup_py_gui}'electrum_gui.${gui}',"
+ done
+
+ sed -i "s/'electrum_gui\\.qt',/${setup_py_gui}/" setup.py || die
+
+ local bestgui
+ if use qt5; then
+ bestgui=qt
+ elif use ncurses; then
+ bestgui=text
+ else
+ bestgui=stdio
+ fi
+ sed -i 's/^\([[:space:]]*\)\(config_options\['\''cwd'\''\] = .*\)$/\1\2\n\1config_options.setdefault("gui", "'"${bestgui}"'")\n/' "${PN}" || die
+
+ local plugin
+ # trezor requires python trezorlib module
+ # keepkey requires trezor
+ for plugin in \
+ $(usex audio_modem '' audio_modem ) \
+ $(usex cosign '' cosigner_pool ) \
+ $(usex digitalbitbox '' digitalbitbox ) \
+ $(usex email '' email_requests ) \
+ hw_wallet \
+ ledger \
+ keepkey \
+ $(usex sync '' labels ) \
+ trezor \
+ $(usex vkb '' virtualkeyboard ) \
+ ; do
+ rm -r plugins/"${plugin}"* || die
+ sed -i "/${plugin}/d" setup.py || die
+ done
+
+ eapply_user
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ doicon -s 128 icons/${PN}.png
+ distutils-r1_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/net-misc/electron-cash/files/3.3.6-no-user-root.patch b/net-misc/electron-cash/files/3.3.6-no-user-root.patch
new file mode 100644
index 000000000000..f5f0aecf382f
--- /dev/null
+++ b/net-misc/electron-cash/files/3.3.6-no-user-root.patch
@@ -0,0 +1,27 @@
+--- a/setup.py
++++ b/setup.py
+@@ -33,23 +33,7 @@
+ # Use per-user */share directory if the global one is not writable or if a per-user installation
+ # is attempted
+ user_share = os.environ.get('XDG_DATA_HOME', os.path.expanduser('~/.local/share'))
+- system_share = os.path.join(opts.prefix_path, "share")
+- if not opts.is_user:
+- # Not neccarily a per-user installation try system directories
+- if os.access(opts.root_path + system_share, os.W_OK):
+- # Global /usr/share is writable for us – so just use that
+- share_dir = system_share
+- elif not os.path.exists(opts.root_path + system_share) and os.access(opts.root_path, os.W_OK):
+- # Global /usr/share does not exist, but / is writable – keep using the global directory
+- # (happens during packaging)
+- share_dir = system_share
+- else:
+- # Neither /usr/share (nor / if /usr/share doesn't exist) is writable, use the
+- # per-user */share directory
+- share_dir = user_share
+- else:
+- # Per-user installation
+- share_dir = user_share
++ share_dir = os.path.join(opts.prefix_path, "share")
+ data_files += [
+ # Menu icon
+ # Menu entry