summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-02-24 15:48:15 -0600
committerWilliam Hubbs <williamh@gentoo.org>2017-02-24 15:48:46 -0600
commit6a9c88e35749b8b4ef050522cef18840695593a7 (patch)
tree77c7bc2b4f5499777ef47db570782a2186c4a3b2 /net-misc/dhcpcd
parentsys-apps/opentmpfiles: sync live ebuild (diff)
downloadgentoo-6a9c88e35749b8b4ef050522cef18840695593a7.tar.gz
gentoo-6a9c88e35749b8b4ef050522cef18840695593a7.tar.bz2
gentoo-6a9c88e35749b8b4ef050522cef18840695593a7.zip
net-misc/dhcpcd: Change live ebuild to pull from git per upstream request
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/dhcpcd-9999.ebuild28
1 files changed, 3 insertions, 25 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-9999.ebuild b/net-misc/dhcpcd/dhcpcd-9999.ebuild
index f6264d2986fd..cb4cb6fc6ba8 100644
--- a/net-misc/dhcpcd/dhcpcd-9999.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-9999.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
if [[ ${PV} == "9999" ]]; then
- FOSSIL_URI="http://roy.marples.name/projects/dhcpcd"
+ EGIT_REPO_URI="git://roy.marples.name/dhcpcd"
+ inherit git-r3
else
MY_P="${P/_alpha/-alpha}"
MY_P="${MY_P/_beta/-beta}"
@@ -27,29 +28,6 @@ COMMON_DEPEND="udev? ( virtual/udev )"
DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"
-if [[ ${PV} == "9999" ]]; then
- DEPEND+=" dev-vcs/fossil"
-
- src_unpack()
- {
- local distdir=${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}
- local repo=${distdir}/fossil/${PN}.fossil
-
- addwrite "${distdir}"
-
- if [[ -e "${repo}" ]]; then
- fossil pull "${FOSSIL_URI}" -R "${repo}" || die
- else
- mkdir -p "${distdir}/fossil" || die
- fossil clone "${FOSSIL_URI}" "${repo}" || die
- fi
-
- mkdir -p "${S}" || die
- cd "${S}" || die
- fossil open "${repo}" || die
- }
-fi
-
src_configure()
{
local dev hooks rundir