summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2020-11-19 07:49:05 +0100
committerStephan Hartmann <sultan@gentoo.org>2020-11-19 07:49:19 +0100
commit9ba1ad6f344c9552f8f2e6927800e09fe922cf40 (patch)
treef424d78fe2a2a32841d9d91d6bc63d22153b41ce /net-misc/croc/croc-8.6.6.ebuild
parentapp-portage/pfl: Remove old pfl-3.1. (diff)
downloadgentoo-9ba1ad6f344c9552f8f2e6927800e09fe922cf40.tar.gz
gentoo-9ba1ad6f344c9552f8f2e6927800e09fe922cf40.tar.bz2
gentoo-9ba1ad6f344c9552f8f2e6927800e09fe922cf40.zip
net-misc/croc: bump to 8.6.6
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'net-misc/croc/croc-8.6.6.ebuild')
-rw-r--r--net-misc/croc/croc-8.6.6.ebuild143
1 files changed, 143 insertions, 0 deletions
diff --git a/net-misc/croc/croc-8.6.6.ebuild b/net-misc/croc/croc-8.6.6.ebuild
new file mode 100644
index 000000000000..05e2a8b4b366
--- /dev/null
+++ b/net-misc/croc/croc-8.6.6.ebuild
@@ -0,0 +1,143 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module systemd
+
+DESCRIPTION="Easily and securely send things from one computer to another"
+HOMEPAGE="https://github.com/schollz/croc"
+
+EGO_SUM=(
+ "github.com/BurntSushi/toml v0.3.1/go.mod"
+ "github.com/OneOfOne/xxhash v1.2.2/go.mod"
+ "github.com/OneOfOne/xxhash v1.2.5"
+ "github.com/OneOfOne/xxhash v1.2.5/go.mod"
+ "github.com/cespare/xxhash v1.1.0"
+ "github.com/cespare/xxhash v1.1.0/go.mod"
+ "github.com/cpuguy83/go-md2man/v2 v2.0.0-20190314233015-f79a8a8ca69d/go.mod"
+ "github.com/cpuguy83/go-md2man/v2 v2.0.0"
+ "github.com/cpuguy83/go-md2man/v2 v2.0.0/go.mod"
+ "github.com/davecgh/go-spew v1.1.0/go.mod"
+ "github.com/davecgh/go-spew v1.1.1"
+ "github.com/davecgh/go-spew v1.1.1/go.mod"
+ "github.com/denisbrodbeck/machineid v1.0.1"
+ "github.com/denisbrodbeck/machineid v1.0.1/go.mod"
+ "github.com/k0kubun/go-ansi v0.0.0-20180517002512-3bf9e2903213/go.mod"
+ "github.com/kalafut/imohash v1.0.0"
+ "github.com/kalafut/imohash v1.0.0/go.mod"
+ "github.com/kr/pretty v0.1.0"
+ "github.com/kr/pretty v0.1.0/go.mod"
+ "github.com/kr/pty v1.1.1/go.mod"
+ "github.com/kr/text v0.1.0"
+ "github.com/kr/text v0.1.0/go.mod"
+ "github.com/mattn/go-isatty v0.0.12"
+ "github.com/mattn/go-isatty v0.0.12/go.mod"
+ "github.com/mattn/go-runewidth v0.0.9"
+ "github.com/mattn/go-runewidth v0.0.9/go.mod"
+ "github.com/mitchellh/colorstring v0.0.0-20190213212951-d06e56a500db"
+ "github.com/mitchellh/colorstring v0.0.0-20190213212951-d06e56a500db/go.mod"
+ "github.com/pmezard/go-difflib v1.0.0"
+ "github.com/pmezard/go-difflib v1.0.0/go.mod"
+ "github.com/russross/blackfriday/v2 v2.0.1"
+ "github.com/russross/blackfriday/v2 v2.0.1/go.mod"
+ "github.com/schollz/cli/v2 v2.2.1"
+ "github.com/schollz/cli/v2 v2.2.1/go.mod"
+ "github.com/schollz/logger v1.2.0"
+ "github.com/schollz/logger v1.2.0/go.mod"
+ "github.com/schollz/mnemonicode v1.0.1"
+ "github.com/schollz/mnemonicode v1.0.1/go.mod"
+ "github.com/schollz/pake/v2 v2.0.5"
+ "github.com/schollz/pake/v2 v2.0.5/go.mod"
+ "github.com/schollz/peerdiscovery v1.6.1"
+ "github.com/schollz/peerdiscovery v1.6.1/go.mod"
+ "github.com/schollz/progressbar/v3 v3.7.1"
+ "github.com/schollz/progressbar/v3 v3.7.1/go.mod"
+ "github.com/shurcooL/sanitized_anchor_name v1.0.0"
+ "github.com/shurcooL/sanitized_anchor_name v1.0.0/go.mod"
+ "github.com/spaolacci/murmur3 v0.0.0-20180118202830-f09979ecbc72/go.mod"
+ "github.com/spaolacci/murmur3 v1.1.0"
+ "github.com/spaolacci/murmur3 v1.1.0/go.mod"
+ "github.com/stretchr/objx v0.1.0/go.mod"
+ "github.com/stretchr/testify v1.3.0/go.mod"
+ "github.com/stretchr/testify v1.6.1"
+ "github.com/stretchr/testify v1.6.1/go.mod"
+ "github.com/tscholl2/siec v0.0.0-20191122224205-8da93652b094"
+ "github.com/tscholl2/siec v0.0.0-20191122224205-8da93652b094/go.mod"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod"
+ "golang.org/x/crypto v0.0.0-20200622213623-75b288015ac9"
+ "golang.org/x/crypto v0.0.0-20200622213623-75b288015ac9/go.mod"
+ "golang.org/x/crypto v0.0.0-20201112155050-0c6587e931a9/go.mod"
+ "golang.org/x/crypto v0.0.0-20201117144127-c1f2f97bffc9"
+ "golang.org/x/crypto v0.0.0-20201117144127-c1f2f97bffc9/go.mod"
+ "golang.org/x/net v0.0.0-20190404232315-eb5bcb51f2a3/go.mod"
+ "golang.org/x/net v0.0.0-20201110031124-69a78807bb2b"
+ "golang.org/x/net v0.0.0-20201110031124-69a78807bb2b/go.mod"
+ "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a/go.mod"
+ "golang.org/x/sys v0.0.0-20190412213103-97732733099d/go.mod"
+ "golang.org/x/sys v0.0.0-20191026070338-33540a1f6037/go.mod"
+ "golang.org/x/sys v0.0.0-20200116001909-b77594299b42/go.mod"
+ "golang.org/x/sys v0.0.0-20200930185726-fdedc70b468f/go.mod"
+ "golang.org/x/sys v0.0.0-20201113135734-0a15ea8d9b02/go.mod"
+ "golang.org/x/sys v0.0.0-20201117222635-ba5294a509c7"
+ "golang.org/x/sys v0.0.0-20201117222635-ba5294a509c7/go.mod"
+ "golang.org/x/term v0.0.0-20201117132131-f5c789dd3221"
+ "golang.org/x/term v0.0.0-20201117132131-f5c789dd3221/go.mod"
+ "golang.org/x/text v0.3.0/go.mod"
+ "golang.org/x/text v0.3.3"
+ "golang.org/x/text v0.3.3/go.mod"
+ "golang.org/x/text v0.3.4"
+ "golang.org/x/text v0.3.4/go.mod"
+ "golang.org/x/tools v0.0.0-20180917221912-90fa682c2a6e/go.mod"
+ "gopkg.in/check.v1 v0.0.0-20161208181325-20d25e280405/go.mod"
+ "gopkg.in/check.v1 v1.0.0-20190902080502-41f04d3bba15"
+ "gopkg.in/check.v1 v1.0.0-20190902080502-41f04d3bba15/go.mod"
+ "gopkg.in/tylerb/is.v1 v1.1.2"
+ "gopkg.in/tylerb/is.v1 v1.1.2/go.mod"
+ "gopkg.in/yaml.v2 v2.2.2/go.mod"
+ "gopkg.in/yaml.v3 v3.0.0-20200313102051-9f266ea9e77c"
+ "gopkg.in/yaml.v3 v3.0.0-20200313102051-9f266ea9e77c/go.mod"
+ )
+go-module_set_globals
+
+SRC_URI="https://github.com/schollz/croc/releases/download/v${PV}/${PN}_${PV}_src.tar.gz -> ${P}.tar.gz
+ ${EGO_SUM_SRC_URI}"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ acct-group/croc
+ acct-user/croc
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-disable-network-tests.patch"
+)
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ # Replace User=nobody with User=croc
+ sed -i -e "s|\(^User=\).*|\1croc|g" croc.service || die
+ # Rename bash completion function
+ sed -i -e "s|_cli_bash_autocomplete|_croc|g" \
+ src/install/bash_autocomplete || die
+}
+
+src_compile() {
+ go build || die
+}
+
+src_install() {
+ dobin croc
+ systemd_dounit croc.service
+ newbashcomp src/install/bash_autocomplete croc
+ einstalldocs
+}
+
+src_test() {
+ go test -work ./... || die
+}