summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/autoupnp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/autoupnp')
-rw-r--r--net-misc/autoupnp/Manifest1
-rw-r--r--net-misc/autoupnp/autoupnp-0.4.6.ebuild33
-rw-r--r--net-misc/autoupnp/autoupnp-9999.ebuild40
-rw-r--r--net-misc/autoupnp/metadata.xml16
4 files changed, 90 insertions, 0 deletions
diff --git a/net-misc/autoupnp/Manifest b/net-misc/autoupnp/Manifest
new file mode 100644
index 000000000000..2633bf042912
--- /dev/null
+++ b/net-misc/autoupnp/Manifest
@@ -0,0 +1 @@
+DIST autoupnp-0.4.6.tar.bz2 240257 SHA256 a8d0a207074fafdb322510fd29a25eb4bf62da9468ea3dc45e7c9740faeccab7 SHA512 570ae76d940879a375e9336cb62cce8b2e007c57df6cbebee5878cf6a71d1fe5853218166ba0ee794586fa20a7c62b158aae9242b30880f6fe110c9bb1502ba1 WHIRLPOOL 4b2d848f36e3f2848e6f08f71296b5cf3fe7794bdfc9e6495428b3b3ae9283ed15e81de0bec2fdf0b36173d59a4c7dbec5dbef30bf3a0ba24e320de313cb20ab
diff --git a/net-misc/autoupnp/autoupnp-0.4.6.ebuild b/net-misc/autoupnp/autoupnp-0.4.6.ebuild
new file mode 100644
index 000000000000..bd42f10eefd1
--- /dev/null
+++ b/net-misc/autoupnp/autoupnp-0.4.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Automatic open port forwarder using UPnP"
+HOMEPAGE="https://bitbucket.org/mgorny/autoupnp/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="net-libs/miniupnpc
+ libnotify? ( x11-libs/libtinynotify )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ myeconfargs=(
+ $(use_with libnotify)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ prune_libtool_files --all
+}
diff --git a/net-misc/autoupnp/autoupnp-9999.ebuild b/net-misc/autoupnp/autoupnp-9999.ebuild
new file mode 100644
index 000000000000..f9ce1293d53b
--- /dev/null
+++ b/net-misc/autoupnp/autoupnp-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-r3
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="Automatic open port forwarder using UPnP"
+HOMEPAGE="https://bitbucket.org/mgorny/autoupnp/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="net-libs/miniupnpc:0=
+ libnotify? ( x11-libs/libtinynotify:0= )"
+DEPEND="${RDEPEND}"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+src_configure() {
+ myeconfargs=(
+ $(use_with libnotify)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/net-misc/autoupnp/metadata.xml b/net-misc/autoupnp/metadata.xml
new file mode 100644
index 000000000000..1ceb5b062490
--- /dev/null
+++ b/net-misc/autoupnp/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/autoupnp/issues/</bugs-to>
+ <remote-id type="bitbucket">mgorny/autoupnp</remote-id>
+ </upstream>
+</pkgmetadata>