summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2022-01-12 13:49:04 -0500
committerCraig Andrews <candrews@gentoo.org>2022-01-12 13:49:28 -0500
commit045446c81ce7161a1ff64570798348ee30e1a090 (patch)
tree8f7475eed6cdddca29c43f918f4b16fa61d22473 /net-libs/neon
parentmedia-gfx/brscan4: Version bump to 0.4.11.1 (diff)
downloadgentoo-045446c81ce7161a1ff64570798348ee30e1a090.tar.gz
gentoo-045446c81ce7161a1ff64570798348ee30e1a090.tar.bz2
gentoo-045446c81ce7161a1ff64570798348ee30e1a090.zip
net-libs/neon: 0.32.2 version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs/neon')
-rw-r--r--net-libs/neon/Manifest1
-rw-r--r--net-libs/neon/neon-0.32.2.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/net-libs/neon/Manifest b/net-libs/neon/Manifest
index adc5a07fec87..82555b12ca47 100644
--- a/net-libs/neon/Manifest
+++ b/net-libs/neon/Manifest
@@ -3,3 +3,4 @@ DIST neon-0.31.0.tar.gz 867476 BLAKE2B 84981d0fcca97bfa495f9e8cbf060a06e04c931ce
DIST neon-0.31.1.tar.gz 867810 BLAKE2B 7b7d0c8ab635446c98f3db7072f1dabbb74ad9f579086f209bb3af5460363520be38886a299d22dc0f27a091f322c6d5972a00d4e6c612c710dca12e7620f850 SHA512 00d7297c102ee828d84eb28c9b6a57e66290904acf5327f8a6d3d1759ffacf88329bb2157dcef418c69e93d1370ccbd591829da06c01c3f44aea6c7b92462c13
DIST neon-0.31.2.tar.gz 867914 BLAKE2B 8ae1301dd5f9ac1a6b518f99919a1b7e7b7c6499413b523ff82e00d364d6d9c5ad96875795330e2fd9c42a42b073e3eea51b6cc0ee9e9a21850763f0cdd0b97e SHA512 1e402b40a0445f68ed24d2697ee60d21636f61ebc98edcde37ff9e26c54430acabf3969ac22a942d1dd51bddee0f312c04073b423b0af3a3e7c9bf60cd53e48c
DIST neon-0.32.1.tar.gz 880434 BLAKE2B 91b942cb0d7184f4da26d7d45e846a0f80aa834226e5ff0689df75650da79cbfad0854c718dbffdd31cc0f09f25458ea37ca39bb38071643a6a609ef6102b896 SHA512 a231865c3aad3668f6effded97a58eb981655f64c71b0954fcb2e667bdec50895d11bf296f4f454bd63e6ce9b02c2fd13cbb17cb82631e16f100000ecd7e1977
+DIST neon-0.32.2.tar.gz 880651 BLAKE2B 3629eee38e10ada5e001bf0afb77c70814083bf553596fc150a6cf21f0b66cf4de28841b242f68faaeb44fa5e0ad260939102b015d2a543ef59012876256b364 SHA512 2580a3c8c3cf4aff2d399f72a721ccfb4e68434ef92da4af8103c126812d779b9fbe5cafbab512c79f4365bbb3d3eac61568748136470e86f7aa7b98b27053c8
diff --git a/net-libs/neon/neon-0.32.2.ebuild b/net-libs/neon/neon-0.32.2.ebuild
new file mode 100644
index 000000000000..b318674ec7f0
--- /dev/null
+++ b/net-libs/neon/neon-0.32.2.ebuild
@@ -0,0 +1,109 @@
+# Copyright 2001-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools libtool multilib-minimal
+
+DESCRIPTION="HTTP and WebDAV client library"
+HOMEPAGE="https://notroj.github.io/neon/"
+SRC_URI="https://notroj.github.io/neon/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/27"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc expat gnutls kerberos libproxy nls pkcs11 ssl static-libs zlib"
+RESTRICT="test"
+
+RDEPEND="expat? ( dev-libs/expat:0=[${MULTILIB_USEDEP}] )
+ !expat? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
+ kerberos? ( virtual/krb5:0=[${MULTILIB_USEDEP}] )
+ libproxy? ( net-libs/libproxy:0=[${MULTILIB_USEDEP}] )
+ nls? ( virtual/libintl:0=[${MULTILIB_USEDEP}] )
+ ssl? (
+ gnutls? (
+ app-misc/ca-certificates
+ net-libs/gnutls:0=[${MULTILIB_USEDEP}]
+ )
+ !gnutls? (
+ dev-libs/openssl:0=[${MULTILIB_USEDEP}]
+ )
+ pkcs11? ( dev-libs/pakchois:0=[${MULTILIB_USEDEP}] )
+ )
+ zlib? ( sys-libs/zlib:0=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/xmlto
+ virtual/pkgconfig
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/neon-config
+)
+
+src_prepare() {
+ # Use CHOST-prefixed version of xml2-config for cross-compilation.
+ sed -e "s/AC_CHECK_PROG(XML2_CONFIG,/AC_CHECK_TOOL(XML2_CONFIG,/" -i macros/neon-xml-parser.m4 || die "sed failed"
+
+ # Fix compatibility with OpenSSL >=1.1.
+ sed -e "s/RSA_F_RSA_PRIVATE_ENCRYPT/RSA_F_RSA_OSSL_PRIVATE_ENCRYPT/" -i src/ne_pkcs11.c || die "sed failed"
+
+ eapply_user
+
+ AT_M4DIR="macros" eautoreconf
+
+ elibtoolize
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myconf=()
+
+ if has_version sys-libs/glibc; then
+ einfo "Enabling SSL library thread-safety using POSIX threads..."
+ myconf+=(--enable-threadsafe-ssl=posix)
+ fi
+
+ if use expat; then
+ myconf+=(--with-expat)
+ else
+ myconf+=(--with-libxml2)
+ fi
+
+ if use ssl; then
+ if use gnutls; then
+ myconf+=(--with-ssl=gnutls --with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt")
+ else
+ myconf+=(--with-ssl=openssl)
+ fi
+ fi
+
+ econf \
+ --enable-shared \
+ $(use_with kerberos gssapi) \
+ $(use_with libproxy) \
+ $(use_enable nls) \
+ $(use_with pkcs11 pakchois) \
+ $(use_enable static-libs static) \
+ $(use_with zlib) \
+ "${myconf[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install-{config,headers,lib,man,nls}
+
+ if multilib_is_native_abi && use doc; then
+ (
+ docinto html
+ dodoc -r doc/html/*
+ )
+ fi
+}
+
+multilib_src_install_all() {
+ find "${D}" -name "*.la" -type f -delete || die
+
+ dodoc AUTHORS BUGS NEWS README.md THANKS TODO
+}