summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-31 04:32:46 +0000
committerSam James <sam@gentoo.org>2021-10-31 04:32:46 +0000
commite1ab2444c5bc7ea380b30447926371d2904cf29a (patch)
treef4b3e5cfb5d12040bb9044c8adad9426b8be5ac4 /net-libs/libtorrent-rasterbar
parentnet-libs/libtorrent-rasterbar: add link to upstream patch (diff)
downloadgentoo-e1ab2444c5bc7ea380b30447926371d2904cf29a.tar.gz
gentoo-e1ab2444c5bc7ea380b30447926371d2904cf29a.tar.bz2
gentoo-e1ab2444c5bc7ea380b30447926371d2904cf29a.zip
net-libs/libtorrent-rasterbar: fix Python bindings in 2.0.4
Thanks-to: Conrad <conrad_bugtracker@fps-power.eu> Closes: https://bugs.gentoo.org/820518 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libtorrent-rasterbar')
-rw-r--r--net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-python-symbols.patch28
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r4.ebuild (renamed from net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r3.ebuild)1
2 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-python-symbols.patch b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-python-symbols.patch
new file mode 100644
index 000000000000..109a6490af23
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-python-symbols.patch
@@ -0,0 +1,28 @@
+https://github.com/arvidn/libtorrent/commit/f2eefd327f1ca89b053eb1e5f4ed229efe52e47f
+https://bugs.gentoo.org/820518
+
+From: Nick Korotysh <kolchaprogrammer@list.ru>
+Date: Fri, 25 Jun 2021 22:08:00 +0300
+Subject: [PATCH] added missed sources to Python bindings CMakeLists.txt
+
+fixes libtorrent loading module issues:
+libtorrent.cpython-39-x86_64-linux-gnu.so: undefined symbol: _Z16bind_sha256_hashv
+--- a/bindings/python/CMakeLists.txt
++++ b/bindings/python/CMakeLists.txt
+@@ -49,6 +49,7 @@ Python3_add_library(python-libtorrent MODULE WITH_SOABI
+ src/entry.cpp
+ src/error_code.cpp
+ src/fingerprint.cpp
++ src/info_hash.cpp
+ src/ip_filter.cpp
+ src/magnet_uri.cpp
+ src/module.cpp
+@@ -56,6 +57,7 @@ Python3_add_library(python-libtorrent MODULE WITH_SOABI
+ src/session.cpp
+ src/session_settings.cpp
+ src/sha1_hash.cpp
++ src/sha256_hash.cpp
+ src/string.cpp
+ src/torrent_handle.cpp
+ src/torrent_info.cpp
+
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r3.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r4.ebuild
index 9dc9cb503708..0982c19a1263 100644
--- a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r3.ebuild
+++ b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r4.ebuild
@@ -41,6 +41,7 @@ BDEPEND="python? (
PATCHES=(
"${FILESDIR}"/${PN}-2.0.4-boost-1.76.patch
"${FILESDIR}"/${P}-boost-1.77.patch
+ "${FILESDIR}"/${P}-python-symbols.patch
)
pkg_setup() {