summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-01-08 22:44:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-08 22:44:24 +0100
commitb2c31e936ee1662faf4653d80824f35bca26e45f (patch)
treeaf7ee40eb865103b5fc673fcf62d44b4039456e1 /net-libs/libquotient
parentdev-cpp/eigen: drop 3.4.0-r1 (diff)
downloadgentoo-b2c31e936ee1662faf4653d80824f35bca26e45f.tar.gz
gentoo-b2c31e936ee1662faf4653d80824f35bca26e45f.tar.bz2
gentoo-b2c31e936ee1662faf4653d80824f35bca26e45f.zip
net-libs/libquotient: add 0.9.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libquotient')
-rw-r--r--net-libs/libquotient/Manifest1
-rw-r--r--net-libs/libquotient/libquotient-0.9.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
index 54ae5392ff10..4c6a0a0ee034 100644
--- a/net-libs/libquotient/Manifest
+++ b/net-libs/libquotient/Manifest
@@ -1,2 +1,3 @@
DIST libquotient-0.8.2.tar.gz 744095 BLAKE2B c33016e4eda22e0a363f06ab4545d17010519b8d778566c1bae29e4c7d6563280f4ce3c1235f7d75f55ce4a8971ef5ce23e45f1d3a0edc043e23857d805a824f SHA512 3d971439f8a89609930ca1648f6cf1bdb59f3ad492af1a15a7f8a13d06c81bd5bfffa1dd732ef5156fab8a9ea2ba3e98376bf76511db17bdeee17641a772b762
DIST libquotient-0.9.1.tar.gz 772882 BLAKE2B f43da0833baa1242f29fb7ed1dd1065b673497d8e2d8358b60d67da0fef8f382ac3fdda8cdc9ed0ac67b5cd423527ef418d0a574fd30e46fe9337214509b1dc2 SHA512 f998b187a1168381c7868400fec73f68ab95af29d1d648921a507fac8782f8c69fd8aab7916466ad9d6b85edadf5168659d7b78a876daa30798891d84afcfa5a
+DIST libquotient-0.9.2.tar.gz 777025 BLAKE2B f616283a7ebd493caba57de950c8dd1a53213b54ff3183ffd436a4d901439607d086020256955375208d3c311e20f3e3fd0b55e3164961bd885b5a0882296919 SHA512 c179b1ca670f9b75b945d50026b02c34dabbd58056abb6f210998229dae80dba8f00de157d9c3fc32254b613c5db149ca497a9b9695cdf5e61255e82be73db0c
diff --git a/net-libs/libquotient/libquotient-0.9.2.ebuild b/net-libs/libquotient/libquotient-0.9.2.ebuild
new file mode 100644
index 000000000000..cafd0f8faefe
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.9.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0/${PV}" # FIXME: check soname on next version bump
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/olm
+ dev-libs/openssl:=
+ >=dev-libs/qtkeychain-0.14.2:=[qt6(+)]
+ >=dev-qt/qtbase-6.4:6=[gui,network,sql,ssl]
+ >=dev-qt/qtmultimedia-6.4:6
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtbase-6.4:6[concurrent] )
+"
+
+# downstream patch
+PATCHES=( "${FILESDIR}"/${PN}-0.8.0-no-android.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ use test && mycmakeargs+=(
+ -DQuotient_INSTALL_TESTS=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # https://github.com/quotient-im/libQuotient/issues/435
+ # testolmaccount requires network connection/server set up
+ local myctestargs=(
+ -j1
+ -E "(testolmaccount)"
+ )
+ cmake_src_test
+}