summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-04-20 13:35:07 +0300
committerMart Raudsepp <leio@gentoo.org>2018-04-20 13:35:31 +0300
commitc77b89c644242e01711086e831642be67c2ac759 (patch)
tree91a86795bc541e0b048eb256be40d6b8f45337f5 /net-libs/gtk-vnc
parentnet-libs/gtk-vnc-0.7.2: remove pygtk2 based python binding (diff)
downloadgentoo-c77b89c644242e01711086e831642be67c2ac759.tar.gz
gentoo-c77b89c644242e01711086e831642be67c2ac759.tar.bz2
gentoo-c77b89c644242e01711086e831642be67c2ac759.zip
net-libs/gtk-vnc-0.7.2: remove gtk2 support, simplify ebuild
Remove gtk2 library, which isn't used by anything in tree anymore. This also removes IUSE=gtk3, which should be fine as all consumers were adjusted to require gtk3(+); only an older gnome-boxes version doesn't yet, but matching ~arch version does have it, and it'll be stabilized before gtk-vnc-0.7.2 is, so should be fine. This greatly simplifies the ebuild because we don't need to use multibuild.eclass anymore. Additionally it fixes the lack of installed docs (NEWS, README, etc), which were broken due to multibuild usage - after its removal, the default einstalldocs without DOCS set kicks in and installs exactly what we need. Also remove VALA_USE_DEPEND="vapigen", as vala versions that had the USE flag are long gone (eclass generates an unnecessary [vapigen(+)] USE dep if VALA_USE_DEPEND is set like this). Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'net-libs/gtk-vnc')
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.7.2.ebuild73
1 files changed, 9 insertions, 64 deletions
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.7.2.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.7.2.ebuild
index 3d93adf97942..3cbb2e545e7a 100644
--- a/net-libs/gtk-vnc/gtk-vnc-0.7.2.ebuild
+++ b/net-libs/gtk-vnc/gtk-vnc-0.7.2.ebuild
@@ -4,9 +4,8 @@
EAPI=6
GNOME2_LA_PUNT="yes"
VALA_MIN_API_VERSION="0.16"
-VALA_USE_DEPEND="vapigen"
-inherit gnome2 multibuild vala
+inherit vala gnome2
DESCRIPTION="VNC viewer widget for GTK"
HOMEPAGE="https://wiki.gnome.org/Projects/gtk-vnc"
@@ -14,29 +13,26 @@ HOMEPAGE="https://wiki.gnome.org/Projects/gtk-vnc"
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="examples +gtk3 +introspection pulseaudio sasl vala"
+IUSE="examples +introspection pulseaudio sasl vala"
REQUIRED_USE="
- vala? ( gtk3 introspection )
+ vala? ( introspection )
"
# libview is used in examples/gvncviewer -- no need
# glib-2.30.1 needed to avoid linking failure due to .la files (bug #399129)
-COMMON_DEPEND="
+RDEPEND="
>=dev-libs/glib-2.30.1:2
>=dev-libs/libgcrypt-1.4.2:0=
dev-libs/libgpg-error
>=net-libs/gnutls-3.0:0=
>=x11-libs/cairo-1.2
- >=x11-libs/gtk+-2.18:2
x11-libs/libX11
- gtk3? ( >=x11-libs/gtk+-2.91.3:3[introspection?] )
+ >=x11-libs/gtk+-3.0.0:3[introspection?]
introspection? ( >=dev-libs/gobject-introspection-0.9.4:= )
pulseaudio? ( media-sound/pulseaudio )
sasl? ( dev-libs/cyrus-sasl )
"
-RDEPEND="${COMMON_DEPEND}"
-
-DEPEND="${COMMON_DEPEND}
+DEPEND="${RDEPEND}
>=dev-lang/perl-5
>=dev-util/intltool-0.40
sys-devel/gettext
@@ -47,24 +43,7 @@ DEPEND="${COMMON_DEPEND}
"
# eautoreconf requires gnome-common
-compute_variants() {
- MULTIBUILD_VARIANTS=( 2.0 )
- use gtk3 && MULTIBUILD_VARIANTS+=( 3.0 )
-}
-
src_prepare() {
- prepare() {
- mkdir -p "${BUILD_DIR}" || die
- }
-
- local MULTIBUILD_VARIANTS
- compute_variants
- multibuild_foreach_variant prepare
-
- # Fix incorrect codegendir check: h2def.py is in pygobject, not pygtk, upstream bug#744393
- sed -e 's/codegendir pygtk-2.0/codegendir pygobject-2.0/g' \
- -i src/Makefile.* || die
-
vala_src_prepare
gnome2_src_prepare
}
@@ -79,43 +58,9 @@ src_configure() {
--without-libview
--disable-static
--disable-vala
+ --with-gtk=3.0
+ --without-python
)
- configure_normal() {
- ECONF_SOURCE="${S}" gnome2_src_configure \
- ${myconf[@]} \
- --with-gtk=${MULTIBUILD_VARIANT} \
- --without-python
- }
-
- local MULTIBUILD_VARIANTS
- compute_variants
- multibuild_foreach_variant run_in_build_dir configure_normal
-}
-
-src_compile() {
- compile_normal() {
- gnome2_src_compile
- }
-
- local MULTIBUILD_VARIANTS
- compute_variants
- multibuild_foreach_variant run_in_build_dir compile_normal
-}
-
-src_test() {
- local MULTIBUILD_VARIANTS
- compute_variants
-
- multibuild_foreach_variant run_in_build_dir default
-}
-
-src_install() {
- install_normal() {
- gnome2_src_install
- }
-
- local MULTIBUILD_VARIANTS
- compute_variants
- multibuild_foreach_variant run_in_build_dir install_normal
+ gnome2_src_configure ${myconf[@]}
}