summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/gsnmp/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/gsnmp/files')
-rw-r--r--net-libs/gsnmp/files/gsnmp-0.3.0-g_access.patch10
-rw-r--r--net-libs/gsnmp/files/gsnmp-0.3.0-pkg_config.patch31
-rw-r--r--net-libs/gsnmp/files/gsnmp-0.3.0-underquoting.patch11
3 files changed, 52 insertions, 0 deletions
diff --git a/net-libs/gsnmp/files/gsnmp-0.3.0-g_access.patch b/net-libs/gsnmp/files/gsnmp-0.3.0-g_access.patch
new file mode 100644
index 000000000000..505f7d166a9d
--- /dev/null
+++ b/net-libs/gsnmp/files/gsnmp-0.3.0-g_access.patch
@@ -0,0 +1,10 @@
+--- a/src/transport.c
++++ b/src/transport.c
+@@ -32,6 +32,7 @@
+ #include "transport.h"
+ #include "dispatch.h"
+ #include "pdu.h" /* xxx only needed for debugging flags... */
++#include <glib/gstdio.h> /* g_access() */
+
+
+ static GUdpSocket *udp_ipv4_socket = NULL;
diff --git a/net-libs/gsnmp/files/gsnmp-0.3.0-pkg_config.patch b/net-libs/gsnmp/files/gsnmp-0.3.0-pkg_config.patch
new file mode 100644
index 000000000000..2e837caa820d
--- /dev/null
+++ b/net-libs/gsnmp/files/gsnmp-0.3.0-pkg_config.patch
@@ -0,0 +1,31 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -21,10 +21,18 @@
+
+ AC_PROG_LIBTOOL
+
++PKG_PROG_PKG_CONFIG
++
+ dnl Checks for libraries.
+
+-AM_PATH_GLIB_2_0(2.0.0)
+-AM_PATH_GNET_2_0(2.0.4)
++PKG_CHECK_MODULES(GLIB, glib-2.0 > 2.0.0,[
++ LIBS="$LIBS $GLIB_LIBS"
++ CPPFLAGS="$CPPFLAGS $GLIB_CFLAGS"
++ ], AC_MSG_ERROR[Could not find glib])
++PKG_CHECK_MODULES(GNET, gnet-2.0 > 2.0.4,[
++ LIBS="$LIBS $GNET_LIBS"
++ CPPFLAGS="$CPPFLAGS $GNET_CFLAGS"
++ ], AC_MSG_ERROR[Could not find gnet])
+
+ dnl Checks for header files.
+ dnl AC_HEADER_STDC
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,5 +1,3 @@
+-AM_CPPFLAGS = $(GNET_CFLAGS)
+-
+ lib_LTLIBRARIES = libgsnmp.la
+ libgsnmp_la_SOURCES = ber.c ber.h \
+ pdu.c pdu.h \
diff --git a/net-libs/gsnmp/files/gsnmp-0.3.0-underquoting.patch b/net-libs/gsnmp/files/gsnmp-0.3.0-underquoting.patch
new file mode 100644
index 000000000000..877aeceb0b0e
--- /dev/null
+++ b/net-libs/gsnmp/files/gsnmp-0.3.0-underquoting.patch
@@ -0,0 +1,11 @@
+--- a/gsnmp.m4
++++ b/gsnmp.m4
+@@ -1,7 +1,7 @@
+ dnl AM_PATH_GSNMP()
+ dnl
+
+-AC_DEFUN(AM_PATH_GSNMP,
++AC_DEFUN([AM_PATH_GSNMP],
+ [
+ PKG_CHECK_MODULES(GSNMP, glib-2.0 >= 2.0.1)
+ ])