summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/cppzmq
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/cppzmq')
-rw-r--r--net-libs/cppzmq/Manifest2
-rw-r--r--net-libs/cppzmq/cppzmq-0_pre130717-r1.ebuild29
-rw-r--r--net-libs/cppzmq/cppzmq-0_pre150606.ebuild29
-rw-r--r--net-libs/cppzmq/metadata.xml11
4 files changed, 71 insertions, 0 deletions
diff --git a/net-libs/cppzmq/Manifest b/net-libs/cppzmq/Manifest
new file mode 100644
index 000000000000..6a3eb5f81386
--- /dev/null
+++ b/net-libs/cppzmq/Manifest
@@ -0,0 +1,2 @@
+DIST cppzmq-0_pre130717.tar.xz 3736 SHA256 94efc2ad76ef779f9ede32d2bbffc82b37ca3004b62a67aed031b3dc4a9e7472 SHA512 3dbff2d3c1cc9f40b58477d2654cd1af4b639c71ca332dd6bcf33cce3d420a2c9e56312c0824bbccc6cea721b5688f8ec255180aace898dca57eb98a8d40c142 WHIRLPOOL 7d99aba2696fdf09c0e2b0af076ef5ca56d89e0dddb3c82f44433a0881fe354169d037a73ee415c0f7ab1e11895fc0d9043726255ffbb67224839b49afea5456
+DIST cppzmq-0_pre150606.tar.xz 4032 SHA256 fb1cb2ebfdfe955f68edca6b09a7f974e63bd35941bd01423907bc4f81febbaf SHA512 d5ab584989f0eec7ce227de4534820f6e00582b8f45ebab5472c8244823a14a89e74005edb8ae933037a1df9684cc21641cd271a147f39577331b96474927efe WHIRLPOOL 15fdc4cedd9dc6e1434cb286d00a4524e73e5e0fae0e11220bd7b1dce0898ef1afedaa5b5cc416add613d5237362661f6d309f9acb629c8026f25e814001fb11
diff --git a/net-libs/cppzmq/cppzmq-0_pre130717-r1.ebuild b/net-libs/cppzmq/cppzmq-0_pre130717-r1.ebuild
new file mode 100644
index 000000000000..b44c84e6828f
--- /dev/null
+++ b/net-libs/cppzmq/cppzmq-0_pre130717-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="High-level CPP Binding for ZeroMQ"
+HOMEPAGE="https://github.com/zeromq/cppzmq"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=net-libs/zeromq-3"
+DEPEND=""
+
+src_install() {
+ doheader zmq.hpp
+ dodoc README
+}
+
+src_test() {
+ $(tc-getCC) -c ./zmq.hpp -L ./.libs/ -I ./include/ -o ./test.o || die "This version of cppzmq is not compatible with the installed version of net-libs/zeromq"
+ rm -f ./test.o
+}
diff --git a/net-libs/cppzmq/cppzmq-0_pre150606.ebuild b/net-libs/cppzmq/cppzmq-0_pre150606.ebuild
new file mode 100644
index 000000000000..b44c84e6828f
--- /dev/null
+++ b/net-libs/cppzmq/cppzmq-0_pre150606.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="High-level CPP Binding for ZeroMQ"
+HOMEPAGE="https://github.com/zeromq/cppzmq"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=net-libs/zeromq-3"
+DEPEND=""
+
+src_install() {
+ doheader zmq.hpp
+ dodoc README
+}
+
+src_test() {
+ $(tc-getCC) -c ./zmq.hpp -L ./.libs/ -I ./include/ -o ./test.o || die "This version of cppzmq is not compatible with the installed version of net-libs/zeromq"
+ rm -f ./test.o
+}
diff --git a/net-libs/cppzmq/metadata.xml b/net-libs/cppzmq/metadata.xml
new file mode 100644
index 000000000000..bbae0452e962
--- /dev/null
+++ b/net-libs/cppzmq/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zeromq/cppzmq</remote-id>
+ </upstream>
+</pkgmetadata>