summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2021-01-17 00:44:21 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-01-29 15:45:47 +0200
commit5669c2bd8322fae6c2d08a89b70d2d003da2374f (patch)
tree586cb364a2470c94e6b7b086ebb4f3b0cdd47845 /net-im/gitter-bin
parentnet-im/gitter-bin: cleanup old ebuild (diff)
downloadgentoo-5669c2bd8322fae6c2d08a89b70d2d003da2374f.tar.gz
gentoo-5669c2bd8322fae6c2d08a89b70d2d003da2374f.tar.bz2
gentoo-5669c2bd8322fae6c2d08a89b70d2d003da2374f.zip
net-im/gitter-bin: version bump to 5.0.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Closes: https://github.com/gentoo/gentoo/pull/19084 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-im/gitter-bin')
-rw-r--r--net-im/gitter-bin/Manifest2
-rw-r--r--net-im/gitter-bin/gitter-bin-5.0.1.ebuild103
2 files changed, 105 insertions, 0 deletions
diff --git a/net-im/gitter-bin/Manifest b/net-im/gitter-bin/Manifest
index bf49cbb16b12..91239435c8c0 100644
--- a/net-im/gitter-bin/Manifest
+++ b/net-im/gitter-bin/Manifest
@@ -1,2 +1,4 @@
DIST gitter_4.1.0_amd64.deb 98314502 BLAKE2B 3f14e044865c9af89dc6ac62dbe8f8221824c6f529418a31fd5236ecec45ddfd6013d734100a414a2bbca0db9e8c40cb7046868391d507ba5c9de9da0c66225d SHA512 2ea0ebbc05cbdc40e4e8cb07a68b3948477a61a81e550b8f131af46315c6fc7547c0954aa101260f93b63c557f3e00b1e23006a236b77be01ea4a82edd170f70
DIST gitter_4.1.0_i386.deb 101820112 BLAKE2B 3d1ab270389da9c82440dc7a204d1973402de1648e0387a026601d34bd1f2b26469b0fab9be4ff4b596cbe257047e88446b5c36d08deeeae1aaea4f387c45ac3 SHA512 c76da19e6eaf79894319848b6121660dab0bd8f2d8cdfaf413a68bee0f4c62fdca25c19c24eeb226164b643582db9ed686c68a5f72701618d41b423df9c9cee8
+DIST gitter_5.0.1_amd64.deb 136453344 BLAKE2B 6e057fb04872f89961a8970d079b14fbaf416db126ac0596485936a069a85fb5e783b052e20af7fbce40bc4805313ad793873c6ad3cadf87fc2662fef39604f1 SHA512 9bca96a2e312e7893ea7e5faca4a6a3e343d0d3bf96b86e0353437517fc006eb917787cb872f305d1c843978cfd80f729474bd485070ec26d99d67d24ffbf4d1
+DIST gitter_5.0.1_i386.deb 141585750 BLAKE2B 464e3416085717702df605fefade3a5aabafbdbfa9274eb9da03832b9a5e442d0a92eacd5c4d757e64709b3ba39bfdc5a87d689bb24db1ede3aca43b187550ce SHA512 b340b161728530e6c397ad6d5fbd591393a893c73b29056094514514d3e0f3a30ebdab94bb19f6c78cf1c73a30c6cd145476e34db5eaea06ba061f8a410579f7
diff --git a/net-im/gitter-bin/gitter-bin-5.0.1.ebuild b/net-im/gitter-bin/gitter-bin-5.0.1.ebuild
new file mode 100644
index 000000000000..df5c40ef1ebb
--- /dev/null
+++ b/net-im/gitter-bin/gitter-bin-5.0.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+MY_PN="${PN/-bin/}"
+
+inherit desktop multilib-build pax-utils unpacker xdg
+
+QA_PREBUILT="opt/gitter/pnacl/pnacl_public_x86_64_pnacl_llc_nexe
+ opt/gitter/pnacl/pnacl_public_x86_64_ld_nexe
+ opt/gitter/pnacl/pnacl_public_x86_64_pnacl_sz_nexe
+ opt/gitter/payload
+ opt/gitter/swiftshader/libEGL.so
+ opt/gitter/swiftshader/libGLESv2.so
+ opt/gitter/chromedriver
+ opt/gitter/lib/libnw.so
+ opt/gitter/lib/libnode.so
+ opt/gitter/lib/libffmpeg.so
+ opt/gitter/nacl_helper
+ opt/gitter/nwjc
+ opt/gitter/nacl_irt_x86_64.nexe
+ opt/gitter/Gitter"
+QA_FLAGS_IGNORED="opt/gitter/minidump_stackwalk
+ opt/gitter/nacl_helper_bootstrap
+ opt/gitter/crashpad_handler
+ opt/gitter/lib/libEGL.so
+ opt/gitter/lib/libGLESv2.so"
+
+DESCRIPTION="Chat and network platform"
+HOMEPAGE="https://www.gitter.im"
+SRC_URI="
+ amd64? ( https://update.gitter.im/linux64/${MY_PN}_${PV}_amd64.deb )
+ x86? ( https://update.gitter.im/linux32/${MY_PN}_${PV}_i386.deb )"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="bindist mirror"
+
+RDEPEND="app-accessibility/at-spi2-core:2[${MULTILIB_USEDEP}]
+ dev-libs/atk:0[${MULTILIB_USEDEP}]
+ dev-libs/expat:0[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr:0[${MULTILIB_USEDEP}]
+ dev-libs/nss:0[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib:0[${MULTILIB_USEDEP}]
+ net-print/cups:0[${MULTILIB_USEDEP}]
+ sys-apps/dbus:0[${MULTILIB_USEDEP}]
+ x11-libs/cairo:0[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libdrm:0[${MULTILIB_USEDEP}]
+ x11-libs/libX11:0[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:0/1.12[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite:0[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor:0[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage:0[${MULTILIB_USEDEP}]
+ x11-libs/libXext:0[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes:0[${MULTILIB_USEDEP}]
+ x11-libs/libXi:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrender:0[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver:0[${MULTILIB_USEDEP}]
+ x11-libs/libXtst:0[${MULTILIB_USEDEP}]
+ x11-libs/pango:0[${MULTILIB_USEDEP}]"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ local arch
+ arch="$(usex amd64 "64" "32")"
+
+ # Remove hardcoded paths
+ sed -i \
+ -e '/Exec/s/=.*/=gitter/' \
+ -e '/Icon/s/=.*/=gitter/' \
+ opt/Gitter/linux"${arch}"/gitter.desktop || die "sed failed"
+}
+
+src_install() {
+ local arch
+ arch="$(usex amd64 "64" "32")"
+
+ newicon opt/Gitter/linux"${arch}"/logo.png gitter.png
+ newicon -s 256 opt/Gitter/linux"${arch}"/logo.png gitter.png
+ domenu opt/Gitter/linux"${arch}"/gitter.desktop
+
+ insinto /opt/gitter
+ doins -r opt/Gitter/linux"${arch}"/.
+ fperms -R +x /opt/gitter/lib/ /opt/gitter/swiftshader/ \
+ /opt/gitter/pnacl/pnacl_public_x86_64_{ld_nexe,pnacl_llc_nexe,pnacl_sz_nexe} \
+ /opt/gitter/{Gitter,chromedriver,crashpad_handler,minidump_stackwalk,nwjc,payload} \
+ /opt/gitter/nacl_{helper,helper_bootstrap,irt_x86_64.nexe}
+
+ dosym ../../opt/gitter/Gitter /usr/bin/gitter
+
+ pax-mark -m "${ED}"/opt/gitter/Gitter
+}