summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-08-24 17:10:31 +0200
committerSam James <sam@gentoo.org>2023-08-26 04:55:03 +0100
commit33ff3498a8a5ffa1eaefd25d5bc3fd806d8d1bff (patch)
tree7ca74f7d24338f8b4e8818c043590460d7bcddb1 /net-analyzer
parentapp-text/qpdf: Stabilize 11.5.0 arm64, #913024 (diff)
downloadgentoo-33ff3498a8a5ffa1eaefd25d5bc3fd806d8d1bff.tar.gz
gentoo-33ff3498a8a5ffa1eaefd25d5bc3fd806d8d1bff.tar.bz2
gentoo-33ff3498a8a5ffa1eaefd25d5bc3fd806d8d1bff.zip
net-analyzer/shodan: add 1.30.0
Switching to PyPI as upstream stopped tagging releases on GitHub Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/shodan/Manifest1
-rw-r--r--net-analyzer/shodan/shodan-1.30.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/shodan/Manifest b/net-analyzer/shodan/Manifest
index 692d15a254a3..ccf8ff62fc9a 100644
--- a/net-analyzer/shodan/Manifest
+++ b/net-analyzer/shodan/Manifest
@@ -1 +1,2 @@
DIST shodan-1.28.0.gh.tar.gz 51277 BLAKE2B e2cd4c322ccdd1d81c998dc810c56b85de903afe9c3a59adc231d382779806909a78e994ff163639468dd9af1e8f7a547953b0e2304ac167ed7cf9c437d69adc SHA512 cb2476faf2c435d29823635e5262bdf6b224b2a5f19b77513fb6e920f4d042b15a7fd23cea7e2a29bc73b00be188dfac16f945fba090da28a72d0342357232c3
+DIST shodan-1.30.0.tar.gz 57790 BLAKE2B 1c3c030e84d31dc79ad737b71e63ce6c9218441be04ec94b4144013545e0d7dd79f1e25e51af1811cdd624f2f32b128e5aeb7dbc8d71b21741712733ca4b6d39 SHA512 996555945f4d874cb0fa3c596e6fad9298f7af396c0e94d75b8e9e103d4a2d7dd33ed8af24a218c753117231a0713caa971106f2152bc429d7c8b5c07b00dbc6
diff --git a/net-analyzer/shodan/shodan-1.30.0.ebuild b/net-analyzer/shodan/shodan-1.30.0.ebuild
new file mode 100644
index 000000000000..9fd2907ed8ae
--- /dev/null
+++ b/net-analyzer/shodan/shodan-1.30.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="The official Python library for Shodan"
+HOMEPAGE="https://github.com/achillean/shodan-python"
+
+MY_PN="${PN}-python"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/achillean/shodan-python.git"
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-plugins[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+"
+
+# Test requires API key
+RESTRICT="test"