summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /net-analyzer
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/arping/arping-2.17.ebuild3
-rw-r--r--net-analyzer/arping/arping-2.19.ebuild3
-rw-r--r--net-analyzer/arping/arping-2.20.ebuild1
-rw-r--r--net-analyzer/ettercap/ettercap-0.8.3.ebuild1
-rw-r--r--net-analyzer/ettercap/ettercap-9999.ebuild3
-rw-r--r--net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p10.ebuild3
-rw-r--r--net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p16.ebuild3
-rw-r--r--net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p26.ebuild3
-rw-r--r--net-analyzer/munin/munin-2.0.49.ebuild1
-rw-r--r--net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.3-r1.ebuild1
-rw-r--r--net-analyzer/sslsplit/sslsplit-0.5.4.ebuild1
-rw-r--r--net-analyzer/sslsplit/sslsplit-0.5.5.ebuild1
-rw-r--r--net-analyzer/sslsplit/sslsplit-9999.ebuild1
-rw-r--r--net-analyzer/suricata/suricata-4.0.4.ebuild1
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.9.3.ebuild1
-rw-r--r--net-analyzer/tcpdump/tcpdump-9999.ebuild1
-rw-r--r--net-analyzer/vnstat/vnstat-1.17.ebuild3
-rw-r--r--net-analyzer/vnstat/vnstat-2.3.ebuild1
-rw-r--r--net-analyzer/vnstat/vnstat-2.4.ebuild1
-rw-r--r--net-analyzer/vnstat/vnstat-9999.ebuild1
20 files changed, 27 insertions, 7 deletions
diff --git a/net-analyzer/arping/arping-2.17.ebuild b/net-analyzer/arping/arping-2.17.ebuild
index afd95c1681ba..d835ad002b19 100644
--- a/net-analyzer/arping/arping-2.17.ebuild
+++ b/net-analyzer/arping/arping-2.17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -12,6 +12,7 @@ LICENSE="GPL-2"
SLOT="2"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
IUSE="test"
+RESTRICT="!test? ( test )"
CDEPEND="
net-libs/libpcap
diff --git a/net-analyzer/arping/arping-2.19.ebuild b/net-analyzer/arping/arping-2.19.ebuild
index c31fa81c7b4f..8c07c531c864 100644
--- a/net-analyzer/arping/arping-2.19.ebuild
+++ b/net-analyzer/arping/arping-2.19.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,6 +12,7 @@ LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
IUSE="test"
+RESTRICT="!test? ( test )"
CDEPEND="
net-libs/libpcap
diff --git a/net-analyzer/arping/arping-2.20.ebuild b/net-analyzer/arping/arping-2.20.ebuild
index bfa7e8bc3a8d..2af28124c81d 100644
--- a/net-analyzer/arping/arping-2.20.ebuild
+++ b/net-analyzer/arping/arping-2.20.ebuild
@@ -12,6 +12,7 @@ LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
IUSE="test"
+RESTRICT="!test? ( test )"
CDEPEND="
net-libs/libpcap
diff --git a/net-analyzer/ettercap/ettercap-0.8.3.ebuild b/net-analyzer/ettercap/ettercap-0.8.3.ebuild
index 0efc31c95f97..5a67e97e5162 100644
--- a/net-analyzer/ettercap/ettercap-0.8.3.ebuild
+++ b/net-analyzer/ettercap/ettercap-0.8.3.ebuild
@@ -20,6 +20,7 @@ else
fi
IUSE="doc geoip gtk ipv6 libressl ncurses +plugins test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-libs/libbsd
dev-libs/libpcre
diff --git a/net-analyzer/ettercap/ettercap-9999.ebuild b/net-analyzer/ettercap/ettercap-9999.ebuild
index 504fab9ea4be..8db7873acf3e 100644
--- a/net-analyzer/ettercap/ettercap-9999.ebuild
+++ b/net-analyzer/ettercap/ettercap-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,6 +20,7 @@ else
fi
IUSE="doc gtk ipv6 libressl ncurses +plugins test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-libs/libbsd
dev-libs/libpcre
diff --git a/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p10.ebuild b/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p10.ebuild
index 74f333413356..b36094f1ee3e 100644
--- a/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p10.ebuild
+++ b/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,6 +18,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="examples nagios4 perl python test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="!sys-apps/ucspi-unix:0
diff --git a/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p16.ebuild b/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p16.ebuild
index 611b5856b891..8c27e80b89bc 100644
--- a/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p16.ebuild
+++ b/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p16.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,6 +18,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="examples nagios4 perl python test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="!sys-apps/ucspi-unix:0
diff --git a/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p26.ebuild b/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p26.ebuild
index 3813d1d6918e..a1b4fa136b85 100644
--- a/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p26.ebuild
+++ b/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p26.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,6 +18,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="examples nagios4 perl python test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="!sys-apps/ucspi-unix:0
diff --git a/net-analyzer/munin/munin-2.0.49.ebuild b/net-analyzer/munin/munin-2.0.49.ebuild
index 42bf360e6029..1e0ed2049704 100644
--- a/net-analyzer/munin/munin-2.0.49.ebuild
+++ b/net-analyzer/munin/munin-2.0.49.ebuild
@@ -19,6 +19,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ppc x86"
IUSE="asterisk irc java ldap memcached minimal mysql postgres selinux ssl test cgi ipv6 syslog ipmi http dhcpd doc apache2"
+RESTRICT="!test? ( test )"
REQUIRED_USE="cgi? ( !minimal ) apache2? ( cgi )"
# Upstream's listing of required modules is NOT correct!
diff --git a/net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.3-r1.ebuild b/net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.3-r1.ebuild
index 608ea0ded029..dbb861877c8b 100644
--- a/net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.3-r1.ebuild
+++ b/net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.3-r1.ebuild
@@ -16,6 +16,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
+RESTRICT="!test? ( test )"
S="${WORKDIR}/${MY_PN}-${PV}"
diff --git a/net-analyzer/sslsplit/sslsplit-0.5.4.ebuild b/net-analyzer/sslsplit/sslsplit-0.5.4.ebuild
index af09469872b6..7960cc011edf 100644
--- a/net-analyzer/sslsplit/sslsplit-0.5.4.ebuild
+++ b/net-analyzer/sslsplit/sslsplit-0.5.4.ebuild
@@ -11,6 +11,7 @@ HOMEPAGE="https://www.roe.ch/SSLsplit"
LICENSE="BSD-2"
SLOT="0"
IUSE="elibc_musl test"
+RESTRICT="!test? ( test )"
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
diff --git a/net-analyzer/sslsplit/sslsplit-0.5.5.ebuild b/net-analyzer/sslsplit/sslsplit-0.5.5.ebuild
index 5ea7c49b62cf..2aa8a7e58600 100644
--- a/net-analyzer/sslsplit/sslsplit-0.5.5.ebuild
+++ b/net-analyzer/sslsplit/sslsplit-0.5.5.ebuild
@@ -11,6 +11,7 @@ HOMEPAGE="https://www.roe.ch/SSLsplit"
LICENSE="BSD-2"
SLOT="0"
IUSE="elibc_musl test"
+RESTRICT="!test? ( test )"
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
diff --git a/net-analyzer/sslsplit/sslsplit-9999.ebuild b/net-analyzer/sslsplit/sslsplit-9999.ebuild
index 5ea7c49b62cf..2aa8a7e58600 100644
--- a/net-analyzer/sslsplit/sslsplit-9999.ebuild
+++ b/net-analyzer/sslsplit/sslsplit-9999.ebuild
@@ -11,6 +11,7 @@ HOMEPAGE="https://www.roe.ch/SSLsplit"
LICENSE="BSD-2"
SLOT="0"
IUSE="elibc_musl test"
+RESTRICT="!test? ( test )"
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
diff --git a/net-analyzer/suricata/suricata-4.0.4.ebuild b/net-analyzer/suricata/suricata-4.0.4.ebuild
index 98ed94d5b7d5..2ea320ca46ba 100644
--- a/net-analyzer/suricata/suricata-4.0.4.ebuild
+++ b/net-analyzer/suricata/suricata-4.0.4.ebuild
@@ -13,6 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+af-packet control-socket cuda debug +detection geoip hardened logrotate lua luajit nflog +nfqueue redis +rules test"
+RESTRICT="!test? ( test )"
DEPEND="
>=dev-libs/jansson-2.2
diff --git a/net-analyzer/tcpdump/tcpdump-4.9.3.ebuild b/net-analyzer/tcpdump/tcpdump-4.9.3.ebuild
index 3ea9ef51738d..c4d7bb454a9d 100644
--- a/net-analyzer/tcpdump/tcpdump-4.9.3.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-4.9.3.ebuild
@@ -17,6 +17,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
IUSE="+drop-root libressl smi ssl samba suid test"
+RESTRICT="!test? ( test )"
RDEPEND="
drop-root? ( sys-libs/libcap-ng )
diff --git a/net-analyzer/tcpdump/tcpdump-9999.ebuild b/net-analyzer/tcpdump/tcpdump-9999.ebuild
index f4831f210d9a..52faf660b30f 100644
--- a/net-analyzer/tcpdump/tcpdump-9999.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-9999.ebuild
@@ -14,6 +14,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
IUSE="+drop-root libressl smi ssl samba suid test"
+RESTRICT="!test? ( test )"
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
KEYWORDS=""
diff --git a/net-analyzer/vnstat/vnstat-1.17.ebuild b/net-analyzer/vnstat/vnstat-1.17.ebuild
index d52c53733fd7..d48e9aa70bab 100644
--- a/net-analyzer/vnstat/vnstat-1.17.ebuild
+++ b/net-analyzer/vnstat/vnstat-1.17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,6 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm hppa ppc ppc64 sparc x86"
IUSE="gd selinux test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="
gd? ( media-libs/gd[png] )
diff --git a/net-analyzer/vnstat/vnstat-2.3.ebuild b/net-analyzer/vnstat/vnstat-2.3.ebuild
index c5e123218abe..63dfca4ff73d 100644
--- a/net-analyzer/vnstat/vnstat-2.3.ebuild
+++ b/net-analyzer/vnstat/vnstat-2.3.ebuild
@@ -12,6 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="gd selinux test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="
dev-db/sqlite
diff --git a/net-analyzer/vnstat/vnstat-2.4.ebuild b/net-analyzer/vnstat/vnstat-2.4.ebuild
index 158b3bde0441..3c08307f0cf8 100644
--- a/net-analyzer/vnstat/vnstat-2.4.ebuild
+++ b/net-analyzer/vnstat/vnstat-2.4.ebuild
@@ -12,6 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="gd selinux test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="
dev-db/sqlite
diff --git a/net-analyzer/vnstat/vnstat-9999.ebuild b/net-analyzer/vnstat/vnstat-9999.ebuild
index 0b1d30191127..7299c18fe077 100644
--- a/net-analyzer/vnstat/vnstat-9999.ebuild
+++ b/net-analyzer/vnstat/vnstat-9999.ebuild
@@ -12,6 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="gd selinux test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="
dev-db/sqlite