summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-12-17 07:46:45 +0100
committerHans de Graaff <graaff@gentoo.org>2021-12-17 07:50:06 +0100
commit915992cd41ab50e492b17aa8f4e8e59898841bd3 (patch)
tree265ee6c9b062237c60cae8cb77917479f66a3e7d /net-analyzer/sslscan/sslscan-2.0.11.ebuild
parentdev-ruby/rouge: add 3.27.0 (diff)
downloadgentoo-915992cd41ab50e492b17aa8f4e8e59898841bd3.tar.gz
gentoo-915992cd41ab50e492b17aa8f4e8e59898841bd3.tar.bz2
gentoo-915992cd41ab50e492b17aa8f4e8e59898841bd3.zip
net-analyzer/sslscan: add 2.0.11
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'net-analyzer/sslscan/sslscan-2.0.11.ebuild')
-rw-r--r--net-analyzer/sslscan/sslscan-2.0.11.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/sslscan/sslscan-2.0.11.ebuild b/net-analyzer/sslscan/sslscan-2.0.11.ebuild
new file mode 100644
index 000000000000..52fba6fc3921
--- /dev/null
+++ b/net-analyzer/sslscan/sslscan-2.0.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# sslscan builds against a static openssl library to allow weak ciphers
+# to be enabled so that they can be tested.
+OPENSSL_RELEASE_TAG="OpenSSL_1_1_1m"
+
+DESCRIPTION="Fast SSL configuration scanner"
+HOMEPAGE="https://github.com/rbsec/sslscan"
+SRC_URI="https://github.com/rbsec/sslscan/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/openssl/openssl/archive/${OPENSSL_RELEASE_TAG}.tar.gz -> ${PN}-${OPENSSL_RELEASE_TAG}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Requires a docker environment
+RESTRICT="test"
+
+# S="${WORKDIR}/${P}-${MY_FORK}"
+
+src_prepare() {
+ ln -s ../openssl-${OPENSSL_RELEASE_TAG} openssl || die
+ touch .openssl_is_fresh || die
+ sed -i -e '/openssl\/.git/,/fi/d' \
+ -e '/openssl test/d' Makefile || die
+
+ default
+}
+
+src_compile() {
+ emake static
+}
+
+src_install() {
+ DESTDIR="${D}" emake install
+
+ dodoc Changelog README.md
+}