summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2019-10-22 03:15:01 -0400
committerSam James <sam@gentoo.org>2021-03-15 23:32:09 +0000
commit69c0548447e9e2a35c8cbc897b0579652a116131 (patch)
tree5f62fe163ee18616b72c10ed3c99a3ff9e3023c7 /net-analyzer/netselect
parentnet-analyzer/nethogs: fix adding capabilities (diff)
downloadgentoo-69c0548447e9e2a35c8cbc897b0579652a116131.tar.gz
gentoo-69c0548447e9e2a35c8cbc897b0579652a116131.tar.bz2
gentoo-69c0548447e9e2a35c8cbc897b0579652a116131.zip
net-analyzer/netselect: Bump EAPI to 7
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/netselect')
-rw-r--r--net-analyzer/netselect/netselect-0.4-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/netselect/netselect-0.4-r2.ebuild b/net-analyzer/netselect/netselect-0.4-r2.ebuild
new file mode 100644
index 000000000000..8ac47519b250
--- /dev/null
+++ b/net-analyzer/netselect/netselect-0.4-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Ultrafast implementation of ping"
+HOMEPAGE="http://apenwarr.ca/netselect/"
+SRC_URI="
+ https://github.com/apenwarr/${PN}/archive/${P}.tar.gz
+ ipv6? ( https://dev.gentoo.org/~jer/${P}-ipv6.patch.xz )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ipv6"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4-bsd.patch
+ "${FILESDIR}"/${PN}-0.4-flags.patch
+)
+
+DOCS=( HISTORY README )
+
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+ use ipv6 && eapply "${WORKDIR}"/${PN}-0.4-ipv6.patch
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin netselect
+
+ if ! use prefix ; then
+ fowners root:wheel /usr/bin/netselect
+ fperms 4711 /usr/bin/netselect
+ fi
+
+ einstalldocs
+
+ doman netselect.1
+}