summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/hunt/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/hunt/files')
-rw-r--r--net-analyzer/hunt/files/hunt-1.5-exit.patch10
-rw-r--r--net-analyzer/hunt/files/hunt-1.5-flags.patch21
-rw-r--r--net-analyzer/hunt/files/hunt-1.5-log2.patch22
3 files changed, 53 insertions, 0 deletions
diff --git a/net-analyzer/hunt/files/hunt-1.5-exit.patch b/net-analyzer/hunt/files/hunt-1.5-exit.patch
new file mode 100644
index 000000000000..226093e1795a
--- /dev/null
+++ b/net-analyzer/hunt/files/hunt-1.5-exit.patch
@@ -0,0 +1,10 @@
+--- a/timer.c
++++ b/timer.c
+@@ -8,6 +8,7 @@
+ */
+ #include <stdio.h>
+ #include <unistd.h>
++#include <stdlib.h> /* exit() */
+ #include "hunt.h"
+
+ struct list timejob_list = LIST_INIT(struct timejob, j_next);
diff --git a/net-analyzer/hunt/files/hunt-1.5-flags.patch b/net-analyzer/hunt/files/hunt-1.5-flags.patch
new file mode 100644
index 000000000000..2ffcd823847e
--- /dev/null
+++ b/net-analyzer/hunt/files/hunt-1.5-flags.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,8 +1,7 @@
+-CFLAGS=-Wall -O2 -g -D_REENTRANT
++CFLAGS += -I. -Wall -D_REENTRANT
+ #CFLAGS+=-DSYNC_FAST
+ #CFLAGS+=-D_WITH_LINUX_KERNEL_HDR
+
+-LDFLAGS=
+ #LDFLAGS=-static
+
+ OBJ=hunt.o main.o c/list.o c/hash.o c/array.o util.o net.o \
+@@ -11,7 +10,7 @@
+ addpolicy.o options.o resolv.o timer.o pktrelay.o
+
+ hunt: $(OBJ)
+- $(CC) ${LDFLAGS} -o $@ $^ -lpthread
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ -lpthread
+
+ hunt_static: $(OBJ)
+ $(CC) ${LDFLAGS} -static -o $@ $^ -lpthread
diff --git a/net-analyzer/hunt/files/hunt-1.5-log2.patch b/net-analyzer/hunt/files/hunt-1.5-log2.patch
new file mode 100644
index 000000000000..fc36eaea1f3b
--- /dev/null
+++ b/net-analyzer/hunt/files/hunt-1.5-log2.patch
@@ -0,0 +1,22 @@
+--- a/hunt.h
++++ b/hunt.h
+@@ -401,7 +401,7 @@
+ void set_tty_color_bg(enum TTY_COLOR fg, enum TTY_COLOR bg);
+
+ int is_power2(unsigned int i);
+-int log2(unsigned int i);
++int _hunt_log2(unsigned int i);
+ int count_mask(unsigned int mask);
+
+
+--- a/util.c
++++ b/util.c
+@@ -70,7 +70,7 @@
+ return i ? 0 : 1;
+ }
+
+-int log2(unsigned int i)
++int _hunt_log2(unsigned int i)
+ {
+ int l = 0;
+