summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-03-12 12:10:45 +0100
committerDavid Seifert <soap@gentoo.org>2022-03-12 12:10:45 +0100
commit6d11a60f5eaf6ae85abd0eef4dba9f52785d547c (patch)
tree7f5ccb3333082969e9d756845109628dc0ce8e01 /net-analyzer/gr-fosphor/gr-fosphor-0.0_p20200131-r1.ebuild
parentnet-wireless/limesuite: drop 19.04.0 (diff)
downloadgentoo-6d11a60f5eaf6ae85abd0eef4dba9f52785d547c.tar.gz
gentoo-6d11a60f5eaf6ae85abd0eef4dba9f52785d547c.tar.bz2
gentoo-6d11a60f5eaf6ae85abd0eef4dba9f52785d547c.zip
net-analyzer/gr-fosphor: update EAPI 7 -> 8
Closes: https://bugs.gentoo.org/834127 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer/gr-fosphor/gr-fosphor-0.0_p20200131-r1.ebuild')
-rw-r--r--net-analyzer/gr-fosphor/gr-fosphor-0.0_p20200131-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-analyzer/gr-fosphor/gr-fosphor-0.0_p20200131-r1.ebuild b/net-analyzer/gr-fosphor/gr-fosphor-0.0_p20200131-r1.ebuild
new file mode 100644
index 000000000000..a95757d28db1
--- /dev/null
+++ b/net-analyzer/gr-fosphor/gr-fosphor-0.0_p20200131-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="gnuradio fosphor block (GPU spectrum display)"
+HOMEPAGE="https://sdr.osmocom.org/trac/wiki/fosphor"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/osmocom/${PN}.git"
+else
+ COMMIT="defdd4aca6cd157ccc3b10ea16b5b4f552f34b96"
+ SRC_URI="https://github.com/osmocom/gr-fosphor/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="glfw qt5"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/log4cpp
+ media-libs/freetype
+ =net-wireless/gnuradio-3.8*:0=[qt5,${PYTHON_SINGLE_USEDEP}]
+ glfw? ( >=media-libs/glfw-3 )
+ virtual/opencl
+ virtual/opengl
+ ${PYTHON_DEPS}
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/swig:0"
+
+PATCHES=( "${FILESDIR}"/${P}-htmldir.patch )
+
+src_configure() {
+ # tries to run OpenCL test program, but failing doesn't hurt
+ addpredict /dev/dri
+
+ local mycmakeargs=(
+ -DENABLE_DEFAULT=OFF
+ -DENABLE_GLFW="$(usex glfw)"
+ -DENABLE_QT="$(usex qt5)"
+ -DENABLE_PYTHON=ON
+ )
+ cmake_src_configure
+}