summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-06-21 10:25:15 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-06-21 10:29:43 +0200
commit032d9f3e8f89b760dc4d179a79128ae0490387b7 (patch)
treec7b8759db255461d04e23af5a19d4b2f67dc8fb5 /media-video/v4l2loopback/v4l2loopback-9999.ebuild
parentdev-perl/MIME-Charset: Stabilize 1.13.1 hppa, #908931 (diff)
downloadgentoo-032d9f3e8f89b760dc4d179a79128ae0490387b7.tar.gz
gentoo-032d9f3e8f89b760dc4d179a79128ae0490387b7.tar.bz2
gentoo-032d9f3e8f89b760dc4d179a79128ae0490387b7.zip
media-video/v4l2loopback: migrate to linux-mod-r1.eclass, EAPI bump
This should also fix Bug 843053 (please confirm that it works now) Should also fix the open CVE-2022-2652, the mentioned patch is in this release Bug: https://bugs.gentoo.org/864442 Bug: https://bugs.gentoo.org/843053 Closes: https://bugs.gentoo.org/888649 Closes: https://bugs.gentoo.org/908723 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-video/v4l2loopback/v4l2loopback-9999.ebuild')
-rw-r--r--media-video/v4l2loopback/v4l2loopback-9999.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/media-video/v4l2loopback/v4l2loopback-9999.ebuild b/media-video/v4l2loopback/v4l2loopback-9999.ebuild
index 760951059416..20dda14f748d 100644
--- a/media-video/v4l2loopback/v4l2loopback-9999.ebuild
+++ b/media-video/v4l2loopback/v4l2loopback-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit linux-mod toolchain-funcs
+inherit linux-mod-r1 toolchain-funcs
case ${PV} in
9999)
@@ -11,7 +11,6 @@ case ${PV} in
EGIT_REPO_URI="https://github.com/umlaeute/v4l2loopback.git"
;;
*)
- inherit vcs-snapshot
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/umlaeute/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
;;
@@ -25,11 +24,9 @@ SLOT="0"
IUSE="examples"
CONFIG_CHECK="VIDEO_DEV"
-MODULE_NAMES="v4l2loopback(video:)"
-BUILD_TARGETS="all"
pkg_setup() {
- linux-mod_pkg_setup
+ linux-mod-r1_pkg_setup
export KERNELRELEASE=${KV_FULL}
}
@@ -39,14 +36,18 @@ src_prepare() {
}
src_compile() {
- linux-mod_src_compile
+ local modlist=(
+ v4l2loopback=video:
+ )
+
+ linux-mod-r1_src_compile
if use examples; then
emake CC="$(tc-getCC)" -C examples
fi
}
src_install() {
- linux-mod_src_install
+ linux-mod-r1_src_install
dosbin utils/v4l2loopback-ctl
dodoc doc/kernel_debugging.txt
dodoc doc/docs.txt