summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-05-02 11:08:51 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-05-02 11:09:02 +0200
commit5d5557b178845bd88f3997cefea43b3ba4bf2c91 (patch)
treee7fcc7a90d81faa418c7d1f3559022372904d9d9 /media-sound
parentmedia-video/movit: add 1.7.1 (diff)
downloadgentoo-5d5557b178845bd88f3997cefea43b3ba4bf2c91.tar.gz
gentoo-5d5557b178845bd88f3997cefea43b3ba4bf2c91.tar.bz2
gentoo-5d5557b178845bd88f3997cefea43b3ba4bf2c91.zip
media-sound/qsynth: bump to 0.9.91
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-0.9.91.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index 23a6a818f4c2..604805a1d54e 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1,2 +1,3 @@
DIST qsynth-0.9.13.tar.gz 333132 BLAKE2B 2d0a388e59f244052b1c3f7e16bda40b3de314d2e8b9316b6f471dcc4869299b56f6234c5cecae2a8105c366d601a28cdb0d5c5ebb0bb9e7eee352d62b5af3d0 SHA512 8249438429191a2beb381af9f6fc6bc0d88711c2590379bfa10c558464c562f28453dacec8edbe1afdc590ee437530cefac211b272553cf8acc266706894f17c
DIST qsynth-0.9.90.tar.gz 333577 BLAKE2B 33a9f799423a0c93674ed57f2920f810edaada3ef65ec40594ed29654e6de9550b626b4fe17a2d75dc79fa74f8326ad7d7cd197d4c8d2b2b72ebae0ba10586cd SHA512 f84df48a8bb7d9de56c8380e2fdac3381da78b90e472fb344d84cae552541c0021830b83faf848f48ff23989a51db33fbbab1cfb315ed847950df9e408fd27cf
+DIST qsynth-0.9.91.tar.gz 334833 BLAKE2B 057ebf72aab4ea811046fede9df42ef7ccb7b98018544397e67212d694d7d798761340114a6609c230062791c81050f11c77348674008e09b1c1f9a28ea27f47 SHA512 0749195078e223ae7e42f2fc7d7f435bc174290f9d018ed01ec27088599f5e1e39739b20aa1233368e45336fb6ff74c9f634942e34543a7405f02749dc76446b
diff --git a/media-sound/qsynth/qsynth-0.9.91.ebuild b/media-sound/qsynth/qsynth-0.9.91.ebuild
new file mode 100644
index 000000000000..496e8129a1ca
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.9.91.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop xdg
+
+DESCRIPTION="Qt application to control FluidSynth"
+HOMEPAGE="https://qsynth.sourceforge.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
+ inherit git-r3
+else
+ SRC_URI="https://downloads.sourceforge.net/qsynth/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa debug jack pulseaudio qt6"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+BDEPEND="
+ qt6? ( dev-qt/qttools:6[linguist] )
+ !qt6? ( dev-qt/linguist-tools:5 )
+"
+DEPEND="
+ qt6? (
+ dev-qt/qtbase:6[gui,network,widgets]
+ dev-qt/qtsvg:6
+ )
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )
+ media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ -DCONFIG_QT6=$(usex qt6 1 0)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${D}/usr/share/applications/org.rncbc.qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth org.rncbc.qsynth
+}