summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-18 17:55:47 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-18 17:56:11 -0500
commit5aca3e490b9eb281ad13d30f1e614aef46ede80e (patch)
treebb5845741aca581b068496c378314aaa00633ed4 /media-sound/xmms2
parentapp-emulation/wine-staging: pass -std=gnu17 for gcc15 for now (diff)
downloadgentoo-5aca3e490b9eb281ad13d30f1e614aef46ede80e.tar.gz
gentoo-5aca3e490b9eb281ad13d30f1e614aef46ede80e.tar.bz2
gentoo-5aca3e490b9eb281ad13d30f1e614aef46ede80e.zip
media-sound/xmms2: backport c23 fixes for gcc15
Closes: https://bugs.gentoo.org/943862 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-sound/xmms2')
-rw-r--r--media-sound/xmms2/files/xmms2-0.9.4-c23.patch33
-rw-r--r--media-sound/xmms2/xmms2-0.9.4.ebuild1
2 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/xmms2/files/xmms2-0.9.4-c23.patch b/media-sound/xmms2/files/xmms2-0.9.4-c23.patch
new file mode 100644
index 000000000000..1f74cb4c4a0b
--- /dev/null
+++ b/media-sound/xmms2/files/xmms2-0.9.4-c23.patch
@@ -0,0 +1,33 @@
+https://bugs.gentoo.org/943862
+https://github.com/xmms2/xmms2-devel/commit/b6a6e8c20b
+https://github.com/xmms2/xmms2-devel/commit/fdf542b408
+https://github.com/xmms2/xmms2-devel/commit/5bd52ac2e5
+--- a/src/clients/lib/xmmsclient/service/client.c
++++ b/src/clients/lib/xmmsclient/service/client.c
+@@ -348,6 +348,6 @@
+ xmmsc_sc_interface_entity_t *ifent;
+
+- x_api_error_if (!name, "with NULL name.", false);
+- x_api_error_if (!validate_entity_name (name), "with invalid name", false);
++ x_api_error_if (!name, "with NULL name.", NULL);
++ x_api_error_if (!validate_entity_name (name), "with invalid name", NULL);
+
+ x_return_null_if_fail (parent);
+--- a/src/clients/lib/xmmsclient/visualization/unixshm.c
++++ b/src/clients/lib/xmmsclient/visualization/unixshm.c
+@@ -29,5 +29,5 @@
+ if (t->shmid == -1) {
+ c->error = strdup ("Couldn't create the shared memory!");
+- return false;
++ return NULL;
+ }
+ /* attach early, so that the server doesn't think we aren't there */
+--- a/src/clients/lib/xmmsclient/xmmsclient.c
++++ b/src/clients/lib/xmmsclient/xmmsclient.c
+@@ -223,5 +223,5 @@
+ xmmsc_get_last_error (xmmsc_connection_t *c)
+ {
+- x_api_error_if (!c, "with a NULL connection", false);
++ x_api_error_if (!c, "with a NULL connection", NULL);
+ return c->error;
+ }
diff --git a/media-sound/xmms2/xmms2-0.9.4.ebuild b/media-sound/xmms2/xmms2-0.9.4.ebuild
index 870046b6842d..a4011e18d871 100644
--- a/media-sound/xmms2/xmms2-0.9.4.ebuild
+++ b/media-sound/xmms2/xmms2-0.9.4.ebuild
@@ -133,6 +133,7 @@ QA_CONFIG_IMPL_DECL_SKIP=(
PATCHES=(
"${FILESDIR}"/${PN}-0.9.1-cpp-client.patch
"${FILESDIR}"/${PN}-0.9.1-faad.patch
+ "${FILESDIR}"/${P}-c23.patch
)
src_prepare() {