summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-08-25 15:59:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-08-25 15:59:04 +0200
commitb4375495951bd3383479cdad7c729a40ca4a6378 (patch)
tree6389407c527e4464f570a3f387ace70e9055bb39 /media-sound/volumeicon/volumeicon-0.5.1.ebuild
parentkde-apps/konsole: introduce minimal USE flag for Plasma 5 compatibility. (diff)
downloadgentoo-b4375495951bd3383479cdad7c729a40ca4a6378.tar.gz
gentoo-b4375495951bd3383479cdad7c729a40ca4a6378.tar.bz2
gentoo-b4375495951bd3383479cdad7c729a40ca4a6378.zip
media-sound/volumeicon: bump to 0.5.1.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-sound/volumeicon/volumeicon-0.5.1.ebuild')
-rw-r--r--media-sound/volumeicon/volumeicon-0.5.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-sound/volumeicon/volumeicon-0.5.1.ebuild b/media-sound/volumeicon/volumeicon-0.5.1.ebuild
new file mode 100644
index 000000000000..b6015935f675
--- /dev/null
+++ b/media-sound/volumeicon/volumeicon-0.5.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A lightweight volume control that sits in your systray"
+HOMEPAGE="http://softwarebakery.com/maato/volumeicon.html"
+SRC_URI="http://softwarebakery.com/maato/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/alsa-lib
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog"
+
+src_configure() {
+ # $(use_enable !alsa oss) fails wrt #419891, is likely only for OSS4
+ econf $(use_enable libnotify notify)
+}