summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/ttaenc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/ttaenc')
-rw-r--r--media-sound/ttaenc/Manifest1
-rw-r--r--media-sound/ttaenc/metadata.xml8
-rw-r--r--media-sound/ttaenc/ttaenc-3.4.1-r1.ebuild35
3 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/ttaenc/Manifest b/media-sound/ttaenc/Manifest
new file mode 100644
index 000000000000..2b8ec75b510e
--- /dev/null
+++ b/media-sound/ttaenc/Manifest
@@ -0,0 +1 @@
+DIST ttaenc-3.4.1-src.tgz 20835 SHA256 b2c9c8b015acc5864f082a0157f2e09c5117d1445321cb6178e925b448be3dc6
diff --git a/media-sound/ttaenc/metadata.xml b/media-sound/ttaenc/metadata.xml
new file mode 100644
index 000000000000..af7bf4d5d068
--- /dev/null
+++ b/media-sound/ttaenc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">tta</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/ttaenc/ttaenc-3.4.1-r1.ebuild b/media-sound/ttaenc/ttaenc-3.4.1-r1.ebuild
new file mode 100644
index 000000000000..b705b8361b40
--- /dev/null
+++ b/media-sound/ttaenc/ttaenc-3.4.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="True Audio Compressor Software"
+HOMEPAGE="http://tta.sourceforge.net"
+SRC_URI="mirror://sourceforge/tta/${P}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+
+S=${WORKDIR}/${P}-src
+
+src_prepare() {
+ sed -i -e "s:gcc:$(tc-getCC):g" \
+ -e "s:-o:${LDFLAGS} -o:g" \
+ Makefile || die
+}
+
+src_compile () {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install () {
+ dobin ttaenc
+ dodoc ChangeLog-${PV} README
+}