summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-25 13:45:00 +0100
committerPacho Ramos <pacho@gentoo.org>2015-10-25 13:45:00 +0100
commit075676d66fb8c17de1758e8eb801547e6fa23c75 (patch)
tree6aaf8d998c4da357a2d3e4e1176e0e0eaa26f704 /media-sound/sooperlooper/files
parentgames-strategy/asc: Support wxGTK:3.0 (#563336) (diff)
downloadgentoo-075676d66fb8c17de1758e8eb801547e6fa23c75.tar.gz
gentoo-075676d66fb8c17de1758e8eb801547e6fa23c75.tar.bz2
gentoo-075676d66fb8c17de1758e8eb801547e6fa23c75.zip
media-sound/sooperlooper: Version bump and support wxGTK:3.0 (#563432)
Package-Manager: portage-2.2.23
Diffstat (limited to 'media-sound/sooperlooper/files')
-rw-r--r--media-sound/sooperlooper/files/sooperlooper-1.7.3-sigc++-2.5.patch166
-rw-r--r--media-sound/sooperlooper/files/sooperlooper-1.7.3-wx3.0.patch177
2 files changed, 343 insertions, 0 deletions
diff --git a/media-sound/sooperlooper/files/sooperlooper-1.7.3-sigc++-2.5.patch b/media-sound/sooperlooper/files/sooperlooper-1.7.3-sigc++-2.5.patch
new file mode 100644
index 000000000000..d105e8271407
--- /dev/null
+++ b/media-sound/sooperlooper/files/sooperlooper-1.7.3-sigc++-2.5.patch
@@ -0,0 +1,166 @@
+Description: support for sigc++>=2.5.2
+ since sigc++-2.5.2, the sigc++/object.h has been removed
+ (and replaced by sigc++/trackable.h>
+Author: IOhannes m zmölnig
+Last-Update: 2015-10-21
+Forwarded: Jesse Chappell <jesse@essej.net>
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- sooperlooper.orig/configure.ac
++++ sooperlooper/configure.ac
+@@ -220,7 +220,15 @@
+ AC_SUBST(NCURSES_LIBS)
+
+ dnl sigc++
+- PKG_CHECK_MODULES(SIGCPP, sigc++-2.0 >= 2.2.10)
++ have_sigcpp=no
++ PKG_CHECK_MODULES(SIGCPP, [sigc++-2.0 >= 2.2.10],[have_sigcpp=yes])
++ if test "x${have_sigcpp}" = "xyes"
++ then
++ presigcpp_CFLAGS=$CFLAGS
++ CFLAGS=$CFLAGS $SIGCPP_CFLAGS
++ AC_CHECK_HEADER([sigc++/object.h], [SIGCPP_CFLAGS="$SIGCPP_CFLAGS -DUSE_SIGCPP_OBJECT_H"])
++ CFLAGS=$presigcpp_CFLAGS
++ fi
+
+ AC_SUBST(SIGCPP_LIBS)
+ AC_SUBST(SIGCPP_CFLAGS)
+--- sooperlooper.orig/libs/pbd/configure.ac
++++ sooperlooper/libs/pbd/configure.ac
+@@ -193,7 +193,15 @@
+ PKG_CHECK_MODULES(XML, libxml-2.0 >= 2.5)
+
+ dnl sigc++
+-PKG_CHECK_MODULES(SIGCPP, sigc++-2.0 >= 2.2.10)
++have_sigcpp=no
++PKG_CHECK_MODULES(SIGCPP, [sigc++-2.0 >= 2.2.10],[have_sigcpp=yes])
++if test "x${have_sigcpp}" = "xyes"
++then
++ presigcpp_CFLAGS=$CFLAGS
++ CFLAGS=$CFLAGS $SIGCPP_CFLAGS
++ AC_CHECK_HEADER([sigc++/object.h], [SIGCPP_CFLAGS="$SIGCPP_CFLAGS -DUSE_SIGCPP_OBJECT_H"])
++ CFLAGS=$presigcpp_CFLAGS
++fi
+
+
+ AM_BUILD_ENVIRONMENT
+--- sooperlooper.orig/src/control_osc.hpp
++++ sooperlooper/src/control_osc.hpp
+@@ -27,7 +27,11 @@
+ #include <list>
+ #include <utility>
+
+-#include <sigc++/object.h>
++#ifdef USE_SIGCPP_OBJECT_H
++# include <sigc++/object.h>
++#else
++# include <sigc++/trackable.h>
++#endif
+
+ #include "event.hpp"
+ #include "event_nonrt.hpp"
+--- sooperlooper.orig/src/gui/app_frame.hpp
++++ sooperlooper/src/gui/app_frame.hpp
+@@ -26,7 +26,11 @@
+ #include <string>
+ #include <vector>
+
+-#include <sigc++/object.h>
++#ifdef USE_SIGCPP_OBJECT_H
++# include <sigc++/object.h>
++#else
++# include <sigc++/trackable.h>
++#endif
+ #include <sigc++/signal.h>
+ #include <sigc++/connection.h>
+
+--- sooperlooper.orig/src/gui/config_panel.hpp
++++ sooperlooper/src/gui/config_panel.hpp
+@@ -26,7 +26,11 @@
+
+ #include <string>
+ #include <vector>
+-#include <sigc++/object.h>
++#ifdef USE_SIGCPP_OBJECT_H
++# include <sigc++/object.h>
++#else
++# include <sigc++/trackable.h>
++#endif
+
+ class wxListCtrl;
+ class wxSpinCtrl;
+--- sooperlooper.orig/src/gui/keys_panel.hpp
++++ sooperlooper/src/gui/keys_panel.hpp
+@@ -26,7 +26,11 @@
+
+ #include <string>
+ #include <vector>
+-#include <sigc++/object.h>
++#ifdef USE_SIGCPP_OBJECT_H
++# include <sigc++/object.h>
++#else
++# include <sigc++/trackable.h>
++#endif
+
+ class wxListCtrl;
+
+--- sooperlooper.orig/src/gui/latency_panel.hpp
++++ sooperlooper/src/gui/latency_panel.hpp
+@@ -26,7 +26,11 @@
+
+ #include <string>
+ #include <vector>
+-#include <sigc++/object.h>
++#ifdef USE_SIGCPP_OBJECT_H
++# include <sigc++/object.h>
++#else
++# include <sigc++/trackable.h>
++#endif
+
+ class wxListCtrl;
+
+--- sooperlooper.orig/src/gui/main_panel.hpp
++++ sooperlooper/src/gui/main_panel.hpp
+@@ -26,7 +26,11 @@
+ #include <string>
+ #include <vector>
+
+-#include <sigc++/object.h>
++#ifdef USE_SIGCPP_OBJECT_H
++# include <sigc++/object.h>
++#else
++# include <sigc++/trackable.h>
++#endif
+ #include <sigc++/signal.h>
+ #include <sigc++/connection.h>
+
+--- sooperlooper.orig/src/gui/midi_bind_panel.hpp
++++ sooperlooper/src/gui/midi_bind_panel.hpp
+@@ -26,7 +26,11 @@
+
+ #include <string>
+ #include <vector>
+-#include <sigc++/object.h>
++#ifdef USE_SIGCPP_OBJECT_H
++# include <sigc++/object.h>
++#else
++# include <sigc++/trackable.h>
++#endif
+ #include <list>
+
+ #include <midi_bind.hpp>
+--- sooperlooper.orig/src/gui/prefs_dialog.hpp
++++ sooperlooper/src/gui/prefs_dialog.hpp
+@@ -26,7 +26,11 @@
+
+ #include <string>
+ #include <vector>
+-#include <sigc++/object.h>
++#ifdef USE_SIGCPP_OBJECT_H
++# include <sigc++/object.h>
++#else
++# include <sigc++/trackable.h>
++#endif
+
+ class wxListCtrl;
+ class wxSpinCtrl;
diff --git a/media-sound/sooperlooper/files/sooperlooper-1.7.3-wx3.0.patch b/media-sound/sooperlooper/files/sooperlooper-1.7.3-wx3.0.patch
new file mode 100644
index 000000000000..fee40e8f98be
--- /dev/null
+++ b/media-sound/sooperlooper/files/sooperlooper-1.7.3-wx3.0.patch
@@ -0,0 +1,177 @@
+Author: Jaromír Mikeš <mira.mikes@seznam.cz>, Olly Betts <olly@survex.com>
+Description: build against wx 3.0.
+Forwarded: yes
+
+Index: sooperlooper/src/gui/main_panel.cpp
+===================================================================
+--- sooperlooper.orig/src/gui/main_panel.cpp
++++ sooperlooper/src/gui/main_panel.cpp
+@@ -448,7 +448,7 @@ MainPanel::init_loopers (int count)
+ while (count < (int)_looper_panels.size()) {
+ looperpan = _looper_panels.back();
+ _looper_panels.pop_back();
+- _main_sizer->Remove(looperpan);
++ _main_sizer->Detach(looperpan);
+ looperpan->Destroy();
+ }
+ }
+@@ -1277,7 +1277,7 @@ void MainPanel::misc_action (bool releas
+ }
+
+
+- wxString filename = do_file_selector (wxT("Choose file to save loop"), wxT("wav"), wxT("WAVE files (*.wav)|*.wav;*.WAV;*.Wav"), wxSAVE|wxCHANGE_DIR|wxOVERWRITE_PROMPT);
++ wxString filename = do_file_selector (wxT("Choose file to save loop"), wxT("wav"), wxT("WAVE files (*.wav)|*.wav;*.WAV;*.Wav"), wxFD_SAVE|wxFD_CHANGE_DIR|wxFD_OVERWRITE_PROMPT);
+
+ if ( !filename.empty() )
+ {
+@@ -1296,7 +1296,7 @@ void MainPanel::misc_action (bool releas
+ index = 0;
+ }
+
+- wxString filename = do_file_selector (wxT("Choose file to open"), wxT(""), wxT("*.slsess"), wxOPEN|wxCHANGE_DIR);
++ wxString filename = do_file_selector (wxT("Choose file to open"), wxT(""), wxT("*.slsess"), wxFD_OPEN|wxFD_CHANGE_DIR);
+
+ if ( !filename.empty() )
+ {
+@@ -1408,7 +1408,7 @@ void MainPanel::set_curr_loop (int index
+
+ void MainPanel::do_load_session ()
+ {
+- wxString filename = do_file_selector (wxT("Choose session to load"), wxT("*.slsess"), wxT("*.slsess"), wxOPEN|wxCHANGE_DIR);
++ wxString filename = do_file_selector (wxT("Choose session to load"), wxT("*.slsess"), wxT("*.slsess"), wxFD_OPEN|wxFD_CHANGE_DIR);
+
+ if ( !filename.empty() )
+ {
+@@ -1419,7 +1419,7 @@ void MainPanel::do_load_session ()
+
+ void MainPanel::do_save_session (bool write_audio)
+ {
+- wxString filename = do_file_selector (wxT("Choose file to save session"), wxT("slsess"), wxT("*.slsess"), wxSAVE|wxCHANGE_DIR|wxOVERWRITE_PROMPT);
++ wxString filename = do_file_selector (wxT("Choose file to save session"), wxT("slsess"), wxT("*.slsess"), wxFD_SAVE|wxFD_CHANGE_DIR|wxFD_OVERWRITE_PROMPT);
+
+ if ( !filename.empty() )
+ {
+Index: sooperlooper/src/gui/pix_button.cpp
+===================================================================
+--- sooperlooper.orig/src/gui/pix_button.cpp
++++ sooperlooper/src/gui/pix_button.cpp
+@@ -250,7 +250,7 @@ PixButton::OnMouseEvents (wxMouseEvent &
+ pt.x += bounds.x;
+ pt.y += bounds.y;
+
+- if (bounds.Inside(pt)) {
++ if (bounds.Contains(pt)) {
+ clicked (get_mouse_button(ev)); // emit
+
+ if (ev.MiddleUp() && ev.ControlDown()) {
+Index: sooperlooper/src/gui/looper_panel.cpp
+===================================================================
+--- sooperlooper.orig/src/gui/looper_panel.cpp
++++ sooperlooper/src/gui/looper_panel.cpp
+@@ -1428,7 +1428,7 @@ LooperPanel::clicked_events (int button,
+ if (cmd == wxT("save"))
+ {
+ wxString filename = _mainpanel->do_file_selector (wxT("Choose file to save loop"),
+- wxT("wav"), wxT("WAVE files (*.wav)|*.wav;*.WAV;*.Wav"), wxSAVE|wxCHANGE_DIR|wxOVERWRITE_PROMPT);
++ wxT("wav"), wxT("WAVE files (*.wav)|*.wav;*.WAV;*.Wav"), wxFD_SAVE|wxFD_CHANGE_DIR|wxFD_OVERWRITE_PROMPT);
+
+ if ( !filename.empty() )
+ {
+@@ -1442,7 +1442,7 @@ LooperPanel::clicked_events (int button,
+ }
+ else if (cmd == wxT("load"))
+ {
+- wxString filename = _mainpanel->do_file_selector(wxT("Choose file to open"), wxT(""), wxT("Audio files (*.wav,*.aif)|*.wav;*.WAV;*.Wav;*.aif;*.aiff;*.AIF;*.AIFF|All files (*.*)|*.*"), wxOPEN|wxCHANGE_DIR);
++ wxString filename = _mainpanel->do_file_selector(wxT("Choose file to open"), wxT(""), wxT("Audio files (*.wav,*.aif)|*.wav;*.WAV;*.Wav;*.aif;*.aiff;*.AIF;*.AIFF|All files (*.*)|*.*"), wxFD_OPEN|wxFD_CHANGE_DIR);
+
+ if ( !filename.empty() )
+ {
+Index: sooperlooper/src/gui/keyboard_target.cpp
+===================================================================
+--- sooperlooper.orig/src/gui/keyboard_target.cpp
++++ sooperlooper/src/gui/keyboard_target.cpp
+@@ -553,10 +553,10 @@ KeyboardTarget::keycode_from_name (const
+ keycode = WXK_RETURN;
+ }
+ else if ( keyname == wxT("PGUP") ) {
+- keycode = WXK_PRIOR;
++ keycode = WXK_PAGEUP;
+ }
+ else if ( keyname == wxT("PGDN") ) {
+- keycode = WXK_NEXT;
++ keycode = WXK_PAGEDOWN;
+ }
+ else if ( keyname == wxT("LEFT") ) {
+ keycode = WXK_LEFT;
+@@ -630,10 +630,10 @@ wxString KeyboardTarget::name_from_keyco
+ case WXK_RETURN:
+ text += wxT("return");
+ break;
+- case WXK_PRIOR:
++ case WXK_PAGEUP:
+ text += wxT("pageup");
+ break;
+- case WXK_NEXT:
++ case WXK_PAGEDOWN:
+ text += wxT("pagedown");
+ break;
+ case WXK_LEFT:
+Index: sooperlooper/src/gui/check_box.cpp
+===================================================================
+--- sooperlooper.orig/src/gui/check_box.cpp
++++ sooperlooper/src/gui/check_box.cpp
+@@ -237,7 +237,7 @@ CheckBox::OnMouseEvents (wxMouseEvent &e
+ }
+ else if (ev.LeftUp())
+ {
+- if (bounds.Inside(ev.GetPosition())) {
++ if (bounds.Contains(ev.GetPosition())) {
+ // toggle value
+ _value = !_value;
+
+Index: sooperlooper/src/gui/midi_bind_panel.cpp
+===================================================================
+--- sooperlooper.orig/src/gui/midi_bind_panel.cpp
++++ sooperlooper/src/gui/midi_bind_panel.cpp
+@@ -880,7 +880,7 @@ void MidiBindPanel::on_button (wxCommand
+ }
+ else if (ev.GetId() == ID_LoadButton)
+ {
+- wxString filename = _parent->do_file_selector(wxT("Choose midi binding file to open"), wxT(""), wxT("*.slb"), wxOPEN|wxCHANGE_DIR);
++ wxString filename = _parent->do_file_selector(wxT("Choose midi binding file to open"), wxT(""), wxT("*.slb"), wxFD_OPEN|wxFD_CHANGE_DIR);
+ if ( !filename.empty() )
+ {
+ _parent->get_loop_control().load_midi_bindings(filename, _append_check->GetValue());
+@@ -888,7 +888,7 @@ void MidiBindPanel::on_button (wxCommand
+ }
+ else if (ev.GetId() == ID_SaveButton)
+ {
+- wxString filename = _parent->do_file_selector(wxT("Choose midi binding file to save"), wxT(""), wxT("*.slb"), wxSAVE|wxCHANGE_DIR|wxOVERWRITE_PROMPT);
++ wxString filename = _parent->do_file_selector(wxT("Choose midi binding file to save"), wxT(""), wxT("*.slb"), wxFD_SAVE|wxFD_CHANGE_DIR|wxFD_OVERWRITE_PROMPT);
+
+ if ( !filename.empty() )
+ {
+Index: sooperlooper/src/gui/config_panel.cpp
+===================================================================
+--- sooperlooper.orig/src/gui/config_panel.cpp
++++ sooperlooper/src/gui/config_panel.cpp
+@@ -378,7 +378,7 @@ void ConfigPanel::on_button (wxCommandEv
+ else if (ev.GetId() == ID_MidiBrowseButton) {
+
+ _parent->get_keyboard().set_enabled(false);
+- wxString filename = _parent->do_file_selector(wxT("Choose midi binding file to use"), wxT(""), wxT("*.slb"), wxOPEN|wxCHANGE_DIR);
++ wxString filename = _parent->do_file_selector(wxT("Choose midi binding file to use"), wxT(""), wxT("*.slb"), wxFD_OPEN|wxFD_CHANGE_DIR);
+ _parent->get_keyboard().set_enabled(true);
+
+ if ( !filename.empty() )
+@@ -389,8 +389,8 @@ void ConfigPanel::on_button (wxCommandEv
+ else if (ev.GetId() == ID_SessionBrowseButton) {
+
+ _parent->get_keyboard().set_enabled(false);
+- wxString filename = _parent->do_file_selector(wxT("Choose session file to use"), wxT(""), wxT("*.slsess"), wxOPEN|wxCHANGE_DIR);
+- //wxString filename = wxFileSelector(wxT("Choose session file to use"), wxT(""), wxT(""), wxT(""), wxT("*.slsess"), wxOPEN|wxCHANGE_DIR);
++ wxString filename = _parent->do_file_selector(wxT("Choose session file to use"), wxT(""), wxT("*.slsess"), wxFD_OPEN|wxFD_CHANGE_DIR);
++ //wxString filename = wxFileSelector(wxT("Choose session file to use"), wxT(""), wxT(""), wxT(""), wxT("*.slsess"), wxFD_OPEN|wxFD_CHANGE_DIR);
+ _parent->get_keyboard().set_enabled(true);
+
+ if ( !filename.empty() )