summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-08-04 23:55:49 +0200
committerDavid Seifert <soap@gentoo.org>2022-08-04 23:55:49 +0200
commit9c803a5a68101609c211acb93837f44177d10f89 (patch)
treec95b8a4e0251c1bde4a4206b6f281cac6e914981 /media-sound/podracer
parentmedia-sound/gmorgan: update EAPI 6 -> 8 (diff)
downloadgentoo-9c803a5a68101609c211acb93837f44177d10f89.tar.gz
gentoo-9c803a5a68101609c211acb93837f44177d10f89.tar.bz2
gentoo-9c803a5a68101609c211acb93837f44177d10f89.zip
media-sound/podracer: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/podracer')
-rw-r--r--media-sound/podracer/podracer-1.4-r2.ebuild37
-rw-r--r--media-sound/podracer/podracer-1.4-r3.ebuild42
2 files changed, 42 insertions, 37 deletions
diff --git a/media-sound/podracer/podracer-1.4-r2.ebuild b/media-sound/podracer/podracer-1.4-r2.ebuild
deleted file mode 100644
index 35df96ec5d56..000000000000
--- a/media-sound/podracer/podracer-1.4-r2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A simple podcast aggregator, designed for cron"
-HOMEPAGE="http://podracer.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="app-shells/bash
- net-misc/curl"
-
-src_unpack() {
- default
-
- # Bug 619956. Change directories first to ensure that "unpack" outputs
- # to ${S} and not to ${WORKDIR}.
- cd "${S}" || die
- unpack "${S}/podracer.1.gz"
-}
-
-src_install() {
- dobin podracer
- sed -i -e "s:sample=/usr/share/doc/\$progname/sample.subscriptions:sample=/usr/share/doc/${PF}/sample.subscriptions:" "${D}"/usr/bin/podracer || die
- dodoc CREDITS README ChangeLog TODO
- doman podracer.1
- docompress -x "/usr/share/doc/${PF}/sample.subscriptions"
- dodoc sample.subscriptions
- insinto /etc/
- doins podracer.conf
-}
diff --git a/media-sound/podracer/podracer-1.4-r3.ebuild b/media-sound/podracer/podracer-1.4-r3.ebuild
new file mode 100644
index 000000000000..4a6f563736bd
--- /dev/null
+++ b/media-sound/podracer/podracer-1.4-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A simple podcast aggregator, designed for cron"
+HOMEPAGE="http://podracer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ app-shells/bash
+ net-misc/curl"
+
+src_unpack() {
+ default
+
+ # Bug 619956. Change directories first to ensure that
+ # "unpack" outputs to ${S} and not to ${WORKDIR}.
+ cd "${S}" || die
+ unpack "${S}"/podracer.1.gz
+}
+
+src_prepare() {
+ default
+ sed -e "s:sample=/usr/share/doc/\$progname/sample.subscriptions:sample=/usr/share/doc/${PF}/sample.subscriptions:" \
+ -i podracer || die
+}
+
+src_install() {
+ dobin podracer
+
+ dodoc CREDITS README ChangeLog TODO sample.subscriptions
+ docompress -x /usr/share/doc/${PF}/sample.subscriptions
+ doman podracer.1
+
+ insinto /etc
+ doins podracer.conf
+}