summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsqozz <sqozz@geekify.de>2017-09-01 21:35:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-11 22:02:53 +0100
commit798b39d002de345abe0eaae950a3a3c89192d76e (patch)
tree2057766b3bcee5f6939dfed4ff3976f44527db2a /media-sound/mpd
parentx11-plugins/allin1: remove unused allin1-0.5.0.ebuild. (diff)
downloadgentoo-798b39d002de345abe0eaae950a3a3c89192d76e.tar.gz
gentoo-798b39d002de345abe0eaae950a3a3c89192d76e.tar.bz2
gentoo-798b39d002de345abe0eaae950a3a3c89192d76e.zip
media-sound/mpd: Add webdav use flag
Committer-comment: Added missing IUSE description and curl REQUIRED_USE. Closes: https://bugs.gentoo.org/629564
Diffstat (limited to 'media-sound/mpd')
-rw-r--r--media-sound/mpd/metadata.xml1
-rw-r--r--media-sound/mpd/mpd-0.20.10.ebuild4
2 files changed, 4 insertions, 1 deletions
diff --git a/media-sound/mpd/metadata.xml b/media-sound/mpd/metadata.xml
index a824cdeb5ff0..44d02733ce25 100644
--- a/media-sound/mpd/metadata.xml
+++ b/media-sound/mpd/metadata.xml
@@ -35,6 +35,7 @@
<flag name="soundcloud">Build plugin to access soundcloud</flag>
<flag name="systemd">Enable support for systemd socket activation</flag>
<flag name="twolame">Support twolame MPEG-2 encoding</flag>
+ <flag name="webdav">Enable using music from a WebDAV share</flag>
<flag name="wildmidi">Enable MIDI support via wildmidi</flag>
<flag name="zip">Support for ZIP files</flag>
</use>
diff --git a/media-sound/mpd/mpd-0.20.10.ebuild b/media-sound/mpd/mpd-0.20.10.ebuild
index 7e3851e85edd..dcde1d4cc468 100644
--- a/media-sound/mpd/mpd-0.20.10.ebuild
+++ b/media-sound/mpd/mpd-0.20.10.ebuild
@@ -17,7 +17,7 @@ IUSE="adplug +alsa ao audiofile bzip2 cdio +curl debug +eventfd expat faad
lame mms libav libmpdclient libsamplerate libsoxr +mad mikmod modplug
mpg123 musepack +network nfs ogg openal opus oss pipe pulseaudio recorder
samba selinux sid +signalfd sndfile soundcloud sqlite systemd tcpd twolame
- unicode upnp vorbis wavpack wildmidi zeroconf zip zlib"
+ unicode upnp vorbis wavpack wildmidi zeroconf zip zlib webdav"
OUTPUT_PLUGINS="alsa ao fifo jack network openal oss pipe pulseaudio recorder"
DECODER_PLUGINS="adplug audiofile faad ffmpeg flac fluidsynth mad mikmod
@@ -31,6 +31,7 @@ REQUIRED_USE="
recorder? ( || ( ${ENCODER_PLUGINS} ) )
opus? ( ogg )
upnp? ( expat )
+ webdav? ( curl expat )
"
CDEPEND="!<sys-cluster/mpich2-1.4_rc2
@@ -220,6 +221,7 @@ src_configure() {
$(use_enable wildmidi)
$(use_enable zip zzip)
$(use_enable icu)
+ $(use_enable webdav)
$(use_enable faad aac)
$(use_with zeroconf zeroconf avahi)
--with-systemdsystemunitdir=$(systemd_get_systemunitdir)