summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/lingot/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/lingot/files')
-rw-r--r--media-sound/lingot/files/lingot-0.7.6-clean-install.patch24
-rw-r--r--media-sound/lingot/files/lingot-0.9.0-jack.patch32
-rw-r--r--media-sound/lingot/files/lingot-0.9.1-clean-install.patch23
3 files changed, 79 insertions, 0 deletions
diff --git a/media-sound/lingot/files/lingot-0.7.6-clean-install.patch b/media-sound/lingot/files/lingot-0.7.6-clean-install.patch
new file mode 100644
index 000000000000..688aea188efd
--- /dev/null
+++ b/media-sound/lingot/files/lingot-0.7.6-clean-install.patch
@@ -0,0 +1,24 @@
+diff -ur lingot-0.7.6.orig/Makefile.am lingot-0.7.6/Makefile.am
+--- lingot-0.7.6.orig/Makefile.am 2007-12-23 21:45:19.000000000 +0200
++++ lingot-0.7.6/Makefile.am 2008-05-08 13:00:18.000000000 +0300
+@@ -8,19 +8,12 @@
+ lingotdocdir = ${docdir}
+ lingotdoc_DATA = \
+ README\
+- COPYING\
+ AUTHORS\
+ ChangeLog\
+- INSTALL\
+ NEWS\
+ TODO\
+ THANKS\
+- MAINTAINERS\
+- src/lingot-background.xpm\
+- src/lingot-logo.xpm\
+- intltool-extract.in\
+- intltool-merge.in\
+- intltool-update.in
++ MAINTAINERS
+
+ EXTRA_DIST = $(lingotdoc_DATA)
+
diff --git a/media-sound/lingot/files/lingot-0.9.0-jack.patch b/media-sound/lingot/files/lingot-0.9.0-jack.patch
new file mode 100644
index 000000000000..c7885a4098e0
--- /dev/null
+++ b/media-sound/lingot/files/lingot-0.9.0-jack.patch
@@ -0,0 +1,32 @@
+--- a/src/lingot-audio-jack.c
++++ b/src/lingot-audio-jack.c
+@@ -177,7 +177,7 @@
+ const char **ports = NULL;
+ const char* exception;
+
+- unsigned long int flags = JackPortIsActive | JackPortIsOutput;
++ unsigned long int flags = JackPortIsOutput;
+
+ try {
+ if (client != NULL) {
+@@ -265,8 +265,9 @@
+ throw(_("Cannot activate client"));
+ }
+
+- ports = jack_get_ports(audio->jack_client, NULL, NULL, JackPortIsActive
+- | JackPortIsOutput);
++ ports
++ = jack_get_ports(audio->jack_client, NULL, NULL,
++ JackPortIsOutput);
+ if (ports == NULL) {
+ throw(_("No active capture ports"));
+ }
+@@ -321,7 +322,7 @@
+ # ifdef JACK
+ //jack_cycle_wait(audio->jack_client);
+ const char** ports = jack_get_ports(audio->jack_client, NULL, NULL,
+- JackPortIsActive | JackPortIsOutput);
++ JackPortIsOutput);
+
+ if (ports != NULL) {
+ int i, j = 0;
diff --git a/media-sound/lingot/files/lingot-0.9.1-clean-install.patch b/media-sound/lingot/files/lingot-0.9.1-clean-install.patch
new file mode 100644
index 000000000000..826a9fd29ce2
--- /dev/null
+++ b/media-sound/lingot/files/lingot-0.9.1-clean-install.patch
@@ -0,0 +1,23 @@
+--- lingot-0.9.1.orig/Makefile.am
++++ lingot-0.9.1/Makefile.am
+@@ -8,19 +8,11 @@
+ lingotdocdir = ${docdir}
+ lingotdoc_DATA = \
+ README\
+- COPYING\
+ AUTHORS\
+ ChangeLog\
+- INSTALL\
+ NEWS\
+- TODO\
+ THANKS\
+- MAINTAINERS\
+- src/lingot-background.xpm\
+- src/lingot-logo.xpm\
+- intltool-extract.in\
+- intltool-merge.in\
+- intltool-update.in
++ MAINTAINERS
+
+ EXTRA_DIST = $(lingotdoc_DATA)
+