summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-06-15 17:41:43 +0000
committerSam James <sam@gentoo.org>2023-06-17 04:11:03 +0100
commit1824ebce68da2dc8b4d2fef2ae513c36a912275d (patch)
treede4106c6a551a981f21e7297806413dd685f27c3 /media-sound/helm/helm-0.9.0-r2.ebuild
parentx11-wm/qtile: downgrade cairocffi dependency for 0.22.1 (diff)
downloadgentoo-1824ebce68da2dc8b4d2fef2ae513c36a912275d.tar.gz
gentoo-1824ebce68da2dc8b4d2fef2ae513c36a912275d.tar.bz2
gentoo-1824ebce68da2dc8b4d2fef2ae513c36a912275d.zip
media-sound/helm: Fix build on musl
Fixes three different issues with the bundled copy of JUCE in helm. First, it conditions the usage of execinfo.h behind __GLIBC__ being defined when on linux. Second, it removes the usage of lfs64 interfaces and defines _FILE_OFFSET_BITS=64. Third, it conditions the usage of _NL_IDENTIFICATION_LANGUAGE and _NL_IDENTIFICATION_TERRITORY behind ifdefs, since musl does not define them. Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/31463 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/helm/helm-0.9.0-r2.ebuild')
-rw-r--r--media-sound/helm/helm-0.9.0-r2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/helm/helm-0.9.0-r2.ebuild b/media-sound/helm/helm-0.9.0-r2.ebuild
new file mode 100644
index 000000000000..46ef109dc534
--- /dev/null
+++ b/media-sound/helm/helm-0.9.0-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg
+
+DESCRIPTION="Open source polyphonic software synthesizer with lots of modulation"
+HOMEPAGE="https://tytel.org/helm/"
+SRC_URI="https://github.com/mtytel/helm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND="
+ media-libs/alsa-lib
+ media-libs/freetype
+ media-libs/lv2
+ virtual/jack
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXrandr"
+RDEPEND="${DEPEND}
+ !app-admin/helm
+"
+
+DOCS=( changelog README.md )
+
+PATCHES=(
+ "${FILESDIR}/${P}-nomancompress.patch"
+ "${FILESDIR}/${P}-fix-gcc91.patch"
+ "${FILESDIR}/${P}-musl.patch"
+)
+
+src_prepare() {
+ default
+ sed -e "s|/usr/lib/|/usr/$(get_libdir)/|" -i Makefile || die "Failed to fix libdir"
+ sed -e "s|^\(CHANGES.*\)/|\1-${PVR}|" -i Makefile || die "Failed to fix doc path"
+}
+
+src_compile() {
+ emake PREFIX=/usr all
+}
+
+src_install() {
+ default
+ make_desktop_entry /usr/bin/helm Helm /usr/share/helm/icons/helm_icon_32_1x.png
+}