summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2019-04-16 00:30:25 +0300
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-04-20 22:01:30 -0700
commitfd37b5281bd4d5e79dae6bb9397d0046dd71bda9 (patch)
treee8f92bba8fc55cfe7e1b277b0306b6241b2bc8e0 /media-sound/guitarix
parentmedia-libs/zita-resampler: new package (diff)
downloadgentoo-fd37b5281bd4d5e79dae6bb9397d0046dd71bda9.tar.gz
gentoo-fd37b5281bd4d5e79dae6bb9397d0046dd71bda9.tar.bz2
gentoo-fd37b5281bd4d5e79dae6bb9397d0046dd71bda9.zip
media-sound/guitarix: new package
guitarix is a virtual guitar amplifier for Linux Ebuild by me with some additions from ebuild by Reva Denis and ebuild from gentoostudio overlay. Closes: https://bugs.gentoo.org/254707 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11703 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'media-sound/guitarix')
-rw-r--r--media-sound/guitarix/Manifest1
-rw-r--r--media-sound/guitarix/guitarix-0.38.1.ebuild73
-rw-r--r--media-sound/guitarix/metadata.xml19
3 files changed, 93 insertions, 0 deletions
diff --git a/media-sound/guitarix/Manifest b/media-sound/guitarix/Manifest
new file mode 100644
index 000000000000..52c41818c5c3
--- /dev/null
+++ b/media-sound/guitarix/Manifest
@@ -0,0 +1 @@
+DIST guitarix2-0.38.1.tar.xz 80768608 BLAKE2B fd745955d8b44da72c669e69c36294d4a2131f2b5868e7e254a0b33768852ba9fcf9302f2a7ebd962c8a6dc02a543f70574466c51341a371c9fb988989123e50 SHA512 54d08b4ed20b9df4c69d0c86e4d668c53fffde8919f5570f376cee903926bd01945169d177d0d45976569ea55b28f8dca7884ac6dfe2f063df6583467559c5b7
diff --git a/media-sound/guitarix/guitarix-0.38.1.ebuild b/media-sound/guitarix/guitarix-0.38.1.ebuild
new file mode 100644
index 000000000000..a35bae00fe20
--- /dev/null
+++ b/media-sound/guitarix/guitarix-0.38.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit python-any-r1 waf-utils xdg
+
+MY_P="${PN}2-${PV}"
+
+DESCRIPTION="Virtual guitar amplifier for Linux"
+HOMEPAGE="http://guitarix.org/"
+SRC_URI="mirror://sourceforge/guitarix/guitarix/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="bluetooth debug lv2 nls +standalone zeroconf"
+REQUIRED_USE="|| ( lv2 standalone )"
+
+COMMON_DEPEND="dev-cpp/eigen:3
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-libs/glib:2
+ >=media-libs/libsndfile-1.0.17
+ >=media-libs/zita-convolver-3
+ media-libs/zita-resampler
+ >=net-misc/curl-7.26.0
+ >=sci-libs/fftw-3.1.2:3.0=
+ x11-libs/gtk+:2
+ lv2? ( media-libs/lv2 )
+ standalone? (
+ dev-libs/boost:=
+ media-libs/liblrdf
+ media-libs/lilv
+ virtual/jack
+ bluetooth? ( net-wireless/bluez )
+ zeroconf? ( net-dns/avahi )
+ )
+"
+# clearlooks gtk engine and roboto fonts are required for correct ui rendering
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/gtk-engines
+ standalone? (
+ media-fonts/roboto
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ nls? ( dev-util/intltool )
+"
+
+DOCS=( changelog README )
+
+src_configure() {
+ waf-utils_src_configure \
+ --cxxflags-debug="" \
+ --cxxflags-release="-DNDEBUG" \
+ --ldflags="${LDFLAGS}" \
+ --enable-lfs \
+ --lib-dev \
+ --no-desktop-update \
+ --no-faust \
+ --no-ldconfig \
+ --shared-lib \
+ $(use_enable nls) \
+ $(usex bluetooth "" "--no-bluez") \
+ $(usex debug "--debug" "") \
+ $(usex lv2 "--lv2dir=${EPREFIX}/usr/$(get_libdir)/lv2" "--no-lv2 --no-lv2-gui") \
+ $(usex standalone "" "--no-standalone") \
+ $(usex zeroconf "" "--no-avahi")
+}
diff --git a/media-sound/guitarix/metadata.xml b/media-sound/guitarix/metadata.xml
new file mode 100644
index 000000000000..567aa7cf7675
--- /dev/null
+++ b/media-sound/guitarix/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexander@tsoy.me</email>
+ <name>Alexander Tsoy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ guitarix is a virtual guitar amplifier for Linux running on Jack Audio Connection Kit
+ </longdescription>
+ <use>
+ <flag name="lv2">Build lv2 plugins</flag>
+ <flag name="standalone">Build standalone application</flag>
+ </use>
+</pkgmetadata>