summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-17 23:56:11 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-18 00:10:35 +0100
commitf7bad51a4cf9b76f1859cee8aff0e1086d73a64b (patch)
tree4ed622cf108e7fc47643d64412311e798314ebc1 /media-sound/clementine/files
parentmedia-sound/clementine: DEPEND on >=media-libs/taglib-1.11.1_p20181028 (diff)
downloadgentoo-f7bad51a4cf9b76f1859cee8aff0e1086d73a64b.tar.gz
gentoo-f7bad51a4cf9b76f1859cee8aff0e1086d73a64b.tar.bz2
gentoo-f7bad51a4cf9b76f1859cee8aff0e1086d73a64b.zip
media-sound/clementine: 1.3.1_p20181112 snapshot bump
Bug: https://bugs.gentoo.org/658808 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/clementine/files')
-rw-r--r--media-sound/clementine/files/clementine-1.3.1_p20181112-no-dbus.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/clementine/files/clementine-1.3.1_p20181112-no-dbus.patch b/media-sound/clementine/files/clementine-1.3.1_p20181112-no-dbus.patch
new file mode 100644
index 000000000000..d03db2451ad3
--- /dev/null
+++ b/media-sound/clementine/files/clementine-1.3.1_p20181112-no-dbus.patch
@@ -0,0 +1,41 @@
+From d940136d0ae2a98ea72d842df0099bebcd361426 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Fri, 2 Nov 2018 12:58:08 +0100
+Subject: [PATCH] Fix build without Qt5DBus
+
+---
+ CMakeLists.txt | 2 +-
+ src/CMakeLists.txt | 4 ++++
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c1de26e3e..eaf794c27 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -304,7 +304,7 @@ endif ()
+ if(WIN32)
+ set(QT_LIBRARIES Qt5::Core Qt5::OpenGL Qt5::Sql Qt5::Network Qt5::Xml Qt5::Widgets Qt5::Concurrent)
+ else(WIN32)
+- set(QT_LIBRARIES Qt5::Core Qt5::OpenGL Qt5::Sql Qt5::Network Qt5::Xml Qt5::Widgets Qt5::Concurrent Qt5::X11Extras Qt5::DBus)
++ set(QT_LIBRARIES Qt5::Core Qt5::OpenGL Qt5::Sql Qt5::Network Qt5::Xml Qt5::Widgets Qt5::Concurrent Qt5::X11Extras)
+ endif(WIN32)
+
+ # Remove GLU and GL from the link line - they're not really required
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 120f09949..88f1ac6c3 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1249,6 +1249,10 @@ target_link_libraries(clementine_lib
+ Qocoa
+ )
+
++if (HAVE_DBUS)
++ target_link_libraries(clementine_lib Qt5::DBus)
++endif ()
++
+ if(ENABLE_VISUALISATIONS)
+ target_link_libraries(clementine_lib ${LIBPROJECTM_LIBRARIES})
+ endif(ENABLE_VISUALISATIONS)
+--
+2.19.1
+