summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/ario
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/ario')
-rw-r--r--media-sound/ario/Manifest1
-rw-r--r--media-sound/ario/ario-1.5.1.ebuild68
-rw-r--r--media-sound/ario/files/ario-1.5.1-single-includes.patch48
-rw-r--r--media-sound/ario/metadata.xml15
4 files changed, 132 insertions, 0 deletions
diff --git a/media-sound/ario/Manifest b/media-sound/ario/Manifest
new file mode 100644
index 000000000000..41f907e9dea0
--- /dev/null
+++ b/media-sound/ario/Manifest
@@ -0,0 +1 @@
+DIST ario-1.5.1.tar.gz 1135444 SHA256 0831281ab8634eb92424b61230eee035822f7f92d8b0526da7316c898239c91e SHA512 78c3d881d51c3109b73252da0742da2a77bcc24ec21ff2ff02fd3527d62d49a75e412bf092051a9035863d645cba73e6cd2fc674d97629909b931ae9d3ec002b WHIRLPOOL 3f280635019dca6dfff5e5681bb38a559986475b31c9c03831ae7e9893af18c03ee8fd3cfd1524a9756b80543bbde01ec3de1a7a4f223e5aeca4e6e8462fe87a
diff --git a/media-sound/ario/ario-1.5.1.ebuild b/media-sound/ario/ario-1.5.1.ebuild
new file mode 100644
index 000000000000..3de19a8e31e7
--- /dev/null
+++ b/media-sound/ario/ario-1.5.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GNOME2_LA_PUNT=yes
+PYTHON_DEPEND="python? 2"
+
+inherit gnome2 python
+
+DESCRIPTION="a GTK2 MPD (Music Player Daemon) client inspired by Rythmbox"
+HOMEPAGE="http://ario-player.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}-player/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="audioscrobbler dbus debug +idle libnotify nls python taglib zeroconf"
+
+RDEPEND=">=dev-libs/glib-2.14:2
+ dev-libs/libgcrypt:0=
+ dev-libs/libunique:1
+ dev-libs/libxml2:2
+ media-libs/libmpdclient
+ net-misc/curl
+ net-libs/gnutls
+ >=x11-libs/gtk+-2.16:2
+ audioscrobbler? ( net-libs/libsoup:2.4 )
+ dbus? ( dev-libs/dbus-glib )
+ libnotify? ( x11-libs/libnotify )
+ python? ( dev-python/pygtk:2
+ dev-python/pygobject:2 )
+ taglib? ( media-libs/taglib )
+ zeroconf? ( net-dns/avahi )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+DOCS=( AUTHORS )
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-single-includes.patch
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-xmms2 \
+ --enable-libmpdclient2 \
+ --enable-search \
+ --enable-playlists \
+ --disable-deprecations \
+ $(use_enable audioscrobbler) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable idle mpdidle) \
+ $(use_enable libnotify notify) \
+ $(use_enable nls) \
+ $(use_enable python) \
+ $(use_enable taglib) \
+ $(use_enable zeroconf avahi)
+}
diff --git a/media-sound/ario/files/ario-1.5.1-single-includes.patch b/media-sound/ario/files/ario-1.5.1-single-includes.patch
new file mode 100644
index 000000000000..da7d7b598a8c
--- /dev/null
+++ b/media-sound/ario/files/ario-1.5.1-single-includes.patch
@@ -0,0 +1,48 @@
+Description: Only <glib.h> can be included directly.
+ Starting with glib 2.32 it is now mandatory to include glib.h
+ instead of individual headers, or the compiler will generate
+ an error.
+Origin: vendor: Debian
+Debian-Bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665506
+
+Index: ario-1.5.1/src/ario-profiles.h
+===================================================================
+--- ario-1.5.1.orig/src/ario-profiles.h 2011-05-17 19:54:49.000000000 +0200
++++ ario-1.5.1/src/ario-profiles.h 2012-03-30 07:10:46.285079675 +0200
+@@ -20,7 +20,7 @@
+ #ifndef __ARIO_PROFILES_H
+ #define __ARIO_PROFILES_H
+
+-#include <glib/gslist.h>
++#include <glib.h>
+ #include "servers/ario-server.h"
+
+ G_BEGIN_DECLS
+Index: ario-1.5.1/src/plugins/ario-plugin-info.c
+===================================================================
+--- ario-1.5.1.orig/src/plugins/ario-plugin-info.c 2011-02-27 16:07:28.000000000 +0100
++++ ario-1.5.1/src/plugins/ario-plugin-info.c 2012-03-30 07:10:48.289079604 +0200
+@@ -27,7 +27,7 @@
+
+ #include <string.h>
+ #include <glib/gi18n.h>
+-#include <glib/gkeyfile.h>
++#include <glib.h>
+
+ #include "plugins/ario-plugin-info-priv.h"
+ #include "ario-debug.h"
+Index: ario-1.5.1/src/ario-util.h
+===================================================================
+--- ario-1.5.1.orig/src/ario-util.h 2011-02-27 16:07:31.000000000 +0100
++++ ario-1.5.1/src/ario-util.h 2012-03-30 07:21:04.725057804 +0200
+@@ -18,8 +18,8 @@
+ */
+
+ #include "servers/ario-server.h"
+-#include "glib/gslist.h"
+-#include "gdk/gdkpixbuf.h"
++#include <glib.h>
++#include <gdk/gdkpixbuf.h>
+
+ /* Number of covers used to generate the drag & drop image */
+ #define MAX_COVERS_IN_DRAG 3
diff --git a/media-sound/ario/metadata.xml b/media-sound/ario/metadata.xml
new file mode 100644
index 000000000000..06aad3410300
--- /dev/null
+++ b/media-sound/ario/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+ <use>
+ <flag name="audioscrobbler">Enable song tracking via last.fm</flag>
+ <flag name="idle">Enable experimental support for MPD's idle command to reduce bandwidth and cpu usage, requires MPD 0.14</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">ario-player</remote-id>
+ </upstream>
+</pkgmetadata>