summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-04-05 22:35:13 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-04-05 22:35:13 +0000
commit553e6e20438354150f9607139de3f88678e72e75 (patch)
tree7f0bd35c707491e481ce66e1912fb5365978279f /media-radio
parent2021-04-05 21:35:02 UTC (diff)
parentdev-perl/Alien-wxWidgets: Depend on WX_GTK_VER SLOT (diff)
downloadgentoo-553e6e20438354150f9607139de3f88678e72e75.tar.gz
gentoo-553e6e20438354150f9607139de3f88678e72e75.tar.bz2
gentoo-553e6e20438354150f9607139de3f88678e72e75.zip
Merge updates from master
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/tqsl/tqsl-2.5.1.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/media-radio/tqsl/tqsl-2.5.1.ebuild b/media-radio/tqsl/tqsl-2.5.1.ebuild
index a6cbd247c04e..479817e6c433 100644
--- a/media-radio/tqsl/tqsl-2.5.1.ebuild
+++ b/media-radio/tqsl/tqsl-2.5.1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils wxwidgets vcs-snapshot
+WX_GTK_VER="3.0"
+inherit cmake wxwidgets vcs-snapshot
DESCRIPTION="ARRL Logbook of the World"
HOMEPAGE="http://www.arrl.org/tqsl-download"
@@ -12,21 +13,20 @@ SRC_URI="https://github.com/rich0/trustedqsl-tqsl/archive/v${PV}.tar.gz -> ${P}.
LICENSE="LOTW"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="dev-libs/expat:=
- dev-libs/openssl:0=
- net-misc/curl:=
- sys-libs/db:=
- sys-libs/zlib:=
- x11-libs/wxGTK:3.0="
+RDEPEND="
+ dev-libs/expat:=
+ dev-libs/openssl:0=
+ net-misc/curl:=
+ sys-libs/db:=
+ sys-libs/zlib:=
+ x11-libs/wxGTK:${WX_GTK_VER}="
DEPEND="${RDEPEND}"
DOCS=( AUTHORS.txt INSTALL README )
-HTML_DOCS=( html )
+HTML_DOCS=( html/. )
-WX_GTK_VER=3.0
-
-pkg_setup() {
+src_configure() {
setup-wxwidgets
+ cmake_src_configure
}