summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/live/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/live/files')
-rw-r--r--media-plugins/live/files/config.gentoo17
-rw-r--r--media-plugins/live/files/config.gentoo-so-r117
-rw-r--r--media-plugins/live/files/live-recursive.patch13
-rw-r--r--media-plugins/live/files/live-recursive2.patch14
4 files changed, 61 insertions, 0 deletions
diff --git a/media-plugins/live/files/config.gentoo b/media-plugins/live/files/config.gentoo
new file mode 100644
index 000000000000..b19d17552aac
--- /dev/null
+++ b/media-plugins/live/files/config.gentoo
@@ -0,0 +1,17 @@
+COMPILE_OPTS = $(INCLUDES) -I. -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64
+C = c
+C_COMPILER = $(CC)
+C_FLAGS = $(COMPILE_OPTS) $(CFLAGS)
+CPP = cpp
+CPLUSPLUS_COMPILER = $(CXX)
+CPLUSPLUS_FLAGS = $(COMPILE_OPTS) $(CXXFLAGS)
+OBJ = o
+LINK = $(CXX) -o
+LINK_OPTS = -L.
+CONSOLE_LINK_OPTS = $(LINK_OPTS)
+LIBRARY_LINK = $(LD) -o
+LIBRARY_LINK_OPTS = $(LINK_OPTS) -r -Bstatic
+LIB_SUFFIX = a
+LIBS_FOR_CONSOLE_APPLICATION =
+LIBS_FOR_GUI_APPLICATION =
+EXE =
diff --git a/media-plugins/live/files/config.gentoo-so-r1 b/media-plugins/live/files/config.gentoo-so-r1
new file mode 100644
index 000000000000..76a603557344
--- /dev/null
+++ b/media-plugins/live/files/config.gentoo-so-r1
@@ -0,0 +1,17 @@
+COMPILE_OPTS = $(INCLUDES) -I. -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64
+C = c
+C_COMPILER = $(CC)
+C_FLAGS = $(COMPILE_OPTS) -fPIC $(CFLAGS)
+CPP = cpp
+CPLUSPLUS_COMPILER = $(CXX)
+CPLUSPLUS_FLAGS = $(COMPILE_OPTS) -fPIC $(CXXFLAGS)
+OBJ = o
+LINK = $(CXX) -o
+LINK_OPTS = -L.
+CONSOLE_LINK_OPTS = $(LINK_OPTS)
+LIBRARY_LINK = $(CXX) -o
+LIBRARY_LINK_OPTS = $(LINK_OPTS) -shared -Wl,-soname,$@
+LIB_SUFFIX = so
+LIBS_FOR_CONSOLE_APPLICATION =
+LIBS_FOR_GUI_APPLICATION =
+EXE =
diff --git a/media-plugins/live/files/live-recursive.patch b/media-plugins/live/files/live-recursive.patch
new file mode 100644
index 000000000000..63b210706634
--- /dev/null
+++ b/media-plugins/live/files/live-recursive.patch
@@ -0,0 +1,13 @@
+Index: live/Makefile.tail
+===================================================================
+--- live.orig/Makefile.tail
++++ live/Makefile.tail
+@@ -14,8 +14,6 @@ all:
+ cd $(GROUPSOCK_DIR) ; $(MAKE)
+ cd $(USAGE_ENVIRONMENT_DIR) ; $(MAKE)
+ cd $(BASIC_USAGE_ENVIRONMENT_DIR) ; $(MAKE)
+- cd $(TESTPROGS_DIR) ; $(MAKE)
+- cd $(MEDIA_SERVER_DIR) ; $(MAKE)
+
+ clean:
+ cd $(LIVEMEDIA_DIR) ; $(MAKE) clean
diff --git a/media-plugins/live/files/live-recursive2.patch b/media-plugins/live/files/live-recursive2.patch
new file mode 100644
index 000000000000..107e53c6e137
--- /dev/null
+++ b/media-plugins/live/files/live-recursive2.patch
@@ -0,0 +1,14 @@
+Index: live/Makefile.tail
+===================================================================
+--- live.orig/Makefile.tail
++++ live/Makefile.tail
+@@ -16,9 +16,6 @@ all:
+ cd $(GROUPSOCK_DIR) ; $(MAKE)
+ cd $(USAGE_ENVIRONMENT_DIR) ; $(MAKE)
+ cd $(BASIC_USAGE_ENVIRONMENT_DIR) ; $(MAKE)
+- cd $(TESTPROGS_DIR) ; $(MAKE)
+- cd $(MEDIA_SERVER_DIR) ; $(MAKE)
+- cd $(PROXY_SERVER_DIR) ; $(MAKE)
+
+ clean:
+ cd $(LIVEMEDIA_DIR) ; $(MAKE) clean