summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-06-11 10:57:53 +0300
committerMart Raudsepp <leio@gentoo.org>2020-06-11 10:57:53 +0300
commit5b5077592ef7b22f898782f32fced5d99a4b6b09 (patch)
treed554ce9473d78eda0d93898e9f28c8b36ebbe0e6 /media-plugins/gst-plugins-webrtc/gst-plugins-webrtc-1.16.2.ebuild
parentsys-boot/unetbootin: Version 681 (diff)
downloadgentoo-5b5077592ef7b22f898782f32fced5d99a4b6b09.tar.gz
gentoo-5b5077592ef7b22f898782f32fced5d99a4b6b09.tar.bz2
gentoo-5b5077592ef7b22f898782f32fced5d99a4b6b09.zip
media-plugins/gst-plugins-webrtc: new package for gstreamer WebRTC elements
Ships the webrtcdsp plugins (echo cancellation) and webrtcbin. Closes: https://bugs.gentoo.org/673282 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-webrtc/gst-plugins-webrtc-1.16.2.ebuild')
-rw-r--r--media-plugins/gst-plugins-webrtc/gst-plugins-webrtc-1.16.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-webrtc/gst-plugins-webrtc-1.16.2.ebuild b/media-plugins/gst-plugins-webrtc/gst-plugins-webrtc-1.16.2.ebuild
new file mode 100644
index 000000000000..991e373498e5
--- /dev/null
+++ b/media-plugins/gst-plugins-webrtc/gst-plugins-webrtc-1.16.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="WebRTC plugins for GStreamer"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:1.0[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-bad-${PV}:1.0[${MULTILIB_USEDEP}]
+ >=media-libs/webrtc-audio-processing-0.2[${MULTILIB_USEDEP}]
+ <media-libs/webrtc-audio-processing-0.4
+ >=net-libs/libnice-0.1.14[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_BUILD="webrtc webrtcdsp"
+GST_PLUGINS_BUILD_DIR="webrtc webrtcdsp"
+
+src_prepare() {
+ default
+ gstreamer_system_link gst-libs/gst/webrtc:gstreamer-webrtc
+ gstreamer_system_link gst-libs/gst/sctp:gstreamer-sctp
+ gstreamer_system_link gst-libs/gst/audio:gstreamer-bad-audio
+}