summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-28 23:43:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-28 23:50:55 +0100
commitffc4bd7ac7d1b38cf54b124c9fe610fb8568ca07 (patch)
treefc0198de295ae9dcb62b2b433555210ae2383deb /media-libs
parentmedia-libs/libcdr: update EAPI 7 -> 8 (diff)
downloadgentoo-ffc4bd7ac7d1b38cf54b124c9fe610fb8568ca07.tar.gz
gentoo-ffc4bd7ac7d1b38cf54b124c9fe610fb8568ca07.tar.bz2
gentoo-ffc4bd7ac7d1b38cf54b124c9fe610fb8568ca07.zip
media-libs/libcdr: add 0.1.8
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libcdr/Manifest1
-rw-r--r--media-libs/libcdr/libcdr-0.1.8.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/media-libs/libcdr/Manifest b/media-libs/libcdr/Manifest
index 9a0875ed1917..28009ab8fa9b 100644
--- a/media-libs/libcdr/Manifest
+++ b/media-libs/libcdr/Manifest
@@ -1 +1,2 @@
DIST libcdr-0.1.7.tar.xz 618528 BLAKE2B 7e74b1936f80078f4b0a07e2e37f9d59489ad27acee66175032ba7250ab492310e4042c7b6d7995b1ffffee7da1c7562f5c2fc24457c3efe0b19fe7e00d8e42b SHA512 9af327fcf9f3f3ef1c446e92f4d2ff06ebaccb54d4c65b021960a212bf416f7098006324625f3e1c00500597eaa9da39832cc27b83a6cd593e97b76b1eb63d38
+DIST libcdr-0.1.8.tar.xz 625836 BLAKE2B e6f63b378e56f15cc194e9b5fb4ebedc3314cfe8179080b042fd84498343858710a5cc1e1e7c47937b6fe9de6f49310d0adc41e1d4b9c6260d6ec7eb49563cb6 SHA512 5dc25ca80817c5d166c89264fb727a723c3439abb8ec655047c2c15bff0a48b87e7c6e3d6b203296964060bf5c2a71a11bceffbbc2f5eb3f61a209bef071a57a
diff --git a/media-libs/libcdr/libcdr-0.1.8.ebuild b/media-libs/libcdr/libcdr-0.1.8.ebuild
new file mode 100644
index 000000000000..9001c20d83cc
--- /dev/null
+++ b/media-libs/libcdr/libcdr-0.1.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libcdr.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libcdr/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="Library parsing the Corel cdr documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ media-libs/lcms:2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ dev-build/libtool
+ virtual/pkgconfig
+ doc? ( app-text/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ default
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc docs)
+ $(use_enable test tests)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}