summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-10-26 22:05:39 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-26 22:16:27 +0200
commited1f940dedfc29c889b889d2638e619e1b8abc69 (patch)
treeac47fd9f2e5d8667704bdabc29446a7d57ed9709 /media-libs
parentmedia-libs/jasper: Version bump to 1.900.15 (diff)
downloadgentoo-ed1f940dedfc29c889b889d2638e619e1b8abc69.tar.gz
gentoo-ed1f940dedfc29c889b889d2638e619e1b8abc69.tar.bz2
gentoo-ed1f940dedfc29c889b889d2638e619e1b8abc69.zip
media-libs/jasper: Update live ebuild
* Add option to limit maximum memory by default Package-Manager: portage-2.3.2
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/jasper/jasper-9999.ebuild23
1 files changed, 18 insertions, 5 deletions
diff --git a/media-libs/jasper/jasper-9999.ebuild b/media-libs/jasper/jasper-9999.ebuild
index 10f690fa1f01..7c007cdc115f 100644
--- a/media-libs/jasper/jasper-9999.ebuild
+++ b/media-libs/jasper/jasper-9999.ebuild
@@ -4,15 +4,27 @@
EAPI=6
-inherit autotools git-r3 multilib-minimal
+inherit autotools multilib-minimal
DESCRIPTION="Implementation of the codec specified in the JPEG-2000 Part-1 standard"
HOMEPAGE="http://www.ece.uvic.ca/~mdadams/jasper/"
-EGIT_REPO_URI="https://github.com/mdadams/jasper.git"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mdadams/jasper.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/mdadams/${PN}/archive/version-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 \
+ ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux \
+ ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+# We limit memory usage to 128 MiB by default, specified in bytes
+: ${JASPER_MEM_LIMIT:=134217728}
LICENSE="JasPer2.0"
SLOT="0/1"
-KEYWORDS=""
IUSE="jpeg opengl static-libs"
RDEPEND="
@@ -21,7 +33,7 @@ RDEPEND="
>=virtual/opengl-7.0-r1:0[${MULTILIB_USEDEP}]
>=media-libs/freeglut-2.8.1:0[${MULTILIB_USEDEP}]
virtual/glu
- )"
+ )"
DEPEND="${RDEPEND}
app-arch/unzip"
@@ -34,7 +46,8 @@ multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
$(use_enable jpeg libjpeg) \
$(use_enable opengl) \
- $(use_enable static-libs static)
+ $(use_enable static-libs static) \
+ --enable-memory-limit="${JASPER_MEM_LIMIT}"
}
multilib_src_install_all() {