summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-05-31 19:49:09 +1000
committerMatt Jolly <kangie@gentoo.org>2024-06-01 08:00:20 +1000
commitb3cef3f377fcc8002b9719a03cba71f049866dd1 (patch)
treeb9e98a13d4bf3231ea804476a9054e80b7498ae5 /media-libs
parentapp-arch/xz-utils: improve PGO (diff)
downloadgentoo-b3cef3f377fcc8002b9719a03cba71f049866dd1.tar.gz
gentoo-b3cef3f377fcc8002b9719a03cba71f049866dd1.tar.bz2
gentoo-b3cef3f377fcc8002b9719a03cba71f049866dd1.zip
media-libs/libaom: add 3.9.0
Update instructions for test tarball generation to point to chromium-tools.git in this and live ebulid. Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libaom/Manifest2
-rw-r--r--media-libs/libaom/libaom-3.9.0.ebuild146
-rw-r--r--media-libs/libaom/libaom-9999.ebuild13
3 files changed, 150 insertions, 11 deletions
diff --git a/media-libs/libaom/Manifest b/media-libs/libaom/Manifest
index 1b4b83e7571b..5d960b7e6684 100644
--- a/media-libs/libaom/Manifest
+++ b/media-libs/libaom/Manifest
@@ -7,3 +7,5 @@ DIST libaom-3.8.0-testdata.tar.xz 426384840 BLAKE2B a195f44aa8f55e869ea613f587a1
DIST libaom-3.8.0.tar.gz 5448720 BLAKE2B 276e50c134a5a5925591cbc5c76a11383d288854bc5f4db79d97f1e4e41e74f5739ee916df127112cb678673f09aeb5dfa91f1d8696b0894923837cea991bd73 SHA512 201a3ef00c0de3f90ed2486b306b836ec3e5c891c0ea05cb4607523f084f957849d38cd1e2684c05af2a93180a1b151ccc7a99ba8d5d52a84d8cb17cb25b0e8a
DIST libaom-3.8.1-testdata.tar.xz 426372276 BLAKE2B 4d6194a98612045023f4d35ca851a37ffc69cbfbfd015d5c1f4e3aebb6789096d7b7f82b9641c545e4203b44fe8a9243de83bb23a8c53aced30ec26aed0376e0 SHA512 03bf5d521c613728dd12fd33bb76fc64a20798e276dbdc2501446e1fb9891552e88adb25f0e4ff65d6c8aad301a550aec195498ab1f1a506bce3fe384e24cc0e
DIST libaom-3.8.1.tar.gz 5450909 BLAKE2B fec3123f8ee68b1027a1a2019969c098b730da72be2902274659b983857f2d8f62dae5b563543b3f144ae8bc51b6d6fdd4fcd6aadf2ca04d5a4dd5be987fbbac SHA512 f9ee918a37699cfaf2bcb5aa16a4d8b077feb1fc577d8c5437ed3fa1a1c0a5d734c9564e3c8c0f0b1baf43dc5abb7ff0196a77607b10d926c0be7858778ac1e3
+DIST libaom-3.9.0-testdata.tar.xz 426348008 BLAKE2B 1d95116e738a3271cbb6381cdeb3d2cd359bd3d3001e759e6ed9f56f7f0d87b6a0a557f3655c4c5640e7812cee2e10de5626de70794c6b49fdac51f33d9a1b56 SHA512 b8e68cffa844ac33f3fd7cce8de08e90bc4e401055fa24e58ea6e1217a64db62bd09c469267106b1e82d480550238ac6aaa12c86f75e9fbfd8fa847180b41537
+DIST libaom-3.9.0.tar.gz 5518815 BLAKE2B 4c68b58f6a8e347ee912e309a030804c4a3cc99714e2aaf127add63222df3056c7cf4b6c50f4861557b0892739035149b5e002e25272882eff55cde5d9b745b7 SHA512 0793e0801be72d35144162141a180ff5e3ae11186f734af738b1eb2d81bff1364be7741cc34ae2507d2b88de11f840609a09f8b05b75e8d853aa80626241bf95
diff --git a/media-libs/libaom/libaom-3.9.0.ebuild b/media-libs/libaom/libaom-3.9.0.ebuild
new file mode 100644
index 000000000000..8062dc97f9b4
--- /dev/null
+++ b/media-libs/libaom/libaom-3.9.0.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake-multilib flag-o-matic multiprocessing python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
+else
+ # To update test data tarball,
+ # chromium-tools.git/generate-libaom-test-tarball.sh
+ SRC_URI="
+ https://storage.googleapis.com/aom-releases/${P}.tar.gz
+ test? ( https://deps.gentoo.zip/${CATEGORY}/${P}-testdata.tar.xz )
+ "
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="Alliance for Open Media AV1 Codec SDK"
+HOMEPAGE="https://aomedia.org https://aomedia.googlesource.com/aom/"
+
+LICENSE="BSD-2"
+SLOT="0/3"
+IUSE="big-endian debug doc +examples test"
+IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3"
+IUSE="${IUSE} cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2"
+IUSE="${IUSE} cpu_flags_arm_crc32 cpu_flags_arm_neon cpu_flags_ppc_vsx"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
+ cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
+"
+
+BDEPEND="${PYTHON_DEPS}
+ dev-lang/perl
+ abi_x86_32? ( dev-lang/yasm )
+ abi_x86_64? ( dev-lang/yasm )
+ abi_x86_x32? ( dev-lang/yasm )
+ doc? ( app-text/doxygen )
+"
+
+# The PATENTS file is required to be distributed with this package, bug #682214
+DOCS=( PATENTS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4.0-posix-c-source-ftello.patch
+ "${FILESDIR}"/${PN}-3.7.0-allow-fortify-source.patch
+ "${FILESDIR}"/${PN}-3.8.1-tests-parallel.patch
+)
+
+multilib_src_configure() {
+ # Follow upstream recommendations in README (bug #921438) and avoid
+ # asserts during common use (bug #914614).
+ append-cppflags $(usex debug '-UNDEBUG' '-DNDEBUG')
+
+ local mycmakeargs=(
+ -DENABLE_CCACHE=OFF
+ -DENABLE_DOCS=$(multilib_native_usex doc ON OFF)
+ -DENABLE_EXAMPLES=$(multilib_native_usex examples ON OFF)
+ -DENABLE_NASM=OFF
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_TOOLS=ON
+ -DENABLE_WERROR=OFF
+ # https://bugs.chromium.org/p/aomedia/issues/detail?id=3487 shows
+ # that big endian detection doesn't really work otherwise.
+ -DCONFIG_BIG_ENDIAN=$(usex big-endian 1 0)
+
+ # Needs libjxl, currently unpackaged.
+ -DCONFIG_TUNE_BUTTERAUGLI=0
+
+ # arm
+ -DENABLE_NEON=$(usex cpu_flags_arm_neon ON OFF)
+ -DENABLE_ARM_CRC32=$(usex cpu_flags_arm_crc32 ON OFF)
+ # bug #917277
+ -DENABLE_NEON_DOTPROD=OFF
+ # bug #917278
+ -DENABLE_NEON_I8MM=OFF
+ # bug #920474
+ -DENABLE_SVE=OFF
+
+ # mips
+ # ENABLE_DSPR2 / ENABLE_MSA for mips
+
+ # amd64
+ -DENABLE_MMX=$(usex cpu_flags_x86_mmx ON OFF)
+ -DENABLE_SSE=$(usex cpu_flags_x86_sse ON OFF)
+ -DENABLE_SSE2=$(usex cpu_flags_x86_sse2 ON OFF)
+ -DENABLE_SSE3=$(usex cpu_flags_x86_sse3 ON OFF)
+ -DENABLE_SSSE3=$(usex cpu_flags_x86_ssse3 ON OFF)
+ -DENABLE_SSE4_1=$(usex cpu_flags_x86_sse4_1 ON OFF)
+ -DENABLE_SSE4_2=$(usex cpu_flags_x86_sse4_2 ON OFF)
+ -DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
+ -DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
+
+ # ppc
+ -DENABLE_VSX=$(usex cpu_flags_ppc_vsx ON OFF)
+ )
+
+ # For 32-bit multilib builds, force some intrinsics on to work around
+ # bug #816027. libaom seems to do runtime detection for some targets
+ # at least, so this isn't an issue.
+ if ! multilib_is_native_abi && use amd64 ; then
+ mycmakeargs+=(
+ -DENABLE_SSE3=ON
+ -DENABLE_SSSE3=ON
+ )
+ fi
+
+ # On ARM32-on-ARM64, things end up failing if NEON is off, bug #835456
+ # Just force generic, given it's a niche situation.
+ # TODO: could try forcing armv7 or similar?
+ if use arm && ! use cpu_flags_arm_neon && [[ $(uname -p) == "aarch64" ]] ; then
+ ewarn "Forcing generic for arm32-on-arm64 build (bug #835456)"
+ mycmakeargs+=(
+ -DAOM_TARGET_CPU=generic
+ )
+ fi
+
+ # LIBAOM_TEST_PROCS is added by our tests-parallel.patch
+ export LIBAOM_TEST_PROCS="$(makeopts_jobs)"
+
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ einfo "Running quiet tests which take hours."
+ # We use ninja rather than test_libaom directly so we can run it in parallel
+ # with sharding, see https://aomedia.googlesource.com/aom/#sharded-testing.
+ LIBAOM_TEST_DATA_PATH="${WORKDIR}/${P}-testdata" eninja -C "${BUILD_DIR}" runtests
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi && use doc ; then
+ local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+ fi
+
+ cmake_src_install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
+}
diff --git a/media-libs/libaom/libaom-9999.ebuild b/media-libs/libaom/libaom-9999.ebuild
index 9ea4cca0ff7e..4f2b0a8a4dae 100644
--- a/media-libs/libaom/libaom-9999.ebuild
+++ b/media-libs/libaom/libaom-9999.ebuild
@@ -10,17 +10,8 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
else
- # To update test data tarball, follow these steps:
- # 1. Clone the upstream repo and check out the relevant tag,
- # or download the release tarball
- # 2. Regular cmake configure (options don't matter here):
- # cd build && cmake ..
- # 3. Set LIBAOM_TEST_DATA_PATH to the directory you want and
- # run the "make testdata" target:
- # LIBAOM_TEST_DATA_PATH=../libaom-3.7.1-testdata make testdata
- # This will download the test data from the internet.
- # 4. Create a tarball out of that directory.
- # cd .. && tar cvaf libaom-3.7.1-testdata.tar.xz libaom-3.7.1-testdata
+ # To update test data tarball,
+ # chromium-tools.git/generate-libaom-test-tarball.sh
SRC_URI="
https://storage.googleapis.com/aom-releases/${P}.tar.gz
test? ( https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-testdata.tar.xz )