summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-06 01:52:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-06 03:24:24 +0100
commit68a6ab2ca89ce4a276c70c72856f360e7eb02b17 (patch)
tree70c58be17d418def460a3003f1809d16957490c3 /media-libs
parentmedia-gfx/pstoedit: 3.75 version bump, EAPI-7 bump, drop static-libs (diff)
downloadgentoo-68a6ab2ca89ce4a276c70c72856f360e7eb02b17.tar.gz
gentoo-68a6ab2ca89ce4a276c70c72856f360e7eb02b17.tar.bz2
gentoo-68a6ab2ca89ce4a276c70c72856f360e7eb02b17.zip
media-libs/plotutils: EAPI-7 bump, fix pkg_postinst message
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/plotutils/files/plotutils-2.6-libpng-1.5.patch4
-rw-r--r--media-libs/plotutils/plotutils-2.6-r2.ebuild65
2 files changed, 36 insertions, 33 deletions
diff --git a/media-libs/plotutils/files/plotutils-2.6-libpng-1.5.patch b/media-libs/plotutils/files/plotutils-2.6-libpng-1.5.patch
index b86d9f457421..431c638a553e 100644
--- a/media-libs/plotutils/files/plotutils-2.6-libpng-1.5.patch
+++ b/media-libs/plotutils/files/plotutils-2.6-libpng-1.5.patch
@@ -1,7 +1,7 @@
fix building with libpng-1.5
---- libplot/z_write.c
-+++ libplot/z_write.c
+--- a/libplot/z_write.c
++++ b/libplot/z_write.c
@@ -164,7 +164,7 @@
}
diff --git a/media-libs/plotutils/plotutils-2.6-r2.ebuild b/media-libs/plotutils/plotutils-2.6-r2.ebuild
index d3c6f4302a93..3b254ce0cae6 100644
--- a/media-libs/plotutils/plotutils-2.6-r2.ebuild
+++ b/media-libs/plotutils/plotutils-2.6-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit libtool eutils autotools
+inherit libtool autotools
DESCRIPTION="Powerful C/C++ function library for exporting 2-D vector graphics"
HOMEPAGE="https://www.gnu.org/software/plotutils/"
@@ -12,47 +12,50 @@ SRC_URI="mirror://gnu/plotutils/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+png static-libs X"
+IUSE="+png X"
DEPEND="
- !<media-libs/plotutils-${PV}
media-libs/libxmi
png? (
media-libs/libpng:0=
- sys-libs/zlib )
- X? ( x11-libs/libXaw )"
-RDEPEND="${DEPEND}"
+ sys-libs/zlib
+ )
+ X? ( x11-libs/libXaw )
+"
+RDEPEND="${DEPEND}
+ !<media-libs/plotutils-${PV}
+"
-DOCS="AUTHORS COMPAT ChangeLog INSTALL.* KNOWN_BUGS NEWS ONEWS PROBLEMS README THANKS TODO"
+DOCS=( AUTHORS COMPAT ChangeLog INSTALL.{fonts,pkg} KNOWN_BUGS NEWS ONEWS PROBLEMS README THANKS TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.1-rangecheck.patch
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-libpng-1.5.patch
+ "${FILESDIR}"/${P}-libxmi.patch
+ "${FILESDIR}"/${P}-format-security.patch
+)
src_prepare() {
- rm -rf libxmi/* || die
- sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
- epatch \
- "${FILESDIR}"/${PN}-2.5.1-rangecheck.patch \
- "${FILESDIR}"/${P}-makefile.patch \
- "${FILESDIR}"/${P}-libpng-1.5.patch \
- "${FILESDIR}"/${P}-libxmi.patch \
- "${FILESDIR}"/${P}-format-security.patch
+ default
+
+ rm -r libxmi/* || die
+ sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' -i configure.ac || die
+
eautoreconf
elibtoolize
}
src_configure() {
- local myconf
- if use X ; then
- myconf="--with-x --enable-libxmi"
- else
- myconf="--without-x"
- fi
-
- econf \
- --enable-shared \
- --enable-libplotter \
- --disable-libxmi \
- $(use_enable static-libs static) \
- $(use_with png libpng) \
- ${myconf}
+ local myeconfargs=(
+ --enable-shared
+ --enable-libplotter
+ --disable-libxmi
+ --disable-static
+ $(use_with png libpng)
+ $(usex X "--with-x --enable-libxmi" "--without-x")
+ )
+ econf "${myeconfargs[@]}"
}
pkg_postinst() {
@@ -60,7 +63,7 @@ pkg_postinst() {
elog "There are extra fonts available in the plotutils package."
elog "The current ebuild does not install them for you since most"
elog "of them can be installed via the media-fonts/urw-fonts"
- elog "package. See /usr/share/doc/${P}/INSTALL.fonts for"
+ elog "package. See /usr/share/doc/${PF}/INSTALL.fonts for"
elog "information on installing the remaining Tektronix fonts."
elog ""
elog "If you manually install the extra fonts and use the"