summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-06-06 20:08:19 -0700
committerMatt Turner <mattst88@gentoo.org>2018-06-06 20:13:29 -0700
commit5d036adfdf3b479be672002443b4cf4d2c2865cf (patch)
tree912a6609182af98c343c9d9a4e897fa4ec43f442 /media-libs
parentdev-lang/rust: Move shell glob outside quotes (diff)
downloadgentoo-5d036adfdf3b479be672002443b4cf4d2c2865cf.tar.gz
gentoo-5d036adfdf3b479be672002443b4cf4d2c2865cf.tar.bz2
gentoo-5d036adfdf3b479be672002443b4cf4d2c2865cf.zip
media-libs/mesa: Only remove files if there are files to remove
Noticed by Arfrever.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-18.1.1-r1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/media-libs/mesa/mesa-18.1.1-r1.ebuild b/media-libs/mesa/mesa-18.1.1-r1.ebuild
index 46ce5dceeebb..8774521335b3 100644
--- a/media-libs/mesa/mesa-18.1.1-r1.ebuild
+++ b/media-libs/mesa/mesa-18.1.1-r1.ebuild
@@ -401,11 +401,13 @@ multilib_src_configure() {
multilib_src_install() {
emake install DESTDIR="${D}"
- # These files are now provided by >=dev-libs/wayland-1.15.0
- rm "${ED}/usr/$(get_libdir)/libwayland-egl.so" || die
- rm "${ED}/usr/$(get_libdir)/libwayland-egl.so.1" || die
- rm "${ED}/usr/$(get_libdir)/libwayland-egl.so.1.0.0" || die
- rm "${ED}/usr/$(get_libdir)/pkgconfig/wayland-egl.pc" || die
+ if use wayland; then
+ # These files are now provided by >=dev-libs/wayland-1.15.0
+ rm "${ED}/usr/$(get_libdir)/libwayland-egl.so" || die
+ rm "${ED}/usr/$(get_libdir)/libwayland-egl.so.1" || die
+ rm "${ED}/usr/$(get_libdir)/libwayland-egl.so.1.0.0" || die
+ rm "${ED}/usr/$(get_libdir)/pkgconfig/wayland-egl.pc" || die
+ fi
if use opencl; then
ebegin "Moving Gallium/Clover OpenCL implementation for dynamic switching"