summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/smpeg2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/smpeg2')
-rw-r--r--media-libs/smpeg2/Manifest1
-rw-r--r--media-libs/smpeg2/files/smpeg2-2.0.0-smpeg2-config.patch33
-rw-r--r--media-libs/smpeg2/metadata.xml5
-rw-r--r--media-libs/smpeg2/smpeg2-2.0.0-r3.ebuild51
4 files changed, 90 insertions, 0 deletions
diff --git a/media-libs/smpeg2/Manifest b/media-libs/smpeg2/Manifest
new file mode 100644
index 000000000000..b142311c606c
--- /dev/null
+++ b/media-libs/smpeg2/Manifest
@@ -0,0 +1 @@
+DIST smpeg-2.0.0.tar.bz2 311846 SHA256 8adcc305a063170ca32983e5e10e216fa4b8106c3947190c0ca561a08ec26512 SHA512 3a58ea6a47224b112390c3fe83e5bd59a852a8828ee9b0451d389e3d193499fd3dfb2344abe4d1379248c4fb197e78ee22c6cfb653a2e32e339c030826c06950 WHIRLPOOL 23c49525df9bbfc1506c7131fe7b6f6bcd6940d4f1a05cfa3386244fcf949bd11f083568271879f64d0c26c406be5462d2dbacb22e367f542a155c34094797d2
diff --git a/media-libs/smpeg2/files/smpeg2-2.0.0-smpeg2-config.patch b/media-libs/smpeg2/files/smpeg2-2.0.0-smpeg2-config.patch
new file mode 100644
index 000000000000..66c246f08cca
--- /dev/null
+++ b/media-libs/smpeg2/files/smpeg2-2.0.0-smpeg2-config.patch
@@ -0,0 +1,33 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Mon Oct 7 15:10:46 UTC 2013
+Subject: fix smpeg2-config.in
+
+SDL_CONFIG is now SDL2_CONFIG in the new sdl2.m4
+
+--------------------------------------CUT---------------------------------------
+also
+
+Only dump -L/-rpath if libdir is non-standard; cribbed from smpeg patches
+
+--- smpeg-2.0.0.orig/smpeg2-config.in
++++ smpeg-2.0.0/smpeg2-config.in
+@@ -42,15 +42,17 @@
+ if test @includedir@ != /usr/include ; then
+ includes=-I@includedir@
+ fi
+- echo $includes -I@includedir@/smpeg2 `@SDL_CONFIG@ --cflags`
++ echo $includes -I@includedir@/smpeg2 `@SDL2_CONFIG@ --cflags`
+ ;;
+ --libs)
++ if [ "@libdir@" != "/usr/lib" ]; then
+ if [ "`uname`" = "SunOS" ]; then
+ libdirs="-L@libdir@ -R@libdir@"
+ else
+ libdirs="-L@libdir@ @SMPEG_RLD_FLAGS@"
+ fi
+- echo $libdirs -lsmpeg2 `@SDL_CONFIG@ --libs`
++ fi
++ echo $libdirs -lsmpeg2 `@SDL2_CONFIG@ --libs`
+ ;;
+ *)
+ echo "${usage}" 1>&2
diff --git a/media-libs/smpeg2/metadata.xml b/media-libs/smpeg2/metadata.xml
new file mode 100644
index 000000000000..cad5a2aa1773
--- /dev/null
+++ b/media-libs/smpeg2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>
diff --git a/media-libs/smpeg2/smpeg2-2.0.0-r3.ebuild b/media-libs/smpeg2/smpeg2-2.0.0-r3.ebuild
new file mode 100644
index 000000000000..037c129e35c6
--- /dev/null
+++ b/media-libs/smpeg2/smpeg2-2.0.0-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs autotools multilib-minimal
+
+MY_P=smpeg-${PV}
+DESCRIPTION="SDL MPEG Player Library"
+HOMEPAGE="http://icculus.org/smpeg/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug cpu_flags_x86_mmx static-libs"
+
+DEPEND=">=media-libs/libsdl2-2.0.1-r1[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES README README.SDL_mixer TODO )
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-smpeg2-config.patch
+
+ # avoid file collision with media-libs/smpeg
+ sed -i \
+ -e '/plaympeg/d' \
+ Makefile.am || die
+
+ mv configure.in configure.ac || die
+ AT_M4DIR="/usr/share/aclocal acinclude" eautoreconf
+}
+
+multilib_src_configure() {
+ # the debug option is bogus ... all it does is add extra
+ # optimizations if you pass --disable-debug
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ --disable-rpath \
+ --enable-debug \
+ --disable-sdltest \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable debug assertions)
+}
+
+multilib_src_install_all() {
+ use static-libs || prune_libtool_files
+}