summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-11 03:48:59 +0000
committerSam James <sam@gentoo.org>2022-11-11 03:48:59 +0000
commit7f2e578801e00c0a195b0d6f72cb69368544db75 (patch)
tree4f842cbe7d46f1aae4cc8b49ba4057052376c371 /media-libs/sdl-ttf
parentmedia-libs/sdl-mixer: add 1.2.12_p20221010 (diff)
downloadgentoo-7f2e578801e00c0a195b0d6f72cb69368544db75.tar.gz
gentoo-7f2e578801e00c0a195b0d6f72cb69368544db75.tar.bz2
gentoo-7f2e578801e00c0a195b0d6f72cb69368544db75.zip
media-libs/sdl-ttf: add 2.0.11_p20220525
Upstream aren't making releases anymore (since a long time ago!) for the 1.2.x branch but are kindly doing backports, so let's make a snapshot. The vulnerable (CVE-2022-27470) code doesn't seem to be in 1.2.x - and given upstream are quite good about backporting, the absence of any related commits seems to support that. Bug: https://bugs.gentoo.org/843434 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/sdl-ttf')
-rw-r--r--media-libs/sdl-ttf/Manifest1
-rw-r--r--media-libs/sdl-ttf/sdl-ttf-2.0.11_p20220525.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/sdl-ttf/Manifest b/media-libs/sdl-ttf/Manifest
index 46d0fe031ed2..8faabab03788 100644
--- a/media-libs/sdl-ttf/Manifest
+++ b/media-libs/sdl-ttf/Manifest
@@ -1 +1,2 @@
DIST SDL_ttf-2.0.11.tar.gz 4053686 BLAKE2B 3a78eeec91d7f6983b851cdd52925890c168cdf85dd34c7722183cc5a8848dab530c0c2d76493e0a380aa7e4f81967eeefd7cb34dc74faafc40497ffcb0e577b SHA512 64e04d1cd77e525e0f2413ad928841e5d3d09d551c030fc577b50777116580e430cb272b2aeb6191dfcc464669cf2f7a5a50d10e7c75637a3b1e8c8fca7fc78b
+DIST sdl-ttf-2.0.11_p20220525.tar.gz 5421461 BLAKE2B 93422fdc912369a503ef0bc2f474a7afd749396176a295484b9ff8b1c0b5a06c2a5a21b93c91b616816f7c1c5f3ff35c611618251e8ae7f2b2d337109a3cab56 SHA512 a371488b59b8d1d2b067ee8bb67912d11875ac202912ffd31d5fee4630dac205e2e757505ab4dba3267e4d2700c043873c3b37aa6813ece8333f1b25fa096346
diff --git a/media-libs/sdl-ttf/sdl-ttf-2.0.11_p20220525.ebuild b/media-libs/sdl-ttf/sdl-ttf-2.0.11_p20220525.ebuild
new file mode 100644
index 000000000000..e6683a15dc3d
--- /dev/null
+++ b/media-libs/sdl-ttf/sdl-ttf-2.0.11_p20220525.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Check SDL-1.2 branch for possible backports/new snapshots
+
+inherit autotools multilib-minimal
+
+SDL_TTF_COMMIT="2648c22c4f9e32d05a11b32f636b1c225a1502ac"
+
+MY_PN="${PN/sdl-/SDL_}"
+DESCRIPTION="Library that allows you to use TrueType fonts in SDL applications"
+HOMEPAGE="https://github.com/libsdl-org/SDL_ttf"
+SRC_URI="https://github.com/libsdl-org/SDL_ttf/archive/${SDL_TTF_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${MY_PN}-${SDL_TTF_COMMIT}
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="static-libs X"
+
+RDEPEND="
+ >=media-libs/libsdl-1.2.15-r4[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]
+ X? ( >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_with X x)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ dodoc CHANGES README
+
+ if ! use static-libs ; then
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
+ fi
+}