summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/openjpeg/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/openjpeg/files')
-rw-r--r--media-libs/openjpeg/files/openjpeg-2.0.0-build.patch14
-rw-r--r--media-libs/openjpeg/files/openjpeg-2.0.0-pkgconfig-static.patch10
-rw-r--r--media-libs/openjpeg/files/openjpeg-2.0.0-pkgconfig.patch37
3 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/openjpeg/files/openjpeg-2.0.0-build.patch b/media-libs/openjpeg/files/openjpeg-2.0.0-build.patch
new file mode 100644
index 000000000000..31ae12f213cb
--- /dev/null
+++ b/media-libs/openjpeg/files/openjpeg-2.0.0-build.patch
@@ -0,0 +1,14 @@
+--- openjpeg-2.0.0/CMakeLists.txt
++++ openjpeg-2.0.0/CMakeLists.txt
+@@ -279,11 +279,4 @@
+ DESTINATION ${OPENJPEG_INSTALL_PACKAGE_DIR}
+ )
+
+-#-----------------------------------------------------------------------------
+-# install CHANGES and LICENSE
+-if(EXISTS ${OPENJPEG_SOURCE_DIR}/CHANGES)
+- install(FILES CHANGES DESTINATION ${OPENJPEG_INSTALL_DOC_DIR})
+-endif()
+-install(FILES LICENSE DESTINATION ${OPENJPEG_INSTALL_DOC_DIR})
+-
+ include (cmake/OpenJPEGCPack.cmake)
diff --git a/media-libs/openjpeg/files/openjpeg-2.0.0-pkgconfig-static.patch b/media-libs/openjpeg/files/openjpeg-2.0.0-pkgconfig-static.patch
new file mode 100644
index 000000000000..60a5a47adbda
--- /dev/null
+++ b/media-libs/openjpeg/files/openjpeg-2.0.0-pkgconfig-static.patch
@@ -0,0 +1,10 @@
+Upstream issue 223, http://code.google.com/p/openjpeg/issues/detail?id=223
+
+--- openjpeg-2.0.0/src/lib/openjp2/libopenjp2.pc.cmake.in
++++ openjpeg-2.0.0/src/lib/openjp2/libopenjp2.pc.cmake.in
+@@ -10,4 +10,5 @@
+ URL: http://www.openjpeg.org/
+ Version: @OPENJPEG_VERSION@
+ Libs: -L${libdir} -lopenjp2
++Libs.private: -L${libdir} -lopenjp2 -lm
+ Cflags: -I${includedir}
diff --git a/media-libs/openjpeg/files/openjpeg-2.0.0-pkgconfig.patch b/media-libs/openjpeg/files/openjpeg-2.0.0-pkgconfig.patch
new file mode 100644
index 000000000000..656f4c20acd3
--- /dev/null
+++ b/media-libs/openjpeg/files/openjpeg-2.0.0-pkgconfig.patch
@@ -0,0 +1,37 @@
+Pkgconfig support http://code.google.com/p/openjpeg/source/detail?r=2250
+
+--- openjpeg-2.0.0/CMakeLists.txt
++++ openjpeg-2.0.0/CMakeLists.txt
+@@ -171,6 +171,16 @@
+ endif()
+
+ #-----------------------------------------------------------------------------
++# pkgconfig support
++if(UNIX)
++ # install in lib and not share (see multi-arch note above)
++ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/lib/openjp2/libopenjp2.pc.cmake.in
++ ${CMAKE_CURRENT_BINARY_DIR}/libopenjp2.pc @ONLY)
++ install( FILES ${CMAKE_CURRENT_BINARY_DIR}/libopenjp2.pc DESTINATION
++ ${OPENJPEG_INSTALL_LIB_DIR}/pkgconfig )
++endif()
++
++#-----------------------------------------------------------------------------
+ # Compiler specific flags:
+ if(CMAKE_COMPILER_IS_GNUCC)
+ # For all builds, make sure openjpeg is std99 compliant:
+--- /dev/null
++++ openjpeg-2.0.0/src/lib/openjp2/libopenjp2.pc.cmake.in
+@@ -0,0 +1,13 @@
++prefix=@CMAKE_INSTALL_PREFIX@
++bindir=${prefix}/@OPENJPEG_INSTALL_BIN_DIR@
++mandir=${prefix}/@OPENJPEG_INSTALL_MAN_DIR@
++docdir=${prefix}/@OPENJPEG_INSTALL_DOC_DIR@
++libdir=${prefix}/@OPENJPEG_INSTALL_LIB_DIR@
++includedir=${prefix}/@OPENJPEG_INSTALL_INCLUDE_DIR@
++
++Name: openjp2
++Description: JPEG2000 library (Part 1 and 2)
++URL: http://www.openjpeg.org/
++Version: @OPENJPEG_VERSION@
++Libs: -L${libdir} -lopenjp2
++Cflags: -I${includedir}