summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-03-30 07:29:31 +0200
committerSam James <sam@gentoo.org>2021-05-04 22:02:16 +0000
commit1bbe14fe858980251f702b71491303041623014b (patch)
treec25fb60f8e867a5619e980006dbaa19702443786 /media-libs/openexr
parentdev-libs/imath: new package (diff)
downloadgentoo-1bbe14fe858980251f702b71491303041623014b.tar.gz
gentoo-1bbe14fe858980251f702b71491303041623014b.tar.bz2
gentoo-1bbe14fe858980251f702b71491303041623014b.zip
media-libs/openexr: bump to 3.0.1
Security fixes Bug: https://bugs.gentoo.org/776808 Closes: https://bugs.gentoo.org/776805 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/19964 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/openexr')
-rw-r--r--media-libs/openexr/Manifest1
-rw-r--r--media-libs/openexr/metadata.xml5
-rw-r--r--media-libs/openexr/openexr-3.0.1.ebuild65
3 files changed, 70 insertions, 1 deletions
diff --git a/media-libs/openexr/Manifest b/media-libs/openexr/Manifest
index bdbd8277f8a8..385bf371a3ce 100644
--- a/media-libs/openexr/Manifest
+++ b/media-libs/openexr/Manifest
@@ -1 +1,2 @@
DIST openexr-2.5.5.tar.gz 27536865 BLAKE2B d0c0b2fd39b2cfafb60b6d0de3960063ff62341cf22be519f874c0c83f05cb604c5d503bb8b88514c71c5a54a79afa80a7fd00c2df15ec2193f6b3cffdc117c6 SHA512 e511af26a8fe2175a641fd25d2dcc6ef807e00bee2aff06a4784125f916ffd47fe376fe0621d385b604180a239bbfee063f8ceee3f7b731fde3c38558e9fdcdf
+DIST openexr-3.0.1.tar.gz 25059445 BLAKE2B 76bce1ff830b5e32362bfaf91d39945add171c5c1f453968b2fa8ba41e0996064d3a104eb7759cea87477e96e8a52d548743c7d83f5c6131dd38aecdd47bd6dd SHA512 e450c55d150e4c0a8a9147f78fe1c73ea9134976444f8c77c832d0671d4c3796f96fee74d23f26cdb9383e658a33d6d57c989e9207d1edfc8556ad688ff25a5b
diff --git a/media-libs/openexr/metadata.xml b/media-libs/openexr/metadata.xml
index 470947824a26..37c6bc8c8117 100644
--- a/media-libs/openexr/metadata.xml
+++ b/media-libs/openexr/metadata.xml
@@ -13,8 +13,11 @@
<email>media-video@gentoo.org</email>
</maintainer>
<use>
+ <flag name="large-stack">
+ Enables code to take advantage of large stack support.
+ </flag>
<flag name="utils">
- Build several utility binaries for verifying and manipulating EXR files.
+ Build several binary tools for verifying and manipulating EXR files.
</flag>
</use>
<upstream>
diff --git a/media-libs/openexr/openexr-3.0.1.ebuild b/media-libs/openexr/openexr-3.0.1.ebuild
new file mode 100644
index 000000000000..90b1ee500f02
--- /dev/null
+++ b/media-libs/openexr/openexr-3.0.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib flag-o-matic toolchain-funcs
+
+DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
+HOMEPAGE="https://www.openexr.com/"
+SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+#S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0/27" # based on SONAME
+# imath needs keywording: arm{,64}, hppa, ia64, ppc{,64}, sparc, x64-macos, x86-solaris
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="cpu_flags_x86_avx doc examples large-stack static-libs utils test threads"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !media-libs/ilmbase
+ dev-libs/imath:=
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CHANGES.md GOVERNANCE.md PATENTS README.md SECURITY.md docs/SymbolVisibility.md )
+
+#src_prepare() {
+ # Fix path for testsuite
+# sed -i -e "s:/var/tmp/:${T}:" "${S}"/IlmImfTest/tmpDir.h || die "failed to set temp path for tests"
+
+# if use abi_x86_32 && use test; then
+# eapply "${FILESDIR}/${PN}-2.5.2-0001-IlmImfTest-main.cpp-disable-tests.patch"
+# fi
+
+# multilib_foreach_abi cmake_src_prepare
+#}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DBUILD_TESTING=$(usex test)
+ -DOPENEXR_BUILD_UTILS=$(usex utils)
+ -DOPENEXR_ENABLE_LARGE_STACK=$(usex large-stack)
+ -DOPENEXR_ENABLE_THREADING=$(usex threads)
+ -DOPENEXR_INSTALL_EXAMPLES=$(usex examples)
+ -DOPENEXR_INSTALL_PKG_CONFIG=ON
+ -DOPENEXR_INSTALL_TOOLS=$(usex utils)
+ -DOPENEXR_USE_CLANG_TIDY=OFF # don't look for clang-tidy
+ )
+
+ cmake_src_configure
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ DOCS+=( docs/*.pdf )
+ fi
+ einstalldocs
+
+ use examples && docompress -x /usr/share/doc/${PF}/examples
+}