summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libiptcdata
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libiptcdata')
-rw-r--r--media-libs/libiptcdata/Manifest1
-rw-r--r--media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild51
-rw-r--r--media-libs/libiptcdata/libiptcdata-1.0.4.ebuild78
-rw-r--r--media-libs/libiptcdata/metadata.xml22
4 files changed, 152 insertions, 0 deletions
diff --git a/media-libs/libiptcdata/Manifest b/media-libs/libiptcdata/Manifest
new file mode 100644
index 000000000000..7795444b40b2
--- /dev/null
+++ b/media-libs/libiptcdata/Manifest
@@ -0,0 +1 @@
+DIST libiptcdata-1.0.4.tar.gz 569132 SHA256 79f63b8ce71ee45cefd34efbb66e39a22101443f4060809b8fc29c5eebdcee0e SHA512 8656b2febaec133d1a8783252047672bebd58ae9ceab5477c4acfa35bcc381dfda08b655a957b962878af28c69deff77d920e780c84b4debdff2f980b3de94e8 WHIRLPOOL c97e9c5566840e5e0ecede481650b91108b047d0324b9260d5083d46e55f0bfe71bf6d91d504fcc59f374dd77a0818397fed87ca8b73ecf0bfe769d43fa2348a
diff --git a/media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild b/media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..d4ff52684d75
--- /dev/null
+++ b/media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="library for manipulating the International Press Telecommunications
+Council (IPTC) metadata"
+HOMEPAGE="http://libiptcdata.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples nls python"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.13.1 )
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure () {
+ econf \
+ $(use_enable nls) \
+ $(use_enable python) \
+ $(use_enable doc gtk-doc)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed."
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/python
+ doins python/README || die "doins failed"
+ doins -r python/examples || die "doins 2 failed"
+ fi
+
+ find "${D}" -name '*.la' -delete || die "failed to remove *.la files"
+}
diff --git a/media-libs/libiptcdata/libiptcdata-1.0.4.ebuild b/media-libs/libiptcdata/libiptcdata-1.0.4.ebuild
new file mode 100644
index 000000000000..391569f4f0c0
--- /dev/null
+++ b/media-libs/libiptcdata/libiptcdata-1.0.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+
+inherit eutils python
+
+DESCRIPTION="library for manipulating the International Press Telecommunications
+Council (IPTC) metadata"
+HOMEPAGE="http://libiptcdata.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86"
+IUSE="doc examples nls python"
+
+RDEPEND="python? ( =dev-lang/python-2* )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.13.1 )
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Python bindings are built/tested/installed manually.
+ sed -e '/SUBDIRS =/s/$(MAYBE_PYTHONLIB)//' -i Makefile.in || die "sed failed"
+}
+
+src_configure () {
+ econf \
+ $(use_enable nls) \
+ $(use_enable python) \
+ $(use_enable doc gtk-doc)
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources python
+ building() {
+ emake PYTHON_CPPFLAGS=-I$(python_get_includedir) \
+ pyexecdir=$(python_get_sitedir)
+ }
+ python_execute_function -s --source-dir python building
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" pyexecdir=$(python_get_sitedir) install
+ }
+ python_execute_function -s --source-dir python installation
+ python_clean_installation_image
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed."
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/python
+ doins python/README || die "doins failed"
+ doins -r python/examples || die "doins 2 failed"
+ fi
+
+ find "${D}" -name '*.la' -delete || die "failed to remove *.la files"
+}
diff --git a/media-libs/libiptcdata/metadata.xml b/media-libs/libiptcdata/metadata.xml
new file mode 100644
index 000000000000..c35be40d2130
--- /dev/null
+++ b/media-libs/libiptcdata/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+ </maintainer>
+ <longdescription lang="en">
+ libiptcdata is a library, written in C, for manipulating the
+ International Press Telecommunications Council (IPTC) metadata stored
+ within multimedia files such as images. This metadata can include
+ captions and keywords, often used by popular photo management
+ applications. The library provides routines for parsing, viewing,
+ modifying, and saving this metadata. The library is licensed under the
+ GNU Library General Public License (GNU LGPL). The libiptcdata package
+ also includes a command-line utility, iptc, for editing IPTC data in
+ JPEG files, as well as Python bindings.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">libiptcdata</remote-id>
+ </upstream>
+</pkgmetadata>