summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <listout@protonmail.com>2022-11-02 11:16:36 +0530
committerMart Raudsepp <leio@gentoo.org>2022-11-20 18:12:28 +0000
commit99857f45011b1da80a5fc0ec73050dec67c65d35 (patch)
treeb65eb27a4f21bd0d77606696f383ff49c467bd9b /media-libs/gstreamer
parentpackage.mask: Stop last rite of media-libs/libvisual for now (diff)
downloadgentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.tar.gz
gentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.tar.bz2
gentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.zip
media-libs/gstreamer: Version bump to 1.20.4
Closes: https://bugs.gentoo.org/877325 Signed-off-by: brahmajit das <listout@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/28086 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-libs/gstreamer')
-rw-r--r--media-libs/gstreamer/Manifest1
-rw-r--r--media-libs/gstreamer/gstreamer-1.20.4.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/media-libs/gstreamer/Manifest b/media-libs/gstreamer/Manifest
index e185260f4ba3..811752c446bc 100644
--- a/media-libs/gstreamer/Manifest
+++ b/media-libs/gstreamer/Manifest
@@ -1,2 +1,3 @@
DIST gstreamer-1.20.2.tar.xz 2677552 BLAKE2B 0e6a818fd900c4f0c2748f15262e1d166755e3c419dfa04d7fc4a434ad9a84474d0eb43b9cf0286008497d7ff3e5340b737aeafc45d2994d7c713d5a12e3e2e3 SHA512 994378b656fa593e134624d5d4d5014e78074199d80152eafce29bc09864bd6d0f32a31eafda6cb8caec60aa85b0bda7c42a8c3b388b47d59f2cf4bc729d551f
DIST gstreamer-1.20.3.tar.xz 2681088 BLAKE2B 423669ff2224cc5d9b979a1353eb1dbcaea5dacca374e83630abf23574f813cbecf5144cdd3209f638aeb50e6764004c3d8020db7f11b21726a9f4b56b513d10 SHA512 e93f9fbf2d7a839dcbe2030ed16dd53eb250741db7c2f1cea396c23e4fabf9a0caff6be4babf7c10aec4b56dc8319a970b1b0bfa6eea2e36aed3e6e1265d9278
+DIST gstreamer-1.20.4.tar.xz 2686324 BLAKE2B b54da03f93f0062df0ada5534f3eff8a37e4b41f404b4bdd466bb6371e3db61a40741d723392bcc7cf7f46cded26c5d8ca625748670ac98daec136b0fb76a810 SHA512 33ba08e67b21a3e2e5dc5caeeae66e561b9d64ae863331a209e711f60a652ba38635e8bb963336e73b9afd5cf38e17139fbf933ca621d040f0d6e22a18ba7ad8
diff --git a/media-libs/gstreamer/gstreamer-1.20.4.ebuild b/media-libs/gstreamer/gstreamer-1.20.4.ebuild
new file mode 100644
index 000000000000..c44deb5aeb41
--- /dev/null
+++ b/media-libs/gstreamer/gstreamer-1.20.4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gstreamer-meson pax-utils
+
+DESCRIPTION="Open source multimedia framework"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+caps +introspection +orc unwind"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2[${MULTILIB_USEDEP}]
+ caps? ( sys-libs/libcap[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+ unwind? (
+ >=sys-libs/libunwind-1.2_rc1[${MULTILIB_USEDEP}]
+ dev-libs/elfutils[${MULTILIB_USEDEP}]
+ )
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ sys-devel/bison
+ sys-devel/flex
+"
+
+DOCS=( AUTHORS ChangeLog NEWS MAINTAINERS README.md RELEASE )
+
+PATCHES=(
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbenchmarks=disabled
+ -Dexamples=disabled
+ -Dcheck=enabled
+ $(meson_feature unwind libunwind)
+ $(meson_feature unwind libdw)
+ )
+
+ if use caps ; then
+ emesonargs+=( -Dptp-helper-permissions=capabilities )
+ else
+ emesonargs+=(
+ -Dptp-helper-permissions=setuid-root
+ -Dptp-helper-setuid-user=nobody
+ -Dptp-helper-setuid-group=nobody
+ )
+ fi
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install() {
+ # can't do "default", we want to install docs in multilib_src_install_all
+ DESTDIR="${D}" eninja install
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}/usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}/usr/bin/gst-launch-${SLOT}"
+}