summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-27 18:11:01 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-03 18:14:09 -0700
commit024bf55aa08e0a7f8448075412930230813e460d (patch)
tree33b1f159c8277fbf6635af86a977e04ae2934dff /media-libs/graphene
parentmedia-libs/dav1d: Switch to meson-multilib (diff)
downloadgentoo-024bf55aa08e0a7f8448075412930230813e460d.tar.gz
gentoo-024bf55aa08e0a7f8448075412930230813e460d.tar.bz2
gentoo-024bf55aa08e0a7f8448075412930230813e460d.zip
media-libs/graphene: Switch to meson-multilib
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/graphene')
-rw-r--r--media-libs/graphene/graphene-1.10.6.ebuild18
1 files changed, 3 insertions, 15 deletions
diff --git a/media-libs/graphene/graphene-1.10.6.ebuild b/media-libs/graphene/graphene-1.10.6.ebuild
index 50207695d8cd..ab7fb554651e 100644
--- a/media-libs/graphene/graphene-1.10.6.ebuild
+++ b/media-libs/graphene/graphene-1.10.6.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
-inherit xdg-utils meson multilib-minimal python-any-r1
+inherit xdg-utils meson-multilib python-any-r1
DESCRIPTION="A thin layer of types for graphic libraries"
HOMEPAGE="https://ebassi.github.io/graphene/"
@@ -34,9 +34,9 @@ BDEPEND="
multilib_src_configure() {
# TODO: Do we want G_DISABLE_ASSERT as buildtype=release would do upstream?
local emesonargs=(
- -Dgtk_doc=$(multilib_native_usex doc true false)
+ $(meson_native_use_bool doc gtk_doc)
-Dgobject_types=true
- -Dintrospection=$(multilib_native_usex introspection enabled disabled)
+ $(meson_native_use_feature introspection)
-Dgcc_vector=true # if built-in support tests fail, it'll just not enable vector intrinsics; unfortunately this probably means disabled on clang too, due to it claiming to be <gcc-4.9
$(meson_use cpu_flags_x86_sse2 sse2)
$(meson_use cpu_flags_arm_neon arm_neon)
@@ -45,15 +45,3 @@ multilib_src_configure() {
)
meson_src_configure
}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_test() {
- meson_src_test
-}
-
-multilib_src_install() {
- meson_src_install
-}